Cannot delete,move mail messages

Discussion in 'Windows Vista Mail' started by BobC, Jan 26, 2007.

  1. BobC

    BobC Guest

    A "first" for me; I have been using Vista since8/05 ,yesterday a spam
    message came in to the inbox,it was deleted,however,it is still in the
    inbox; in addition,2 other messages ,which are not spam,cannot be
    viewed,deleted,etc.Windows Mail message "an unexpected error has occured
    "etc.
    I have been in the message store folder,a "wildcard" search for eml
    files.deleted everything in the deleted folder,and sent feedback to MS.
    I can send and receive new mail(my own to test) ,but would like to get the
    problem rectified.
    Any ideas would be appreciated.
    TIA
     
    BobC, Jan 26, 2007
    #1
    1. Advertisements

  2. Try compacting the database. Go to Tools | Options | Advanced | Maintenance
    and set the compaction threshold to 1. Then close WinMail and let it
    compact. (set that value back to 100 after that). See if that fixes it.

    steve
     
    Steve Cochran, Jan 26, 2007
    #2
    1. Advertisements

  3. BobC

    BobC Guest

    My recollection is I did compact the database,and did the same again
    ,twice; still have the same problem.
    Guess I will have to put up with the 3 files; strange thing,the 2 messages
    prior to the spam cannot be moved,deleted,etc.
    Thanks for your reply!!
     
    BobC, Jan 26, 2007
    #3
  4. BobC

    BobC Guest

    My recollection is I did compact the database,and did the same again
    ,twice; still have the same problem.
    Guess I will have to put up with the 3 files; strange thing,the 2 messages
    prior to the spam cannot be moved,deleted,etc.
    Thanks for your reply!!
     
    BobC, Jan 26, 2007
    #4
  5. BobC

    BobC Guest

    Sorry for the "duplicate" message; Mail has some problems<g>
     
    BobC, Jan 26, 2007
    #5
  6. BobC

    Tom Lake Guest

    I had the same problem with one message. Eventually (a matter of weeks) it
    disappeared on its own.

    Tom Lake
     
    Tom Lake, Jan 26, 2007
    #6
  7. BobC

    BobC Guest

    Thanks Tom,"Patiently waiting" <BG>
     
    BobC, Jan 26, 2007
    #7
  8. Check your database with esentutl.exe /p <database_name> command.
    You'll be get more options with esentutl.exe /?.

    Michal Kawecki [MS-MVP]
    Warsaw, PL
     
    Michal Kawecki, Jan 26, 2007
    #8
  9. Try using the esentutl to repair the database. Others indicated it worked.

    From an earlier post:
     
    Steve Cochran, Jan 26, 2007
    #9
  10. BobC

    BobC Guest

    To Michael and Steve;
    Still working on the "esentutl" fix; I "cut my teeth" on Dos many years
    ago,but this utility is giving me a "fit";
    Thanks to each of you!
     
    BobC, Jan 27, 2007
    #10
  11. BobC

    BobC Guest

    Well,to furthur "confuse the issue" ,there are no emails in the
    users\me\appdata\local\microsoft\windows mail ...inbox ,yet,still have
    emails in the inbox in the mail window:IMHO ,I believe there is a bug in the
    system,so will continue working on it,perhaps,one of the MS folks will start
    monitoring the forum.
    Tks again!

     
    BobC, Jan 27, 2007
    #11
  12. The problem is the database, so ignore the fact there are no messages in the
    folder.

    The utility is very easy.

    Right click on the cmd prompt and then choose Run as Administrator.

    Then you can copy this from Windows and paste into the Command window

    esentutl /p "c:\users\BobC\appdata\local\microsoft\windows
    mail\windowsmail.msmessagestore"

    Then edit the BobC to reflect the correct user name.

    That's all you have to do.

    steve



     
    Steve Cochran, Jan 27, 2007
    #12
  13. BobC

    BobC Guest

    Yep,it is "easy to use" however.havng run the utility many times,I receive
    the following message:
    Jet error-1032 <Jet-err File access denied,cannot access the file,the file
    is locked,or in use>after 30.63 seconds.
    I have used the utility on line,off line,no browser,with browser,no
    email,etc.
    Same message,any ideas on the error message would be appreciated.

     
    BobC, Jan 27, 2007
    #13
  14. BobC

    BobC Guest

    Steve,latest "error" message,when running from root,"cannot find file
    "windowsmail.msmessagestore"
    I saw this error message sever times last evening,that is when I posted IMHO
    a system bug.
    I have taken a lot of you time,which I apologize for,and really appreciate
    it!
    Other than using "attrib',which I haven't done, and really should not be
    needed,I suppose I will have to continue loking ate 3 messages in the inbox.
    Thanks again for you interest and expertise.

     
    BobC, Jan 27, 2007
    #14
  15. BobC

    BobC Guest

    Got it fixed!!
    Finally "bit the bullet" and moved the msmessage store file which the
    "esentutl" utility could not find,deketed the "original" restarted
    Winmail,new msmessage store file was created!
    Thanks to each of you who assisted me!
     
    BobC, Jan 27, 2007
    #15
  16. You have to tell it the full path (enclosed in quotes) to the message store
    file, which I suspect you didn't do.

    Also, it sounds as if you tried to run the utility with WinMail still open
    (or running) and so that's why you got the permissions error.

    Anyway, wiping the database will certainly fix things, but that's sort of
    overkill.

    cheers,

    steve

     
    Steve Cochran, Jan 28, 2007
    #16
  17. BobC

    BobC Guest

    Yes,ran it with full quotes; in the directory tree,"msmessage store" is the
    last file on the tree,there were several folders such as Avast,Money,Adobe
    ,etc before the msmessage store,the utility times out before it went to the
    message store file.
    Thanks
     
    BobC, Jan 28, 2007
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.