Cannot fix corrupted registry value: The handle is invalid error.

Discussion in 'Windows Vista Security' started by memoconq, Jun 3, 2009.

  1. memoconq

    memoconq Guest

    I'm trying to install SQL Server Express 2008 using Web Platform Express 2008
    installer (2.0 beta) on Windows Vista Ultimate SP1 (all updates installed),
    but it fails. I searched for the reason, and found that the values in the
    following registry key is corrupted:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\009

    Counter and Help values cannot include empty lines, but there is an empty
    line at the end of them. When I tried to delete that line, following error

    Error editing value - Cannot edit counter: Error writing the value's new

    When I tried to change permissions to full for that key, following error

    Windows security - Unable to save permission changes on 009. The handle is

    Same error occurs when I try to change ownership, too. I tried using
    subinacl tool, too. But same error occurs: RegSetKeySecurity Error : 6 The
    handle is invalid

    I'm using the windows as a domain user with some group policies at work. But
    I install software with my local user account with full administrator rights
    without any problem until now. I tried lots of solutions of simular issues.
    Is there a way to fix this issue without formatting and reinstalling the
    memoconq, Jun 3, 2009
    1. Advertisements

  2. Step one of any trouble shooting process would be to eliminate any none
    standard items.
    So the obvious question -- Do you get the same error when not using a BETA
    product to drive the installs? or have you not bothered with that yet?
    Also what do you mean by not being allowed an empty line at he end of the
    counter reg value?
    Looking at mine (which does have SQL Express 2008 and more installed) when
    you click on the reg item to edit the values are highlighted in blue and the
    cursor is placed two lines/carriage returns after the last entry on each
    one. These are not real empty lines as they would appear as a blue bar in a
    Multi-String typed reg value - so this is normal behavior. All the errors
    you see when trying to remove the 2 "carriage returns" in both values are
    completely normal and not a corruption in the registry.

    So I think your problem lie elsewhere - so as I said step one don't use a
    Beta installer and try the real package.
    Ensure you have sufficient permissions to perform the install.
    Mike Brannigan, Jun 3, 2009
    1. Advertisements

  3. memoconq

    memoconq Guest

    Yes, after I posted my question, I saw in anotyher post that says value
    should end with double null characters.

    When trying a solution, I created a key with a different name, and copied
    the values to the same values in that key. When I clicked OK, it said the
    value cannot include empty lines and it will clean the empty lines. Then I
    looked at the values and there is one empty line et the end. So I thought the
    other key is corrupted, but I was wrong.

    I will unistall and reinstall with version 1 of the installer. I hope it
    memoconq, Jun 3, 2009
  4. memoconq


    Dec 24, 2010
    Likes Received:
    Hi, guys. I got same problem with you. I bought my Dell inspiron last Christmas. It worked sharp at the first few months, but got slow after that. It took about 15 mins to start up. I can even walk away and brew my coffee during waiting! I even thought about reinstall my computer! My friend recommended the software tuneup360 and Norton systemwork. I tried both. Norton did look really powerful and could do lots of thing, but it was too difficult for me and too expensive, while Tuneup360 is my type. I just need to click one big “fix now” button and get my computer fixed. Now my computer takes only 30 sec to start up.
    jolin, Dec 28, 2010
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.