cannot install vista sp1

Discussion in 'Windows Vista Help' started by Pedro, Nov 25, 2011.

  1. Pedro

    Pedro Guest

    Hello friends,
    I've a windows vista x86 os installed on my system (4GB RAM). The problem
    is that when trying to install vista service pack 1 on or off-line
    instalations, the system stays for many many hours in an indefinite loop or
    eventually crashing but never finishing installation. I can get no other
    windows updates except for the windows defender ones. Can anybody, please
    help me with this problem?

    Thanks in advance,
    Pedro
     
    Pedro, Nov 25, 2011
    #1
    1. Advertisements

  2. Pedro

    ceej Guest

    If you have IE9 then remove this and go back to IE8 and try again.
     
    ceej, Nov 25, 2011
    #2
    1. Advertisements

  3. Pedro

    housetrained Guest

    Hello friends,
    I've a windows vista x86 os installed on my system (4GB RAM). The problem
    is that when trying to install vista service pack 1 on or off-line
    instalations, the system stays for many many hours in an indefinite loop or
    eventually crashing but never finishing installation. I can get no other
    windows updates except for the windows defender ones. Can anybody, please
    help me with this problem?

    Thanks in advance,
    Pedro
    run a virus ridder first - find out if you have unwanted guf on your
    computer. then try

    If you have trouble installing Windows Vista SP1 on your Vista Computer,
    here are some suggestions:

    To work around installation problems, perform the following steps in the
    specified order:

    1. Ensure that you have enough disk space. Then restart the computer and try
    to install SP1 again. This will ensure that all files are synchronized
    properly.

    2. If the installation still fails, open an elevated Command Prompt window,
    and then run chkdsk /f. The Chkdsk tool checks the file system and metadata
    for errors, and then it fixes the errors, if possible. Then try to install
    SP1 again.

    3. If the installation still fails, open an elevated Command Prompt window,
    and then run SFC /scannow. The System File Checker tool scans all protected
    files to verify their versions, and then it updates these files, if
    possible. Then try to install SP1 again.

    4. If the installation still fails, open an elevated Command Prompt window,
    and then run MdSched.exe. The Windows Memory Diagnostic tool tests the
    Random Access Memory (RAM) on your computer for errors. Then try to install
    SP1 again.

    5. If the installation still fails, download and extract the KB947821 update
    from the Microsoft Download Center. The Windows6.0-KB947821-XXX.msu file
    will ensure that the computer is ready to be updated. Then try to install
    SP1 again.

    "Pedro" wrote in message news:jao7t6$ilj$...
     
    housetrained, Nov 25, 2011
    #3
  4. Pedro

    Pedro Guest

    "Pedro" wrote in message
    Hello friends,
    I've a windows vista x86 os installed on my system (4GB RAM). The problem
    is that when trying to install vista service pack 1 on or off-line
    instalations, the system stays for many many hours in an indefinite loop or
    eventually crashing but never finishing installation. I can get no other
    windows updates except for the windows defender ones. Can anybody, please
    help me with this problem?

    Thanks in advance,
    Pedro

    Thank you very much for your answers. I have installed avast antivirus which
    finds nothing. I also have installed malwarebytes antimalware which also
    does not find anything bad. I'll try to uninstall ie9 and will let you all
    know what happens.

    Pedro
     
    Pedro, Nov 25, 2011
    #4
  5. Pedro

    Pedro Guest

    "Pedro" wrote in message


    "Pedro" wrote in message
    Hello friends,
    I've a windows vista x86 os installed on my system (4GB RAM). The problem
    is that when trying to install vista service pack 1 on or off-line
    instalations, the system stays for many many hours in an indefinite loop or
    eventually crashing but never finishing installation. I can get no other
    windows updates except for the windows defender ones. Can anybody, please
    help me with this problem?

    Thanks in advance,
    Pedro

    Thank you very much for your answers. I have installed avast antivirus which
    finds nothing. I also have installed malwarebytes antimalware which also
    does not find anything bad. I'll try to uninstall ie9 and will let you all
    know what happens.

    Pedro

    Tried uninstalling ie9 and reverting to previous version but the problem
    with windows updates persists

    Has anybody any other possible solution?

    Thanks all,
    Pedro
     
    Pedro, Nov 26, 2011
    #5
  6. Pedro

    Jolly polly Guest

    What error is thrown up? exactly!
    What is the (exact) name of the file you have downloaded as SP1?
     
    Jolly polly, Nov 26, 2011
    #6
  7. Pedro

    Pedro Guest

    "Jolly polly" wrote in message

    What error is thrown up? exactly!
    What is the (exact) name of the file you have downloaded as SP1?

    The exact error message says:
    An internal error ocurred while installing the service pack
    0x8007000D See http://go.microsoft.com/fwlink/?Linkld=101139 for details.

    I remember long ago having visited this page and checked the posible causes
    and solutions it offered with no success solving this problem

    the exact file name I have downloaded as service pack 1 is
    Windows6.0-KB936330-X86-wave0.exe

    Thanks,
    Pedro
     
    Pedro, Nov 27, 2011
    #7
  8. Pedro

    Pedro Guest

    testing...

    "Pedro" wrote in message


    "Jolly polly" wrote in message

    What error is thrown up? exactly!
    What is the (exact) name of the file you have downloaded as SP1?

    The exact error message says:
    An internal error ocurred while installing the service pack
    0x8007000D See http://go.microsoft.com/fwlink/?Linkld=101139 for details.

    I remember long ago having visited this page and checked the posible causes
    and solutions it offered with no success solving this problem

    the exact file name I have downloaded as service pack 1 is
    Windows6.0-KB936330-X86-wave0.exe

    Thanks,
    Pedro
     
    Pedro, Nov 29, 2011
    #8
  9. Pedro

    Jolly polly Guest

    Double check that your system is 32 bit first,
    then if you haven't tried it yet. try the System Update Readiness Tool
    (KB947821) (file = Windows6.0-KB947821-v4-x86.msu)
    have you also tried uninstalling your antivirus program, rebooting the
    system and trying to install the update, it might also be a good idea to get
    a fresh copy of SP1 (you have the correct package for 32bit Vista) incase
    there is a corruption in the one you have
     
    Jolly polly, Nov 29, 2011
    #9
  10. Pedro

    Pedro Guest

    "Jolly polly" wrote in message

    Double check that your system is 32 bit first,
    then if you haven't tried it yet. try the System Update Readiness Tool
    (KB947821) (file = Windows6.0-KB947821-v4-x86.msu)
    have you also tried uninstalling your antivirus program, rebooting the
    system and trying to install the update, it might also be a good idea to get
    a fresh copy of SP1 (you have the correct package for 32bit Vista) incase
    there is a corruption in the one you have

    All of that has been made. I tried the System update readiness tool,
    uninstalled antivirus, restarted the system, and then tried again to install
    sp1. the problem still persisted. i also downloaded twice the sp1,
    previously I cleared the web browser's cache so i would not get a copy of
    the previous download. No success until now.

    thanks,
    Pedro
     
    Pedro, Nov 29, 2011
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.