Cannot migrate Content and Approvals from SUS

Discussion in 'Update Services' started by Massimo Maffei, Jun 15, 2005.

  1. Hello

    I've tried to migrate local content and approvals from SUS installed on the
    same machine with the tool WSUSutil.exe.

    From the command line:

    wsusutil migratesus /content <cabspath> /approvals <SUSserver> /log
    <logfile>

    All the cabs (3,1 GB) were copied to the directories '
    C:\WSUS\WsusContent\xx' but in the console nothing appears.

    In the log file:

    .... Started migration of content from C:\Data\MSUpdate\cabs
    .... Content migration complete. 1069 files migrated
    .... Started migration of approved updates from SUS 1.0 server on iluvatar
    .... Warning: SUS 1.0 update
    "com_microsoft.328940_xp_rtm_winse_51283_critical" was not found on the WUS
    server
    .... <idem for all files>
    .... Approved update migration complete. 0 approvals migrated

    what's wrong ?
     
    Massimo Maffei, Jun 15, 2005
    #1
    1. Advertisements

  2. Observations during the beta were that this tool wasn't always reliable
    working in a one-pass process.

    There was some success by splitting it up into two steps,
    first the migration:
    wsusutil migratesus /content <cabspath> /log <logfile_part1>

    and then the approvals:
    wsusutil migratesus /approvals <SUSserver> /log <logfile_part2>

    However.. before you get caught up in a wholesale transfer of content and
    approvals from your SUS server -- consider the potential benefits of
    starting from scratch:
    (a) Only approve content on WSUS that you need to apply on top of your
    baseline installation image.
    (b) Since WSUS is configurable to only download approved content, you
    won't have to suck up space storing things like XP Service Pack 1 if you're
    never going to distribute it via WSUS.
     
    Lawrence Garvin, Jun 16, 2005
    #2
    1. Advertisements

  3. Massimo Maffei

    Guyza Guest

    I have the same prob
     
    Guyza, Jun 16, 2005
    #3
  4. Massimo Maffei

    lforbes Guest

    Hi,

    Go onto the WSUSAdmin for the WUS Server and synchronize. It will download
    the latest "list" with all being "detect now". When you change all the
    "Detect now" to "install" That is when it looks at the directory to see if
    the update is there or if it needs to be downloaded. If it is there, it
    doesn't download it.

    Cheers,

    Lara
     
    lforbes, Jun 16, 2005
    #4
  5. Massimo Maffei

    fdenio Guest

    I have a problem similar to the one at the start of this thread. I can
    migrqate the content but the approval log startes that "Error: Could not
    connect to the specified SUS 1.0 server". Migrating the content worked fine.

    If you do as stated below it would seem that all of the updates will now be
    approved and will then try to install.
     
    fdenio, Jun 21, 2005
    #5
  6. From the documentation, SUS-to-WSUS guide.. the approvals are obtained from
    the SUS server via HTTP, therefore the SUS server must be on an enabled and
    reachable web server to obtain approvals.

    Since the parameter in the wsusutil line is typically described as only a
    system name, then it's also necessary that the system name properly resolve
    via internal DNS to the SUS Server.
     
    Lawrence Garvin, Jun 22, 2005
    #6
  7. Massimo Maffei

    fdenio Guest

    Lawrence,

    You were right on the money. Used the DNS entry that points to SUS and it
    worked perfectly. I guess I didn't read the documentation carefully enough.

    Thanks for the help.
     
    fdenio, Jun 22, 2005
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.