Cannot print to a networked printer

Discussion in 'Windows Vista Printing / Faxing / Scanning' started by Bill, Jun 7, 2007.

  1. Bill

    Bill Guest

    I was able to install a networked printer to my Vista Ultima machine.
    However, when I try to print the test page, it reports "Test page failed to
    print. ... Operation could not be completed (error 0x0000007a)." FYI, I am
    able to print to the printer using another XP computer.

    Could you help me to solve the issue?

    Thanks,
     
    Bill, Jun 7, 2007
    #1
    1. Advertisements

  2. E:\>winerror 0x0000007a
    122 ERROR_INSUFFICIENT_BUFFER <--> 0xc0000023 STATUS_BUFFER_TOO_SMALL

    This issue has been hit previously but the poster never informed us what
    type of printer they have. What is yours?

    Can you setup a 'fake" printer on the XP machine that uses an inbox driver
    and successfully make a connection from the Vista machine?"

    --
    Alan Morris
    Windows Printing Team
    Search the Microsoft Knowledge Base here:
    http://support.microsoft.com/default.aspx?scid=fh;[ln];kbhowto

    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Alan Morris [MSFT], Jun 7, 2007
    #2
    1. Advertisements

  3. Bill

    Bill Guest

    Yes. I saw this previous post.

    The printer is Canon imageRUNNER 3300.

    I cannot conduct the test since my Vista machine cannot access the XP one.

    Thanks,


     
    Bill, Jun 7, 2007
    #3
  4. Bill

    Bill Guest

    OK. I find a way to circumvent the problem.

    Previously, I added the printer using \\servername\printername, which does
    not work.

    But the printer Canon imageRUNNER 3300 is connected to the network with its
    own IP. So I added the printer using its IP address. Now I can print to it
    successfully.



     
    Bill, Jun 7, 2007
    #4
  5. Bill

    jonawebb

    Joined:
    Jan 1, 2009
    Messages:
    1
    Likes Received:
    0
    Same problem with HP PhotoSmart D5460

    I'm getting the same problem with an HP Photosmart D5460 installed on a Windows XP machine. The PC I'm trying to print from is running Vista Home Premium and is an x64 box. The printer installs OK but nothing happens when I try to print a test page. After the first time or so I get the 0x0000007a message.
    I can't do the port manipulation suggested here on the Vista box because the Add Port button is grayed out there, even when I run Properties as Administrator (selecting Run as Administrator from the drop down menu.)
    I've contacted HP tech support but no progress there yet. Any ideas?
     
    jonawebb, Jan 1, 2009
    #5
  6. Bill

    djgobby

    Joined:
    Jan 25, 2011
    Messages:
    1
    Likes Received:
    0
    Resolution

    I realise this thread is now years old, but since I encountered a similar problem recently and managed to figure it out, I thought I'd post how I did it for anyone else that may run into the same issue.

    The printer was installed on a Windows XP Home Edition desktop PC and working correctly. I was trying to connect to the printer from a Windows 7 Home Premium (64bit) laptop.

    *WHERE I WENT WRONG*
    I navigated to the UNC path for the shared printer (e.g \\desktop\hpphoto), right clicked the printer and clicked "connect". This installed the printer fine and could see it's status and alter it's settings, but attempts to print would throw up the 0x0000007a error.

    This is because XP is using a different version of the driver which is not compatible with Windows 7 or perhaps in your case Vista. When you connect to a printer in this fashion, the host computer is supposed to supply the guest computer with the correct drivers, so long as they have been specified in the "additional drivers" section. Since it isn't possible to supply additional drivers for Vista or Windows 7 in XP, it seems to install the XP driver instead.

    *THE FIX*
    First, remove the broken printer from the computer that is throwing up the error (right clicking the printer and selecting remove device is fine). Now start the "Add Printer" wizard. You'll want to "Add a local printer", click next and create a new port of type "Local Port". When you click next you will be asked to name the port. You should name the port with the UNC address of the shared printer i.e \\computername\printersharename (\\desktop\hpphoto in my case)

    If the wizard accepts your UNC address you can then specify the correct drivers for you version of Windows, which can be downloaded from your printer manufacturer's website. If you are told that drivers are already on the system, choose to overwrite them since they are the drivers that were installed from XP in previous attempts to connect.

    When all is finished, printing should work normally. At least, it did for me. :)
     
    djgobby, Jan 25, 2011
    #6
  7. Bill

    patator

    Joined:
    Jun 23, 2011
    Messages:
    1
    Likes Received:
    0
    Hi,

    FYI: it worked for me too but the w7 user is not able to see the print queue on the server. Strangly, the print queue opened on the computer is not the one on the server and doesn't show any of the jobs in the server queue. All the jobs printed from the w7 computer do go on the server print queue, it is just the print queue opened localy on the w7 pc is forever empty, even if jobs are waiting on the server's.

    :confused:

    just to let you know.
     
    patator, Jun 23, 2011
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.