Cannot RDP to cluter IP when there are 2 RDP-TCP configured tscc.m

Discussion in 'Clustering' started by Mr555, Sep 15, 2008.

  1. Mr555

    Mr555 Guest

    Hi All

    Just doing some testing on NLB, I have setup 2 windows 2003 Server (TestA)
    and (TestB) Server. Each server has 2 NIC installed, each of these servers on
    NIC (1) I have enabled NLB. The cluster IP is 10.10.1.55. DNS name is
    nlbtest.test.com in the port rule we have allow port 80, 443 and 3389.

    Each NIC has its own IP adddress. for TestA server NIC 1 IP address is
    10.10.1.1 NIC 2 IP address is 10.10.1.2

    TestB server NIC 1 Ip is 10.10.1.3 and NIC2 IP is 10.10.1.4

    in TSCC.msc, we have created 2 connection . 1 is called admin the other one
    is called user.

    In User RDP-TCP connection > Network adapter tab > set to use NIC 1
    In Admin RDP-TCP connection. > Network adapter > set to use NIC 2

    in Admin RDP-TCP connection under permission I have remove Remote user group

    No if I go back to my workstation, open RDP. then type nlbtest , I receive
    the following error.
    This computer can't connect to the remote computer. try connecting again. If
    the problem continuesm contact the owner of the remote computer or you
    network administrator.

    If i remove 1 of the RDP-TCP connection under tscc.msc , in network adapter
    , if I set to "all network adapters configured with this protocol". it works

    I want to have 2 RDP-TCP connection enable is this possible

    Thank you
     
    Mr555, Sep 15, 2008
    #1
    1. Advertisements

  2. Hello Mr555,

    You can have only 2 concurrent connections on a TS in administration mode.
    So if you create two connections and then use a third connection from the
    client i t can not work. Or did i misunderstand your configuration?

    Best regards

    Meinolf Weber
     
    Meinolf Weber, Sep 16, 2008
    #2
    1. Advertisements

  3. Mr555

    Mr555 Guest

    Hi Meinolf

    At the moment we have 1 terminal server. 50 users is connecting to that
    server for their accountant work. we have 2 NIC installed to that terminal
    server. NIC 1 is for users and NIC 2 is for Admin. that is specify in
    tscc.msc RDP-TCP users connection. and ( i have configured 2 RDP-TCP
    connection) let say I want to stop user connect to the terminal server, all I
    have to do is disable NIC 1. it is working really well for us. The current
    terminal server is running out of resource. Want I am trying to achieve is to
    have 25 users connect to (Terminal Server 1) and the rest of the 25 users
    connect to (Terminal Servr 2)

    in my test Lab I enabled NLB on network card 1 to both of the terminal
    server to share the work load.

    I have created 2 RDP-TCP connection you (admin) and (user)

    (Admin) configured to use network card 2 (user) configured to use network
    card 1

    so if I want to stop user connect to terminal servrr 1 all i have to do is
    disable the NIC 1 on Terminal server1

    Is this the correct way to set it up

    Thank you













    thank you for your reply.. what I am trying to do is host some custom
    appliction
     
    Mr555, Sep 16, 2008
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.