Cannot register 32 bit DLL on W2008

Discussion in 'Windows Server' started by ThomasAJ, Aug 22, 2008.

  1. ThomasAJ

    ThomasAJ Guest

    I think I need to use regsvr32 in syswow64 to register a 32 bit dll:
    c:\Windows\syswow64\regsvr32.exe "C:\Program Files (x86)\Common
    Files\MSSoap\Binaries\MSSOAP30.DLL"

    It says the module failed to load etc.

    I also tried:
    regsvr32.exe "C:\Program Files (x86)\Common
    Files\MSSoap\Binaries\MSSOAP30.DLL"

    Same error message.

    I am installing a program that needs MSSOAP30.DLL
     
    ThomasAJ, Aug 22, 2008
    #1
    1. Advertisements

  2. You need to use "Run as administrator". If you run the command at a command
    prompt, launch the command prompt by right clicking a shortcut to cmd.exe
    and selecting "Run as administrator". If the regsvr32 statement is in a
    program, like a batch file, right click the program and select "Run as
    administrator".
     
    Richard Mueller [MVP], Aug 22, 2008
    #2
    1. Advertisements

  3. ThomasAJ

    ThomasAJ Guest

    I ran the above commands as you said. Same error message every time.

    I also had the same problem registering another DLL using REGSVR32.EXE. So I
    tracked down that DLL's installer from the DLL's website and the installer
    installed the DLL.

    So the MSSOAP30.DLL is unlikely to be at fault (it currently runs on Server
    2003 SP2) and it is almost definitely how I am running REGSVR32.EXE.

    Yes I am logged on as ADMINISTRATOR (thru TS) and am running CMD.EXE as 'Run
    as administrator'.
     
    ThomasAJ, Aug 23, 2008
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.