Cannot rip CDs to MP3 format with Media Player 10, Windows XP

Discussion in 'Windows Media Player' started by Alex L, Apr 8, 2006.

  1. Alex L

    Alex L Guest

    It looks like this is a fairly common problem, judging from prior questions.

    I downloaded Windows Media Player 10 about one month ago. I have just
    started to try and rip music from CDs to MP3 format, but get this error
    message:

    "Windows Media Player cannot rip the track because a compatible MP3 encoder
    is not installed on your computer. Install a compatible MP3 encoder or choose
    a different format to rip to (such as Windows Media Audio)."

    For some reason, the only setting that would rip properly into MP3 format
    was 56 kbps.

    (B) I then went to the Microsoft Help Center, where I came across this:

    " There may be a problem with a registry setting on your computer that is
    preventing Windows Media Player 10 from ripping into the MP3 format at a
    quality setting of 128 Kbps. You can switch to a different quality setting,
    or you can delete the registry setting if you prefer to use the 128 Kbps
    setting.

    In Registry Editor, click the following registry key:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MediaPlayer\Settings\Mp3Encoding
    In the pane on the right, right-click the LowRateSample value, and then
    click Delete."

    (C) I deleted the LowRateSample from my registry, as suggested above. Now, I
    cannot rip into MP3 in any format. I get an error for all MP3 settings,
    including the previously working 56 kbps.

    (D) Going through my registry, my PreferredCodecPath is l3codeca.acm, which
    apparently is an error according to zachd

    I am a bit of a novice, so I would need slow, step by step guidance on how
    to correct this problem.

    Thanks!
     
    Alex L, Apr 8, 2006
    #1
    1. Advertisements

  2. Alex L

    AE Guest

    I second that motion!
    I have the exact problem, and did the exact same thing, and don't know what
    to do.
     
    AE, Apr 8, 2006
    #2
    1. Advertisements

  3. Alex L

    Alex L Guest

    I managed to fix the problem. I changed my PreferredCodecPath from
    l3codeca.acm to l3codecp.acm in the Registry Editor, which is what zachd
    recommended in an earlier post. Everything is working fine now.
     
    Alex L, Apr 8, 2006
    #3
  4. Alex L

    AE Guest

    Thank you so very very very much.

    That worked.
     
    AE, Apr 8, 2006
    #4
  5. Alex L

    Alex L Guest

    Okay, now I can rip to MP3 format, but now I can't sync the MP3 files to my
    MP3 player. *sigh* one problem after another.

    Does anyone know if changing the PreferredCodecPath from
    l3codeca.acm to l3codecp.acm in the Registry Editor is causing the problem?
     
    Alex L, Apr 9, 2006
    #5
  6. Alex L

    zachd [MSFT] Guest

    It shouldn't.
    What's the error in that context? Was it working previously?
     
    zachd [MSFT], Apr 9, 2006
    #6
  7. Alex L

    Alex L Guest

    (1) At first, I could only rip to MP3 with the 56 kbps setting, and had no
    problems syncing to my MP3 player.

    (2) I then deleted the LowRateSample from the registry. After that, I could
    not rip to MP3 at ANY setting, including the previously working 56 kbps.

    (3) I then changed my PreferredCodecPath from l3codeca.acm to l3codecp.acm.
    After that, I can rip to MP3 with any setting.

    (4) However, now I can't sync to my MP3 player. I even tried syncing some
    non-protected "preloaded" songs that came with WMP 10, which I assume would
    be properly formatted.

    (5) The error message I receive when trying to sync is:

    "WMP cannot play the file. If the file is on another computer, verify you
    are connected to the network. If you typed a path, verify that it is correct.
    If the problem persists, the server may not be available. "

    When I click "more information," it says Error Code C00D1197 Cannot play the
    file," with more information popping up.

    Any help appreciated, thanks!
     
    Alex L, Apr 10, 2006
    #7
  8. Alex L

    zachd [MSFT] Guest

    Is there any correlation between those data points? That is: if you reverse
    the steps can you get syncing working again...? I can help with ripping to
    some extent, but syncing you're probably better off talking to actual
    product support-
    http://zachd.com/pss/pss.html#psssupport
    since I don't keep track of the various firmware updates and etc that
    vendors are putting out. =\

    -Zach
    --
    Windows Media Development Team (speaking for myself only)
    See http://zachd.com/pss/pss.html for some helpful WMP info.
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Now Playing: "MILK BATTLE3 mix" by "Dan the Swede and Steve Bloodbath" in
    WMP10.
     
    zachd [MSFT], Apr 14, 2006
    #8
  9. Alex L

    Lord Skudley Guest

    Say What??? I have this same problem and I don't understand this solution.
    Please asume I have no clue as to what "PreferredCodecPath" means or what a
    Registry Editor is and explane it in layman terms.
     
    Lord Skudley, Jun 25, 2006
    #9
  10. Alex L

    zachd [MSFT] Guest

    In that case, reinstalling the player likely would be a good option for you.
    I believe that should fix it up. If not-
    http://zachd.com/pss/pss.html#mp3encode
    is the data which you might ask a friend to translate. =)
     
    zachd [MSFT], Jun 28, 2006
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.