Cannot save configuration because the server is still processinga previous configuration change

Discussion in 'Update Services' started by Robert Hindla, Sep 6, 2005.

  1. Having recently installed WSUS, I was very pleased with it . . . Until I hit
    my first error. I tried to change from manual to automatic synchronization,
    but when I reopened the console the next day, I was told to "please wait
    while your settings are saved." Restarting IIS and rebooting the server did
    not help.

    When I went to make another change, on another menu, I received "cannot save
    configuration because the server is still processing a previous
    configuration change."
     
    Robert Hindla, Sep 6, 2005
    #1
    1. Advertisements

  2. Robert, I encountered this issue today while doing some testing and
    research. While I don't think my scenario is similar to anybody elses (at
    the time I encountered it, I had just Disabled the BITS service), my 'fix'
    may well be relevant for anybody.

    I closed the WSUS Admin console, (would have stopped BITS, but it was
    already stopped), reset BITS back to Manual, and restarted the Update
    Services service, which also restarted BITS. Then reopened the WSUS Admin
    Console and the "settings are being saved" message was gone and
    functionality was returned.

    Rebooting the server should have accomplished the same thing, but perhaps
    there is something in the dependencies and sequencing of startup/shutdown of
    services that prevents it from resetting. It's also possible that simply
    restarting the Update Services service won't help -- but it's worth a
    shot -- as it did reset my one occurrence of the situation.
     
    Lawrence Garvin, Sep 7, 2005
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.