cannot schedule jobs except as administrator

Discussion in 'Windows Small Business Server' started by jim smith, Jun 20, 2007.

  1. jim smith

    jim smith Guest

    Just purchased 2 new Dell Optiplex desktops with XP Pro. After MS updates,
    attempted to schedule a job to run at logon. Signed on as Admin, the task
    created and when logging on as Admin, it works (launch Notepad.exe). Logged
    on as Admin, I could not successfully create a task for another profile
    (student) as the message Access Denied was issued.

    Attempting to run the task successfully created to run as Admin when logging
    on as Student, it shows as running, shows as a process, but will not show as
    a task. Notepad never pops up. It must be some kind of local policy issue
    with the new machines that I cannot find. I have 38 other Dell Optiplex
    machines with XP Pro purchased last year that let me create the task to run
    as Student and they work just fine.

    Any ideas? Thanks

    Jim
     
    jim smith, Jun 20, 2007
    #1
    1. Advertisements

  2. You might want to consider using a local computer policy to spawn the task
    instead:

    start > run > gpedit.msc

    Local computer policy > windows settings > Scripts > Startup

    Create a bat file to open notepad.exe and link it using the Startup
    properties dialog.

    You could also write a Group policy object if you are using an AD domain.

    Good luck
     
    Keith Lawrence MCP, Jun 20, 2007
    #2
    1. Advertisements

  3. Hi Jim:

    Are these systems, new and/or old connected to a Small Business Server 2003?

    Larry
     
    Larry Struckmeyer, Jun 20, 2007
    #3
  4. jim smith

    jim Guest

    brand new, out of the box Dell Optiplex 745's! connecting to a 2 year old
    SBS 2003 Server, SP2. All the other Optiplex 320's work just fine. Never a
    problem. It cannot be a group policy being pushed from the server or I
    would have 20 problems at this one location instead of the two 745's.
    Therefore, what did Dell and/or MS do to XP Pro SP2 on these machines that
    created this problem? It has to be a policy issue/registry entry somewhere.
    I cannot believe I am the only one to have this issue.

    Jim
     
    jim, Jun 20, 2007
    #4
  5. Jim,

    I wasnt suggesting it was a GP problem, just putting forward a better way of
    accomplishing your desired outcome.

    Since you seem to have identified it as a Dell issue, I would suggest Dell
    support is your next port of call.

    Keith
     
    Keith Lawrence MCP, Jun 21, 2007
    #5
  6. jim smith

    jim Guest

    the problem was finally solved. I had to flatten both computers. After
    installing XP Pro and Service Pack 2, I installed my programs and scheduled
    the tasks at that time. Testing showed that the tasks would run under
    administrator and any other user with restricted access on the local machine.
    The machines were then joined to the domain and worked as expected (like the
    38 other machines worked). MS Updates were applied and the tasks scheduled
    for login continued to work as expected. the machines are now deployed and
    working flawlessly.

    The problem here is that the task scheduler should launch the programs and
    let them work as designed not only BEFORE applying the 80 updates to XP Pro,
    but also AFTER applying the MS updates. There is no excuse for the MS
    updates to have affected the machines in such a negative manner. I now have
    a workaround, but what a heck of a price to pay to figure it out. Thanks, MS.
     
    jim, Jul 3, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.