Cannot start Diagnostic Policy Service

Discussion in 'Windows Vista Security' started by artzoop, Feb 13, 2008.

  1. artzoop

    artzoop Guest

    Running Vista and am logged on as a member of the Administrators group
    and "owner" of C: drive, but cannot start the Diagnostic Policy
    Service. Error 5: Access is denied.

    Any suggestions how to solve this much appreciated!

    Thank you,

    Greg B.
    artzoop, Feb 13, 2008
    1. Advertisements

  2. artzoop

    AlexB Guest

    You may try to add a group to Local Users and Groups: "Diagnostic Policy
    Service" and add yourself to the group as a user.
    AlexB, Feb 14, 2008
    1. Advertisements

  3. artzoop

    artzoop Guest

    Thanks, Alex, for your response. I don't see how adding a new group
    and me as a user would have any bearing on permissions to start/stop a

    artzoop, Feb 15, 2008
  4. artzoop

    Malke Guest

    It wouldn't. AlexB gives advice that is, at best, peculiar and wrong. You
    need to run services.msc elevated. This isn't the same as being an
    administrator in XP.

    Start Orb>Search box>type: services.msc

    When it appears above, right-click on it and choose "run as Administrator".
    Now you'll have the permissions necessary to start the service. I'm
    assuming this box is not a domain member.

    Malke, Feb 15, 2008
  5. artzoop

    artzoop Guest

    Thank you, Malke. I ran services.msc as Administrator and tried to
    start the DPS service, but I still get the same "Error 5: Access is
    denied" messsage.

    This computer is on a domain. Does that mean I have to be a domain
    administrator? How about when I take this computer home (off the
    domain) and login locally? Maybe your suggestion would work then.

    I appreciate your help.

    artzoop, Feb 15, 2008
  6. artzoop

    Malke Guest

    Yes, you must be a domain administrator to make changes to your services.
    You don't need to take the machine home to log in locally. I absolutely am
    not saying this to hurt your feelings, but based on this post I strongly
    suggest you speak to your IT Dept. I get the distinct feeling that you were
    thinking about taking the machine home and removing it from the domain
    entirely (making it part of a Workgroup) and that will cause you a lot more

    If I'm wrong about your skill level then I apologize.

    Malke, Feb 16, 2008
  7. artzoop

    artzoop Guest

    Thank you, Malke, for your response.

    I reread my last response and see how it sounds naive. Of course, I
    don't need to take my laptop home to login locally. I said that as it
    indirectly refers to the root of my issue -- when I take my laptop
    home, I cannot connect to the internet. I cannot run Diagnostic
    Policy Service to investigate why. (I don't take it off the domain at
    home, by the way).

    I logged in locally as a member of the Administrators group and ran
    services.msc "as administrator", but still receive the same access
    error. If the resolution requires a Domain Administrator intervention,
    what exactly do I ask him to configure so that I have appropriate
    permissions to troubleshoot why I cannot connect to the internet from
    home? (No problem with my XP laptop, incidently). Is there a setting
    in the local security policy that can enable local administrators to
    have access to starting and stopping any service -- as well as access
    to change any security policy?

    Thank you,

    artzoop, Feb 18, 2008
  8. artzoop

    Malke Guest

    Thanks for the very good explanation, Greg and also thanks for understanding
    that I wasn't trying to insult you.

    I think that rather than chase after that Group Policy error at this point,
    I'd take a look at your network setup at home such as:

    1. How do you connect to the Internet?
    2. With what hardware?
    3. Wired or wireless?

    Some modems and routers aren't really compatible with Vista; some need to
    have firmware updated and some can only be replaced.

    Perhaps your IT Dept. has your wireless set up so you can't connect to your
    home wireless network (I'm just guessing at this point, throwing out

    Perhaps the problem is that the domain-member laptop is only looking to get
    its IP/DNS from the domain server and needs to either have the Alternate
    Configuration set up or third-party multi-network management software

    See where I'm going with this?

    Malke, Feb 18, 2008
  9. artzoop

    artzoop Guest

    Thanks, Malke,

    I was able to connect from home by changing the tcp/ip properties to
    automatic ip detection. I was not able to do an ipconfig /release
    from a cmd window, however, as I got a "must be elevated" or similar
    message. Is that elevatable via one of the local security policies?

    For future reference, I'd still like to know how to enable
    Administrators on my machine be able to start/stop any service and
    change any local security policy.

    Thanks for your help!

    artzoop, Feb 18, 2008
  10. artzoop

    Malke Guest

    Glad you figured it out. As for the cmd, you can elevate it yourself.

    Start Orb>Search box>type: cmd
    When it appears above, right-click on it and choose "Run as administrator".

    You'll need to be a local administrator to change services on the local
    machine and a domain administrator to change services on a domain
    workstation, although what you do locally won't matter once the machine is
    joined to the Mothership. It will get its Group Policy settings from the
    domain server then.

    Malke, Feb 18, 2008
  11. artzoop

    artzoop Guest

    Hi, Malke,

    My domain administrator logged on to my laptop connected to the
    domain, and got the same access denied message when he tried to start
    the Diagnostic Policy Service. And, as I previously mentioned, when I
    logged on locally (not on the domain) with a local administrator
    logon, I was not able to start the service either.

    What's the secret to administering services? My findings contradict
    your statement "You'll need to be a local administrator to change
    services on the local machine and a domain administrator to change
    services on a domain workstation...".

    Thank you,

    artzoop, Feb 20, 2008
  12. artzoop

    Malke Guest

    I'm sorry but we've reached the end of how I can help you without seeing the
    computer on either network. I currently don't have a server set up in my
    lab and I'd rather be able to see what I'm doing. I would suggest that you
    simply set up either the Alternate Configuration or use a Multi-Network
    Manager instead of changing any Group Policies set by the domain.

    I'm sorry that I was unable to help you.

    Malke, Feb 20, 2008
  13. artzoop

    royoleary Guest

    Hi Malke

    I have a similar problem without the conflict of home/work. After
    getting many blue screens on my Vista connected via linksys cable
    modem along with two XPs I ran memory diagnosis and it registered a
    hardware error. I pulled the memory out and reinserted and computer
    seems to work fine except for one very important thing. Like artzoop
    I can't get the windows Diagnostic Policy Service. to load and get
    Error 5: Access is denied. I'm logged on as administrator. Without
    access to the Policy list, which I can see but not change, I can't get
    back to my network/internet. Vista won't find any connections and
    won't let me access the Policy that will get me there. Perfect Catch
    22. Any further ideas on this?


    royoleary, Feb 27, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.