Cannot succeed with the Event sample

Discussion in 'Windows Vista Drivers' started by hardworkboy, Feb 28, 2006.

  1. hardworkboy

    hardworkboy Guest

    Dear all,

    I am sorry to bother you again.
    I have installed the DDK on my E driver. And I have download
    the event source code from MS website. but the build got some problem.
    the buildchk_w2K_x86 is as following.
    Actually I don't have the event.rc file inside the sys directory.
    Could anyone tell me what error I have made? Do I need to add the
    "inc" directory of the WINDDK to my environment variable setting?

    p.s.

    BUILD: Examining e:\0227w\event\sys directory for files to compile.
    Compiling (NoSync) e:\0227w\event\sys directory ********************
    'nmake.exe /nologo BUILDMSG=Stop. -i NTTEST= UMTEST= NOLINK=1 386=1'
    cl -nologo -Ii386\ -I. -IE:\WINDDK\3790~1.183\inc\mfc42 -I..
    -Iobjchk_w2K_x86\i386 -IE:\WINDDK\3790~1.183\inc\w2K
    -IE:\WINDDK\3790~1.183\inc\w2K -IE:\WINDDK\3790~1.183\inc\ddk\w2K
    -IE:\WINDDK\3790~1.183\inc\ddk\wdm\w2K -IE:\WINDDK\3790~1.183\inc\crt
    -D_X86_=1 -Di386=1 -DSTD_CALL -DCONDITION_HANDLING=1 -DNT_INST=0
    -DWIN32=100 -D_NT1X_=100 -DWINNT=1 -D_WIN32_WINNT=0x0500
    /DWINVER=0x0500 -D_WIN32_IE=0x0501 -DWIN32_LEAN_AND_MEAN=1 -DDEVL=1
    -DDBG=1 -D__BUILDMACHINE__=WinDDK -DFPO=0 -DNDEBUG -D_DLL=1 /c
    /Zl /Zp8 /Gy /Gm- -cbstring /W3 /WX /Gz /GX- /GR- /GF /GS /G6 /Ze
    /Gi- /QIfdiv- /hotpatch -Z7 /Od /Oi /Oy-
    -FIE:\WINDDK\3790~1.183\inc\w2K\warning.h .\event.c .\pnp.c
    event.c
    pnp.c
    Generating Code...

    Stop.
    Linking e:\0227w\event\sys directory ********************
    'nmake.exe /nologo BUILDMSG=Stop. -i LINKONLY=1 NOPASS0=1 NTTEST=
    UMTEST= 386=1'
    link -out:eek:bjchk_w2K_x86\i386\Event.sys -machine:ix86
    @C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\nm2571.tmp
    Microsoft (R) Incremental Linker Version 7.10.4035
    Copyright (C) Microsoft Corporation. All rights reserved.

    -MERGE:_PAGE=PAGE
    -MERGE:_TEXT=.text
    -SECTION:INIT,d
    -OPT:REF
    -OPT:ICF
    -IGNORE:4198,4010,4037,4039,4065,4070,4078,4087,4089,4221
    -INCREMENTAL:NO
    -FULLBUILD
    /release
    -NODEFAULTLIB
    /WX
    -debug
    -debugtype:cv
    -version:5.0
    -osversion:5.0
    /functionpadmin:5
    /pdbcompress
    -STACK:0x40000,0x1000
    -driver
    -base:0x10000
    -align:0x80 /stub:E:\WINDDK\3790~1.183\lib\w2K\stub512.com
    -subsystem:native,5.00
    -entry:GsDriverEntry@8
    -out:eek:bjchk_w2K_x86\i386\Event.sys
    objchk_w2K_x86\i386\event.obj
    objchk_w2K_x86\i386\pnp.obj
    E:\WINDDK\3790~1.183\lib\w2K\i386\BufferOverflowK.lib
    E:\WINDDK\3790~1.183\lib\w2K\i386\ntoskrnl.lib
    E:\WINDDK\3790~1.183\lib\w2K\i386\hal.lib
    E:\WINDDK\3790~1.183\lib\w2K\i386\wmilib.lib
    E:\WINDDK\3790~1.183\lib\w2K\i386\sehupd.lib
    echo Skip Binplace:
    Skip Binplace:

    Stop.


    Thanks!
    Jeff
     
    hardworkboy, Feb 28, 2006
    #1
    1. Advertisements

  2. hardworkboy

    Mark Roddy Guest

    Which sample? A link would be helpful.
    There doesn't appear to be an error in your output.

    If you downloaded a sample, you should try building it first with all
    of its components in exactly its original configuration. Then start
    changing stuff.

    =====================
    Mark Roddy DDK MVP
    Windows Vista/2003/XP/2000 Consulting
    Device and Filesystem Drivers
    Hollis Technology Solutions 603-321-1032
    www.hollistech.com
     
    Mark Roddy, Feb 28, 2006
    #2
    1. Advertisements

  3. hardworkboy

    hardworkboy Guest

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q262947 is the
    link for the event example.
    on the website( the above link), it said "This process invokes the
    Microsoft make routines that produce .log files (Buildxxx.log) and also
    Buildxxx.wrn and Buildxxx.err, if there are any warnings or errors,
    where xxx stands for .fre or .chk, depending on the environment
    chosen." So I guess maybe I have got some errors.
    I have got the Event.sys in the cannot get the eventtst.exe and my
    Event.sys file size is different from the one given by the website.
    so.........
    Please help again!

    Sincerely,
    Jeff
     
    hardworkboy, Mar 1, 2006
    #3
  4. hardworkboy

    hardworkboy Guest

    I am sorry. The build process seems done. But the test procedure seems
    got some problem. I have copied the Event.sys and the eventtst.exe to
    the same directory such as E:\test. But the
    SetupDiEnumDeviceInterfaces() got some problem of 259,means "No
    GUID_EVENT_INTERFACE interface found".
    Do I need to copy the Event.sys to the system32\drivers\ directory?
    How is the Event.inf generated? Why is it said "automatically" but
    failed?

    Jeff
     
    hardworkboy, Mar 1, 2006
    #4
  5. For me, this looks like the successful BUILD log.
     
    Maxim S. Shatskih, Mar 1, 2006
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.