Cannot uninstall / reinstall / repair WMP 11

Discussion in 'Windows Media Player' started by misle, Oct 11, 2008.

  1. misle

    misle Guest

    I was lucky enough to get my first virus in 9 years and after I got
    everything cleaned and put back together, the only victim is WMP 11, which
    crashes as soon as I open it.

    I downloaded the version on MS's website hoping to reinstall or repair, but
    it says:
    There is a more recent version of Windows Media Player (11.0.6001.7000)
    already insatlled on your computer. It is not possible to use an older
    installation package (11.0.5721.5146) to install files or to repair your
    current version of the Player.

    So, how do I fix this? Vista Business, btw.

    Thanks.
     
    misle, Oct 11, 2008
    #1
    1. Advertisements

  2. misle

    zachd [MSFT] Guest

    zachd [MSFT], Oct 15, 2008
    #2
    1. Advertisements

  3. misle

    Josh Guest

    zachd - actually going to give you what you've been looking for - an actual
    error message. I start it up (Admin or Otherwise) and get this.

    "Windows Media Player has stopped working"
    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: wmplayer.exe
    Application Version: 11.0.6001.7000
    Application Timestamp: 47919356
    Fault Module Name: Indiv01.key
    Fault Module Version: 11.0.6000.6324
    Fault Module Timestamp: 47e66ef0
    Exception Code: c0000005
    Exception Offset: 001016e7
    OS Version: 6.0.6001.2.1.0.256.1
    Locale ID: 1033
    Additional Information 1: fd00
    Additional Information 2: ea6f5fe8924aaa756324d57f87834160
    Additional Information 3: fd00
    Additional Information 4: ea6f5fe8924aaa756324d57f87834160

    Read'em and weep. Hauppage is to blame. I'd love to do a repair, but no
    such animal. Bonus points - I have a DRM folder - it's completely empty.

    Thanks!
    Josh
    --
    AMD Phenom 9950
    ASUS M3N HT Deluxe
    4g DDR2-800mhz
    2 x EVGA 280 SLi
    750G RAID 0
    160G RAID 1
     
    Josh, Dec 11, 2008
    #3
  4. misle

    zachd [MSFT] Guest

    Follow the steps here:
    http://support.microsoft.com/kb/891664/en-us
    You have a corrupt DRM store, likely caused by a processor upgrade.

    You can't see the files by default because either a) you're viewing the
    wrong folder or b) you do not have Show System Hidden Files turned on. =)
     
    zachd [MSFT], Dec 11, 2008
    #4
  5. misle

    Josh Guest

    I alsways show hidden folders and files, and the DRM folder still doesn't
    show. I can type it in directly and it opens, but it won't show up in the
    tree until I do that. As far as I can see it's empty too.

    I verified the registry tree and there was no DataPath key, only an empty
    (DEFAULT) key so I think that could be the issue. I tried reinstalling the
    DRM components and I crash when clicking Update button on the site.
    --
    AMD64FX55 | 2Gig HyperX
    2 x 7800 GT SLi | 160G 3G/SSATA
     
    Josh, Dec 12, 2008
    #5
  6. misle

    zachd [MSFT] Guest

    Are you on a 32bit or 64bit system?


     
    zachd [MSFT], Dec 12, 2008
    #6
  7. misle

    Josh Guest

    Sorry about that, running VISTA Ultimate x64
    --
    AMD64FX55 | 2Gig HyperX
    2 x 7800 GT SLi | 160G 3G/SSATA
     
    Josh, Dec 13, 2008
    #7
  8. misle

    zachd [MSFT] Guest

    OK, then you should have a second location for DataPath in your Wow6432Node
    and you likely have a second folder.

    Regardless that file exists on your system since that's where you're
    crashing: the next trick is to figure out where. What path is it at on your
    system?
     
    zachd [MSFT], Dec 14, 2008
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.