Can't clear read-only attribute on Temp folder

Discussion in 'Windows Vista File Management' started by Richard, Apr 10, 2007.

  1. Richard

    Richard Guest

    I need to clear the RO attribute on C:\Temp. I log-in as Administrator, run
    Windows Explorer as administrator, right click on C:\Temp, Properties,
    Security and set Full control for all user groups. Then, General tab, clear
    Read-only, Apply then on the Confirm Attribute Changes dialog select Apply
    changes to this folder, subfolders and files, OK, OK. But when I check
    properties again the Read-only attribute is checked!

    Please help!

    Thanks! ;^)
    Richard
     
    Richard, Apr 10, 2007
    #1
    1. Advertisements

  2. That check box doesn't set or clear the read-only attribute for the folder,
    only the contents of the folder. Also know that the read-only attribute on
    a folder doesn't prevent a user from writing files to the folder, it just
    tells Explorer to process the folder's desktop.ini file.

    That being said, to accurately determine whether or not the read-only
    attribute is set on a folder, add the attributes column to a detail view in
    Windows Explorer. To set or clear the attribute, use the 'attrib' command
    from a command prompt window.
     
    Keith Miller MVP, Apr 10, 2007
    #2
    1. Advertisements

  3. Hi, Richard.

    The RO attribute on folders/directories does not mean what it used to.
    Perhaps this KB article will help:
    You Cannot View or Change the Read-Only or System Attribute of Folders
    http://support.microsoft.com/kb/326549/en-us

    To quote one sentence from that KB:
    "Unlike the Read-only attribute for a file, the Read-only attribute for a
    folder is typically ignored by Windows, Windows components and accessories,
    and other programs."

    RC
    --
    R. C. White, CPA
    San Marcos, TX

    Microsoft Windows MVP
    (Running Windows Mail in Vista Ultimate x64)
     
    R. C. White, MVP, Apr 10, 2007
    #3
  4. Richard

    Richard Guest

    Thanks Keith,
    I'm trying to install Adobe Reader. Part way through the installation I get
    an error dailog that says: "Windows Installer The Temp folder is on a drive
    that is full or is inaccessible. Free up space on the drive or verify that
    you have write permission on the Temp folder." I have 107G of free space on
    C: so I'm assuming it's a write permission problem. I've tried clearing the
    RO attribute on C:\Temp, C:\Windows\Temp and Local Settings\Temp. All show
    no R attribute in Explorer details Atributes column but still no luck
    installing Reader.

     
    Richard, Apr 10, 2007
    #4
  5. Richard

    Richard Guest

    OK, so the RO attribute doesn't mean the folder is read-only. Any ideas as
    to why Adobe Reader installer says it's read-only?
     
    Richard, Apr 10, 2007
    #5
  6. Richard G. Harper, Apr 10, 2007
    #6
  7. Richard

    Richard Guest

    Thanks Richard,
    How do I turn UAC on/off?

     
    Richard, Apr 10, 2007
    #7
  8. Richard

    dean-dean Guest

    Maybe this article from Adobe will help:

    Error, "The Temp folder is on a drive that is full..." when installing
    Acrobat 8 trial or Adobe Reader 8 (Windows Vista):
    http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=333643


     
    dean-dean, Apr 10, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.