Can't delete a file - Access is denied to Administrator

Discussion in 'Windows Vista File Management' started by jeff, Aug 4, 2007.

  1. jeff

    jeff Guest

    I have an mpeg file on my local hard drive that I cannot delete. My account
    is an administrator account, running under vista ultimate. When I look at the
    file properties I see that the ownership is unassigned (unable to display
    current owner), but when I attempt to take ownership, windows security
    reports "Unable to set new owner on [filename]. Access is denied."

    Can anyone recommend steps to delete this file?
     
    jeff, Aug 4, 2007
    #1
    1. Advertisements

  2. jeff

    dean-dean Guest

    Try this. Right-click Command Prompt, and choose Run as Administrator.
    Type the following command, and then press
    ENTER:

    takeown /f Path_And_File_Name

    For example, type:
    takeown /f C:\Users\You\Downloads\unwanted.mp3

    Type the following command, and then press ENTER to grant
    administrators full access to the file:

    icacls Path_And_File_Name /GRANT ADMINISTRATORS:F

    For example, type:
    icacls C:\Users\You\Downloads\unwanted.mp3 /grant administrators:F

    Then try to delete unwanted.mp3.

    If that doesn't work, try to delete the file in Safe Mode.
     
    dean-dean, Aug 4, 2007
    #2
    1. Advertisements

  3. jeff

    Njetspam Guest

    Played the mpeg with vista mediaplayer ? take and install vlc-player :)
    do not use mediaplayer it kinda sucks :D
     
    Njetspam, Aug 4, 2007
    #3
  4. I ran into a 3 gig file just yesterday that was seemingly impossible to
    delete. I tried everything.

    I then ran chkdsk g: /f (fix option) on the partition. I was then able to
    delete the file (it had apparently become corrupted).

    --


    Regards,

    Richard Urban
    Microsoft MVP Windows Shell/User
    (For email, remove the obvious from my address)
     
    Richard Urban, Aug 4, 2007
    #4
  5. jeff

    gdoran Guest

    What can you do if takeown is getting 'access denied" when trying t
    take ownership
     
    gdoran, Mar 27, 2008
    #5
  6. jeff

    Bob Guest

    How are you running takeown?
    -------
    *Report back, please*
    [When responding to posts, please include the post(s) you are replying to so
    that others may learn and benefit from the issue]

    [How to ask a question]
    http://support.microsoft.com/kb/555375
     
    Bob, Mar 27, 2008
    #6
  7. jeff

    gdoran Guest

    takedown /f foldername /r. Get Sucess: the fodler foldername is now
    owned by domainname\gdoran. Then get Info: access is denied
    foldername\filename. Filename is set to read-only, can't seem to unset
    it.
     
    gdoran, Mar 27, 2008
    #7
  8. jeff

    Bob Guest

    Do this then try takeown again:
    attrib -r -a -s -h del [drive] path] [filename]
    -------
    *Report back, please*
    [When responding to posts, please include the post(s) you are replying to so
    that others may learn and benefit from the issue]

    [How to ask a question]
    http://support.microsoft.com/kb/555375
     
    Bob, Mar 28, 2008
    #8
  9. jeff

    gdoran Guest

    Get a access denied trying to change the attribute with attrib
     
    gdoran, Mar 28, 2008
    #9
  10. jeff

    Bob Guest

    Run the command from an Administrator Command prompt.
     
    Bob, Mar 28, 2008
    #10
  11. Hy. I runned into that damn problem too. And after days of searching I finally found this software: Long Path Tool.
    It's GREAT. You can find it here: http://www.longpathtool.com/
    Regards.
     
    Mihaela Roata, Nov 3, 2010
    #11
  12. jeff

    Danteskasas

    Joined:
    Mar 21, 2012
    Messages:
    1
    Likes Received:
    0
    Hi friends you can solve by this long path Tool
     
    Danteskasas, Mar 21, 2012
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.