Cant delete folder, cant name folder "con"

Discussion in 'Windows Vista General Discussion' started by jmclaren7, Sep 24, 2008.

  1. jmclaren7

    jmclaren7 Guest

    so i think this is the first thing on vista to truly stump me....

    First Issue: 2 folders named "con" in sepperate sub directories of th
    same top level directory can not be deleted, saying that "This folder i
    no longer located in <blah dir>. Verify the items location and tr
    again.", the parrent folder of "con" can also not be deleted, displayin
    the same error.

    Second Issue: I cannot create a folder with the name "con" anyplace o
    my system, giving this message: "The specified device name is invalid"


    These folders originaly did not exist on the system, they were create
    when i downloaded part of a web directory via ftp using the progra
    FlashFXP.

    when i view these folders properties page i see a lack of dates an
    security permisions



    ive seen alot of talk about issues related to folder deletion on thi
    forum but nothing like this, any idea?

    thank you
     
    jmclaren7, Sep 24, 2008
    #1
    1. Advertisements

  2. Second issue:
    'con' is a reserved system word, stands for the 'console' device. As such
    you cannot have a folder or file named 'con'.

    Now as to how you got such a folder , and what you can do about that --
    sorry I haven't a clue.

    Michael
     
    Michael Walraven, Sep 24, 2008
    #2
    1. Advertisements

  3. jmclaren7

    DanS Guest

    Open a cmd prompt.
    CD to the 'con' directory's ("folder's") parent directory
    isues a: dir /x
    Look for the 'con' folder to the far right.
    See if it has an 8.3 name in the second column from the right.
    use: rd using the folder con's 8.3 name...if it has one.

    This used to work in XP for malformed file/folder names. I have no idea
    if it still works in Vista...haven't had to do it.
     
    DanS, Sep 24, 2008
    #3
  4. jmclaren7

    jmclaren7 Guest

    the folder just showed up as 'con'

    "The system cannot find the file specified."

    i got the file onto my system using FlashFXP, i created the file on the
    server (linux) and then transfered it using flashfxp

    i cant belive that all happend by chance


    so my guess is that i have to use a live cd and mount my ntfs drive and
    the delete the folder


    i think ill go cry now, because last time i tried mounting a ntfs drive
    i couldnt get it to work.
     
    jmclaren7, Sep 25, 2008
    #4
  5. jmclaren7

    DanS Guest

    No 8.3 name showed ? That sucks.

    If you use Ubuntu (with GNome desktop, not Kubuntu or Xbuntu) the
    'Places' menu has a selection 'Connect to Server', which you can use to
    connect to the shared drive....if that selection is active from the
    LiveCD that is.
     
    DanS, Sep 25, 2008
    #5
  6. jmclaren7

    jmclaren7 Guest

    hmm, thanks for the tip... i actualy JUST figured this out... using the
    following method worked, and i have no idea what \\. means, but
    whatev...

    rd \\.c:\blablabla\con

    if anyone knows what \\. does to a path id love to know
     
    jmclaren7, Sep 25, 2008
    #6

  7. I have no idea why that would have worked for you, as the command does not
    make any sense. \\ would be the start of a UNC path, and the period (.)
    would signify the current directory.

    http://en.wikipedia.org/wiki/UNC_path#Uniform_Naming_Convention

    ss.
     
    Synapse Syndrome, Sep 25, 2008
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.