can't download file - "you need permission"

Discussion in 'Windows Vista Security' started by sonar1313, Jul 13, 2008.

  1. sonar1313

    sonar1313 Guest

    I am trying to download a game file I bought. It is an .exe file. No matter
    what folder I try to save it to, even if I try to save to a flash drive, the
    computer tells me "You need permission to perform this action." I can "Try
    Again" or "Cancel" but Try Again only brings up the same message. I am
    running from the administrator account. I have already tried shutting off
    User Access Control. How am I supposed to give myself permission to do this?
     
    sonar1313, Jul 13, 2008
    #1
    1. Advertisements

  2. It sounds strange, but try:
    - Open Internet Explorer
    - Select Tools -> Internet Options
    - Click Security -> Default Level

    Then just "done" your way out. It fixed a similar problem I had.

    - empbrd
     
    empathy beard, Jul 13, 2008
    #2
    1. Advertisements

  3. sonar1313

    sonar1313 Guest

    Default Level is grayed out....already at that setting I imagine. Tried
    lowering the security setting a notch, still no good. Error messages
    continue:

    "You'll need to provide administrator permission to copy to this file."

    ok, so I hit "Continue"...Skip and Cancel just cancel my download

    "Windows needs your permission to continue."

    again....continue....

    then the "you need permission to perform this action" message.
     
    sonar1313, Jul 13, 2008
    #3
  4. sonar1313

    JerryM Guest

    Something to try,

    Right click CMD.EXE and select Run as Administrator.
    This will put you in the Root directory where you can run your EXE files.
     
    JerryM, Jul 13, 2008
    #4
  5. sonar1313

    JerryM Guest

    After hitting return, type CD\ and hit return to put you in the Root
    directory.
     
    JerryM, Jul 13, 2008
    #5
  6. sonar1313

    sonar1313 Guest

    I can't even download the file let alone run it. I've tried "Run" instead of
    "Save" when I click the download link but that literally does nothing.

    The download instructions say: "If the file ends in dm.exe, click OPEN.
    Otherwise, click SAVE and save it to a place you'll remember later, such as
    your desktop."

    File does end in dm.exe. I don't know what difference that makes. Not sure
    what I'm supposed to do once I get into cmd.exe if I don't even have the file
     
    sonar1313, Jul 13, 2008
    #6
  7. sonar1313

    JerryM Guest

    I think I'm missing something here,

    If you click Start, All Programs, and Accessories, you should see CMD.EXE
    Right click it and select - Run as Administrator,
    Type CD\ to put you in the Root directory where you should be able to use
    your EXE files.
    BUT
    If downloading your file is the problem, type - Download files - on the
    search line above the start button.
    The file should show up there, where you can double click it to run.

    Sorry if this doesn't help
     
    JerryM, Jul 13, 2008
    #7
  8. sonar1313

    sonar1313 Guest

    Can't even download the file - that's the problem. It downloads 99% of the
    file, then tells me I need permission, and makes me cancel the
    download......even though it seems like I've given permission by clicking
    CONTINUE twice.
     
    sonar1313, Jul 13, 2008
    #8
  9. sonar1313

    Fmjc001 Guest

    Maybe the parental control have been set to block downloads. Go to
    Control panel, user accounts, parental control, your username and then
    check. Although you need to be an admin to do this and admins cant have
    parental controls on them...Are you an admin?
     
    Fmjc001, Jul 13, 2008
    #9
  10. sonar1313

    sonar1313 Guest

    Yes, it's my home computer and I'm the admin. I've been trying to download
    the program as the admin.....parental controls not an issue.
     
    sonar1313, Jul 13, 2008
    #10
  11. sonar1313

    Gordon Guest

    So to what location on your HDD are you trying to download this file to?
     
    Gordon, Jul 14, 2008
    #11
  12. sonar1313

    sonar1313 Guest

    I have tried the desktop, various other places in my own user folder
    including the Downloads folder, Program Files, and an empty thumb drive.
     
    sonar1313, Jul 15, 2008
    #12
  13. sonar1313

    Regalia Guest

    I almost didn't bother going through registration to answer this.
    Almost.

    For my idea of a solution.

    Do you see the name of the file in the 'save' window?
    The thing is, v64 won't let you save some types of files. For some
    reason. It can be disabled, but you don't really have to. Just change
    the extension of the saved file to say: 'a'.

    So if you have 'file.exe' it would be 'file.a'. Thus the "protection"
    is circumvented. Yay.

    When downloaded, the file should be renamed back to exe but i guess you
    knew that.
     
    Regalia, Jul 15, 2008
    #13
  14. sonar1313

    sonar1313 Guest

    Thanks for going through the trouble :)

    I do think it would have worked....but the story already has a happy
    ending....someone advised me to just disable virus protection, so I did.
    (Cheesy virus protection software that came installed on the computer.) And
    it worked. Funny, because it never gave any indication that it was the
    anti-virus that was causing my problem.

    Thanks to all who offered advice!
     
    sonar1313, Jul 16, 2008
    #14
  15. You *are* going to replace it with another AV program, aren't you? There
    are several very good ones (a couple free) out there,,,

    --

    Regards,
    Hank Arnold
    Microsoft MVP
    Windows Server - Directory Services
     
    Hank Arnold (MVP), Jul 16, 2008
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.