can't install msft own MSI package; marked as 'unsafe'

Discussion in 'Clustering' started by seth, Mar 2, 2005.

  1. seth

    seth Guest

    been having problems on my new 2 node cluster servers (2003), errors 1517
    and 1524 about not being able to unload registry because of an application
    using it. in article 837115 their fix is the user profile cleanup service.
    i've used it previously and worked fine. but now can't use it on the new
    servers.

    when i try to install it, it says "the advertised application will not be
    installed because it might be unsafe. contact the administrator to change
    the user interface option of the package to basic."

    running it as domain administrator.
    why does this happen? does terminal services have anything to do with it?
     
    seth, Mar 2, 2005
    #1
    1. Advertisements

  2. Hi Seth,

    I'm by no means an expert in this subject matter of MSI packages, but I'll
    try to assist you to the best of my ability. This can occur on any server,
    it's not specific to Cluster servers. This problem can happen when the
    application is not completely uninstalled from the system. Try to do the
    following to check:

    If the application is a Windows Service -
    1. Go to START, RUN and type (without the quotes): "Services.MSC" and click
    OK.

    2. If the service exists in the list, you will need to use INSTALLUTIL.EXE
    to
    remove it. To use INSTALLUTIL, do the following:

    * Go to START, RUN and open a command prompt by typing CMD. Navigate to
    the
    C:\Windows(or WINNT)\Microsoft.NET\Framework\(version number)\

    * InstallUtil should be in this directory. Then type the following
    (without
    the quotes): INSTALLUTIL /U "Path to the .exe for the service"

    * After the service is removed, you should be able to move forward with
    the
    installation.

    If the application is a component in the Global Assembly Cache, do the
    following:

    1. Navigate to the C:\Windows(or WINNT)\Assembly and check to see if the
    component
    is listed in the GAC folder.

    2. If it is, you will need to use GACUTIL.EXE /U to uninstall the component
    from
    the GAC. Use GACUTIL the same way you would use INSTALLUTIL (above) except
    set the
    pathing information to the location of the .DLL or component used for the
    GAC.

    If the application is a Windows or Web application -

    1. Go to START, RUN and type the following: MSIEXEC /X "path to the .MSI
    file you
    want to uninstall" and click OK.

    2. After the application is uninstalled, try installing your MSI file again.
    If you
    get the same error, then some portion of the application still exists on the
    machine. You will want to use MSIZAP to remove the product, or you can
    search for
    the PRODUCTID of the msi package in the registry and remove the associated
    registry
    keys. The Product ID looks like {xxxxx-xxxxx-xxx-xxxxx-xxxxx}

    --
    Hope this helps,
    Mike Rosado
    Windows 2000 MCSE + MCDBA
    Microsoft Enterprise Platform Support
    Windows NT/2000/2003 Cluster Technologies

    ====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ====================================================

    This posting is provided "AS IS" with no warranties, and confers no rights.
    <http://www.microsoft.com/info/cpyright.htm>

    -----Original Message-----
     
    Mike Rosado [MSFT], Mar 2, 2005
    #2
    1. Advertisements

  3. seth

    seth Guest

    1) It is a windows service, but does not exist on this system
    2) application does not show in global assembly cache.
    3) the product id is 9DC557FB581EA894AABF9E8F74A01BCC and appears nowhere in
    the registry; attempt to uninstall using msiexec /x yielded "this action is
    only valid for products that are currently installed"
     
    seth, Mar 2, 2005
    #3
  4. From the readme.txt file that comes with the package:

    <quote>
    INSTALLATION PROBLEMS
    =====================
    If you get an error using the MSI installation package and the
    package is on a network share attempt the installation from a local
    drive. Another alternative is to use the manual installation
    instructions.

    INSTALLATION
    ============
    To manually install it (you need a copy of uphclean.exe):

    - Create a directory under Program Files for the service
    (e.g. c:\program files\uphclean)
    - Copy the program (uphclean.exe) to the directory
    (e.g. c:\program files\uphclean\uphclean.exe)
    - Open a command prompt on the computer
    - Change directory where you copied the program
    (e.g cd \program files\uphclean)
    - Run the program with the -install switch to install the service
    and start it
    (e.g. uphclean -install)

    The service is set to automatically start when the computer boots
    so you will not need to start it manually.
    </quote>

    Make sure to downloaded the latest version of the UPHclean
    utitlity, there's a problem with versions before 1.5:

    885958 - Your Windows Server 2003-based terminal server that uses
    the UPHClean utility to unload user profiles when users log off may
    suddenly stop responding
    http://support.microsoft.com/?kbid=885958
     
    Vera Noest [MVP], Mar 2, 2005
    #4
  5. seth

    seth Guest

    got nervous at first when i saw that article. it can crash with 1.5.0.11
    but i have 1.5.5

    i found the problem. the domain administrator has roaming profile.
    apparently, unlike most software, this msi puts the config/uninstall info
    within the user profile, not with the system. the uninstall is found in
    HKCU\software\microsoft\windows\current version\uninstall instead of HKLM.
    i tried it as local administrator and installed fine.
     
    seth, Mar 3, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.