Can't install/uninstall anything...says I'm already doing it

Discussion in 'Windows Vista Performance' started by sean in d.c., Feb 10, 2007.

  1. sean in d.c.

    sean in d.c. Guest

    I am unable to install or uninstall any programs in Windows Vista. If I
    attempt to do so, I get the following message:

    Another program is being installed. Please wait until that installation is
    complete, and then try installing this software again.

    I get this error if I try to install a program using a CD, DVD or download,
    and I get this error if I try to uninstall a program from the Control Panel.

    I have rebooted several times, yet this problem persists. Any suggestions?
     
    sean in d.c., Feb 10, 2007
    #1
    1. Advertisements

  2. sean in d.c.

    escarrgo Guest

    I have the same kind of broken installation, and no clue about how to recover.
    I was trying to remove an older Cisco VPN client, and (perhaps mistaken) hit
    cancel to stop the uninstall to remove it later. Now I can't remove it, and
    get the error message you cite. I also cannot "Repair" which gives a similar
    error message in a different widget. It really bugs me that there is no way
    to explicity resume an installation (which Vista claims needs to be done) and
    no way to determine what it is that is being installed. It's a terrible lack
    of transparency.
     
    escarrgo, Mar 1, 2007
    #2
    1. Advertisements

  3. I am having the same problem, has anyone come up with a solution?
     
    startingtohatevista, Oct 28, 2009
    #3
  4. "startingtohatevista"


    If you want help, please take the time and energy to describe your
    own problem, else you are not likely to obtain assistance anywhere.

    Me too doesn't cut it here. Every computer is different. Unless you have the
    exact same computer with the exact same software loaded you are NOT a ""ME
    TOO"". You are different.
     
    Richard Urban, Oct 28, 2009
    #4
  5. I was trying to install a logitech camera. The installation seemed to
    complete so I started to install Microsoft Office. After the initial
    installation of office I restarted and it gave me the same error that is
    stated below "Another program is being installed...". I tried to use
    the logitech CD to unistall and it gave me the same error. I deleted
    all of the logitech files and tried again, and got the same error. I
    tried a reinstall, and that didn't work either. I restarted after each
    step, but got the same error every time. I basically need to figure out
    how to stop windows installer, or reset it so that it doesn't look to
    install the logitech program.
     
    startingtohatevista, Oct 28, 2009
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.