Can't open a file via UNC, but can via a mapped drive

Discussion in 'Windows Vista Drivers' started by Peter Leviton, Jun 15, 2009.

  1. Hi Everyone,

    We have implemented an installable file system which works quite nicely, but
    we have a strange problem: Excel cannot open a file if we use UNC. For
    instance, Start > Run > "excel \\server\share\file.xls" causes Excel to
    display the message:


    '\\server\share\file.xls\' could not be found. Check the spelling of the
    file name, and verify that the location is correct.

    If you are trying to open the file from your list of most recently used file
    on the File menu, make sure that the file has not been renamed, moved, or
    deleted.


    The extra backslash on the end of the file name in the message isn't a typo,
    Excel really does put it there. Perhaps that means something.

    If we now map a drive to the share then Start > Run > "excel Z:\file.xls"
    causes Excel to open the file correctly.

    No other application that we have tried has been unable to open a file using
    UNC - we tried many, including Notepad and Word.

    In one particular instance, we were trying to open a file of size 222208
    bytes. The reads we saw were the following:


    IRP_MJ_READ
    ByteOffset = 0 and Length = 32768
    We read 32768 and returned success.

    IRP_MJ_READ
    ByteOffset = 192512 and Length = 32768
    We read 29696 and returned success.


    So Excel read the first 32768 bytes then jumped to near the end of the file
    and tried to read beyond it. After this we don't get any more reads.

    We are using Excel 2003 on Windows XP service pack 3. Does anyone have any
    idea what might be causing this problem?

    Cheers, Peter
     
    Peter Leviton, Jun 15, 2009
    #1
    1. Advertisements

  2. Well, Excel is displaying the same message for me if I run it via:

    excel \\server\volodymyr\New Microsoft Office Excel Worksheet.xlsx

    But if I run it via:

    excel "\\server\volodymyr\New Microsoft Office Excel Worksheet.xlsx"

    It works perfectly.
     
    Volodymyr Shcherbyna, Jun 16, 2009
    #2
    1. Advertisements

  3. Ah, sorry for noise, I see that in your case there are not spaces in path
    ....
     
    Volodymyr Shcherbyna, Jun 16, 2009
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.