cant open files from old hard-drive

Discussion in 'Windows Vista Security' started by aaronofyo, Dec 18, 2008.

  1. aaronofyo

    aaronofyo Guest

    i recently got new computer with vista home premium x64. i attached th
    harddrive from my old xp computer (w/external case) so i can get all th
    files from it, but when i try to open the files it says i dont hav
    permission. ive managed to use the security tab to "replace owner an
    subcontainers on objects" while changing the owner, for some of th
    files (mostly mp3's) but this is very tedious. is there anyway i ca
    disable the 'owner' from my old computer
     
    aaronofyo, Dec 18, 2008
    #1
    1. Advertisements

  2. aaronofyo

    Malke Guest

    Run this at an elevated Command Prompt:

    cacls c:\ /t /e /g Administrators:f [enter]

    This will give full rights to all the files and folders on drive C: to the
    Administrators group, any member to this group will then have full rights
    to the files.

    To grant full rights to a specific user issue the command with the user's
    name:

    cacls c:\ /t /e /g Steve:f [enter]

    will grant Steve full rights to all the files and folders on C:. If the
    user name has spaces you must surround it with quotation marks:

    cacls c:\ /t /e /g "Some User":f [enter]

    Obviously you will substitute your desired owner user name on Vista for
    "Steve".

    Malke
     
    Malke, Dec 18, 2008
    #2
    1. Advertisements

  3. aaronofyo

    aaronofyo Guest

    when i enter that command it displays a list of "processed file :
    L:_____(various files)"
    but when it gets to "processed dir:L: Documents and Settings" it says
    "access is denied".
     
    aaronofyo, Dec 18, 2008
    #3
  4. aaronofyo

    Gordon Guest


    To whom are you talking? Please QUOTE the post you are replying to.
    Thank you
     
    Gordon, Dec 18, 2008
    #4
  5. I don't think that the CACLS command handles ownership issues, so you
    probably need to take ownership of the files and folders first. Rather
    than doing so one file/folder at a time, you can use the TAKEOWN command
    to do so, like this:

    TAKEOWN /F L:\* /R /D

    That should give ownership of all files and folders on L: to the current
    user. To give ownership to the Administrators group instead of the
    current user, add /A.

    Hope this helps.
     
    Zaphod Beeblebrox, Dec 18, 2008
    #5
  6. aaronofyo

    Leo Guest

    Perhaps this may help

    Step by step instruction on how to take ownership of a folder



    - Right-click the file/folder you want to own, click properties

    - Click Security Tab

    - Click Advanced

    - Click the Owner Tab

    - Click Edit

    - Select the Administrators group from the list

    - Click OK

    - Click OK

    - Click OK

    You have now taken 'Ownership' of the file and you can close the property

    Windows



    Now again



    1) Right-click on the file

    2) Select Properties

    3) Go to the Security tab again, click the Advanced button

    4) Now Press Edit, then double-click 'Administrators' in the list and tick

    the 'allow' box for 'Full control'



    You have now taken 'Full control' of file


    --
    Leo

    'Whoever said the pen is mightier than the sword
    obviously never encountered automatic weapons.'
    General MacArthur
     
    Leo, Dec 18, 2008
    #6
  7. aaronofyo

    aaronofyo Guest

    that worked leo. thanks for the help.

     
    aaronofyo, Dec 19, 2008
    #7
  8. aaronofyo

    Leo Guest

    YW, glad the problem has been fixed.

    --
    Leo

    'Whoever said the pen is mightier than the sword
    obviously never encountered automatic weapons.'
    General MacArthur
     
    Leo, Dec 19, 2008
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.