can't ping Vista wireless lap top from LAN XP computers

Discussion in 'Windows Vista General Discussion' started by lucky_jack, Sep 29, 2007.

  1. lucky_jack

    lucky_jack Guest

    My configuration for this problem started as two desktop computers running
    Wndows XP Pro both connected to my private work group via an ethernet/DSL
    switch. Then I purchased a lap top with a wireless addapter (802.11g) in it
    running Vista Home Premium and swapped my Lan switch with a wireless/LAN/DSL
    router.

    I have it all working except: While I can ping the two XP computers from the
    Vista computer and access the files on the XP computers from the Vista
    computer, I can not do the reverse. A ping from either desktop to the lap top
    always times out, and I can not get the lap top to appear in the "network
    places" of the desktops.

    What must I do to get access to the lap top with Vista from the desktops
    with XP?
     
    lucky_jack, Sep 29, 2007
    #1
    1. Advertisements

  2. lucky_jack

    lucky_jack Guest

    By the way, I have tried all of this with my fire walls off and with them on.
     
    lucky_jack, Sep 29, 2007
    #2
    1. Advertisements

  3. lucky_jack

    Rick Rogers Guest

    Hi,

    Click start, type 'network and sharing' and hit <enter> to open the
    networking dialog. Enable network discovery as well as file sharing.
     
    Rick Rogers, Sep 30, 2007
    #3
  4. lucky_jack

    lucky_jack Guest

    Sorry, Rick. No go. I already had network discovery enabled. Besides, the
    Vista machine has no difficulties seeing files on the XP machines. It is the
    other direction I am having troubles with.
     
    lucky_jack, Sep 30, 2007
    #4
  5. lucky_jack

    Rick Rogers Guest

    Hi,

    Also make sure you are set as being on a private network. If you are set to
    public the machine will not be visible to other systems.
     
    Rick Rogers, Sep 30, 2007
    #5
  6. lucky_jack

    lucky_jack Guest

    Where do I find the "private network" setting in XP?
     
    lucky_jack, Sep 30, 2007
    #6
  7. lucky_jack

    Rick Rogers Guest

    Hi,

    In that same dialog, click 'customize' on the right, about halfway down.



     
    Rick Rogers, Sep 30, 2007
    #7
  8. lucky_jack

    Mick Murphy Guest

    Mick Murphy, Sep 30, 2007
    #8
  9. lucky_jack

    lucky_jack Guest

    OK. Lets take this one step at a time. With all I have done in implementing
    the responses I have received the symptoms I see have changed.

    First step, lets get the computers all talking together and lets get the
    "ping" problems fixed first.

    At this point I can:
    1) From the Vista laptop - ping desk top (XP) "a" by name and IP.
    2) From desktop "a" - ping lap top (Vista) by name and IP.
    3) From desktop "b" (XP) - ping desktop "a" by IP but not by name
    4) From desktop "b" - ping laptop by IP but not by name.

    I can not:
    1) From the lap top - ping desktop "b" by name or IP.
    2) From desktop "a" - ping desktop "b" by name or IP.
    3) From desktop "b" - ping desktop "a" by name (IP works).
    4) From desktop "b" - png laptop by name (IP works).

    Let's start with the basic question, what is wrong and on what machine and
    how do I verify it. (I am NOT going to make any more changes until I can SEE
    what the problem is! And I am only going to proceed one step at a time.)

    --
    lucky jack


     
    lucky_jack, Sep 30, 2007
    #9
  10. lucky_jack

    Rick Rogers Guest

    Hi,

    On "a" and "b", open a command prompt and run ipconfig /all. What mode type
    is each in?
     
    Rick Rogers, Sep 30, 2007
    #10
  11. lucky_jack

    lucky_jack Guest

    Rick,
    I do not find a "mode type" but I do find a "node type" so I assume that
    is what you mean.

    On "a" it is "mixed". On "b" it is "unknown". (For completeness, on the
    laptop it is "hybrid".)
     
    lucky_jack, Sep 30, 2007
    #11
  12. lucky_jack

    Rick Rogers Guest

    Hi,

    Fat fingers there, it should be "node". Ok, do this on both machines: Run
    regedit, navigate here:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netbt\Parameters

    Locate the Dhcpnodetype string and set it to 1 on both systems. The Vista
    laptop is fine as hybrid.



     
    Rick Rogers, Sep 30, 2007
    #12
  13. lucky_jack

    lucky_jack Guest

    Hi Rick,
    On machine "a" it was a four (I set it to 1). On machine "b" the
    parameter does not exist, so I added it to mirror the one on "a". Is there an
    action needed to activate these new registry values? (I am guessing a reboot
    of both desktops is needed.)

    And is there a special meaning to the Dhcpnodetype registration parameter on
    "b" not being there at all? When I installed the drivers for the router I was
    expecting instructions to put something on the "b" machine, but the install
    process was faulty and I had to get product support (for the router) to help
    me. I gave them the complete configuration of the net, but they didn't
    mention anything about putting anything on the "b" computer (and even though
    I wondered about it, I didn't ask). If so I will call them again to get the
    instructions. I have to also wonder about the Vista laptop, but I can imagine
    it already had what ever support code is needed for this router.

    BTW, before I got your last post, I had pings running from all machines to
    all machines, and I was able to copy files from both desktops to the laptop
    (but not from the laptop to the desktops). It turns out that I have two
    firewalls on "b" and they were both on. One is the Windows Firewall and the
    other was in Norton Internet Security.

    I saw some posts about sharing files that I will investigate later, once I
    am certain I have this "ping" problem fixed and stabilized.

    Thanks,
    Jack
     
    lucky_jack, Oct 1, 2007
    #13
  14. lucky_jack

    Rick Rogers Guest

    Hi,

    Yes, you need to reboot for the new entry to be active.

    "b" was messed up because the entry was missing. Most times, you don't
    actually need router software. Simply type the gateway address into IE's
    address bar to access it. This can be seen in the same ipconfig command.
    Normally, it's something like 192.168.0.1, just preface it with the normal
    http:// prefix.
     
    Rick Rogers, Oct 1, 2007
    #14
  15. lucky_jack

    lucky_jack Guest

    Thanks, Rick.
    That got all of the ping problems resolved, at least for the moment. I
    will be giving all I have done some time to "settle" just to make sure.

    BTW, in order to ping from "b" to the laptop by name I had to reboot the
    laptop. I guess the next test will be tomorrow after a night of powered off
    machines. Then on to finding out about the file sharing procedures.

    Rick, many thanks for your time and patience.

    Luck_Jack
     
    lucky_jack, Oct 1, 2007
    #15
  16. lucky_jack

    Rick Rogers Guest

    Cool, and yes the reboot is necessary for a node change to take effect. Let
    us know if there are any further issues.
     
    Rick Rogers, Oct 1, 2007
    #16
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.