Can't play .avi's, "COM Surrogate closed"

Discussion in 'Windows Vista Music, Pictures and Video' started by Jason, Aug 15, 2007.

  1. Jason

    zachd [MSFT] Guest

    I apologize. I do not understand the current problem that you are trying to
    solve. Could you please clarify? Thank you! =)
     
    zachd [MSFT], Feb 16, 2008
    #21
    1. Advertisements

  2. Jason

    veranyon Guest

    I wrote it on the previous page. there's last message
     
    veranyon, Feb 16, 2008
    #22
    1. Advertisements

  3. Jason

    evan s Guest

    i kno i doidnt install the ripper u did, and i dont kno what program cause it, so i uninstalled all the programs that i installed right befor the prob. anyway, i think about a week ago i started getting that message when i wnet to a fold w/ .AVIs in them(such as my collection of anime) when i looked up thing about the message, it i found many people saying the had problems playing .AVIs, vut at the time i didnt have trouble playing them after i updated my codecs(ive used the same codec brand for a long time, so i kno its not the codecs) anyway, yesterday i got a new episode of anime and tried to watch it when i discovered it had an X in a red circle next to the file name in the WMP now playing list, and was only playing the audio, no video!!! frustrated, i tried again, and as i watched the bottom of the screen, it said aquiring codec(usualy does) for longer then it usually does. i decided that maybe the vid. itself had problems, so i tried another .avi that i knew worked, and i had the same problem. so far, every place i've been to only tells me A)how to stop the message, not get it to play .AVIs again, B)That i need to get codecs, ect. to play the format, which i already have, and C) to uninstall some software i never in my live have had on this computer
     
    evan s, Apr 19, 2008
    #23
  4. Jason

    evan s Guest

    i don't know why this didn't work the other times i tried, but i guess that the current version of vista codecs has a problem, so i will temporarily use cccp, and it works, just doesn't have all the codecs i need for other videos, so ill keep tabs on if a new vista codec pack is available
     
    evan s, Apr 19, 2008
    #24
  5. Jason

    prestage Guest

    I have found a fix for this lol type in search ffdshow.ax then righ
    click, open file location, cut the file to desktop and try to play .av
    files and it should work it happened to me and this worked so give it
    shot
     
    prestage, Jun 13, 2008
    #25
  6. Jason

    creash Guest

    i am having pretty much the same problems as jason, and i do not have the
    k-lite codec pack. i have had this problem since a friend of mine downloaded
    a dvd ripper/converter onto my computer. i have uninstalled all of this, but
    the problem still persists. how do i fix it? can someone answer that?
     
    creash, Jun 25, 2008
    #26
  7. Jason

    creash Guest

    I'm having the COM surrogate problem as well, and i have no codec packs....
     
    creash, Jun 25, 2008
    #27
  8. Jason

    zachd [MSFT] Guest

    zachd [MSFT], Jun 26, 2008
    #28
  9. Jason

    creash Guest

    I re-installed DivX, and now I'm not having that problem. Now it just plays
    the audio on .avi's, but not the video...GRRRRR lol
     
    creash, Jun 26, 2008
    #29
  10. Jason

    zachd [MSFT] Guest

    I would still love to know that information as that might enable me to help
    others.

    What video codec does that video file use?
     
    zachd [MSFT], Jun 26, 2008
    #30
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.