cant run defrag couse drive keeps geting dirty bit set

Discussion in 'Windows Small Business Server' started by John, May 3, 2006.

  1. John

    John Guest

    i have an 800 Gig raid 5 array . can seem to get defrag to run . i get an
    error in event viewer that the file system strusture is corrupt. i run chkdsk
    /f. it did not find ant errors. every time the computer restarts it runs
    chkdsk. does not find any errors. then after arround 5 to 10 min i get the
    ntfs error aggain.

    any ideas ?
     
    John, May 3, 2006
    #1
    1. Advertisements

  2. This kind of thing is almost always hardware-related. If you run chkdsk and the errors return, then there is likely a problem with the disk subsystem, including possibly the
    RAID controller, one or more individual drives, drivers, firmware, etc.

    First, you need to make sure you are getting regular backups because this could be a sign of a serious problem.
    Second, you should update all of the firmware and drivers for the RAID controller, etc.
    If that does not resolve it you should consider replacing the controller.
    You should perform whatever hardware diagnostics are available to you for your hardware.
    In a rare case I worked on an issue in which it appeared that anti-virus was corrupting the MFT on the file system, but that's pretty unlikely. But you might try doing a clean
    boot using msconfig to disable 3rd party services, or just boot into safe mode to see if you get the same thing.

    How long after a reboot before the errors start occurring? I'm assuming you are getting event 55 from NTFS.


    HTH,
    Regards,

    Jim Martin, MCSE 2003, 2000, NT 4.0
    Microsoft Corporation

    This posting is provided "AS IS" with no warranties, and confers no rights
     
    Jim Martin [MSFT], May 3, 2006
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.