Can't Update or Install/Uninstall Silverlight

Discussion in 'Windows Vista General Discussion' started by PeoplesChoice, Feb 21, 2010.

  1. Microsoft says I need some updates to Silverlight. I can't use the
    updates (error code 64C), I can't uninstall or Install it (the feature
    you are trying to use is on a network resource that is unavailable.) What
    should I do?
     
    PeoplesChoice, Feb 21, 2010
    #1
    1. Advertisements

  2. PeoplesChoice

    Peter Foldes Guest

    Peter Foldes, Feb 21, 2010
    #2
    1. Advertisements

  3. Ǝиçεl, Feb 22, 2010
    #3
  4. PeoplesChoice

    Mr. Yazen J. Qafisheh

    Joined:
    Feb 27, 2012
    Messages:
    1
    Likes Received:
    0
    One Method to Successfully Uninstall then reinstall a WORKING! Microsoft Silverlight

    Well I had quite another fun Vista adventure. No, not with the Windows Update not working for about a year (resolved), but this time with Silverlight getting all jacked up. The problem once again stemmed from bad or corrupt registry key related issues. I searched the web for a little bit & came across lots of stupidly obvious suggestions from lots of places & people (even on Microsoft sites where supposed tech experts were telling people with issues "Try going to the control panel folder & use programs & features to uninstall through there then reinstall. Really? Good God...) I tried uninstalling that way first or IIRC Silverlight didn't even show up in there. Tried Revo Uninstaller which found a bunch of Silverlight related files around the drive & deleted them. However I still couldn't install a new Silverlight. It would get hung up @ 99% then stop. Before I started making progress with the registry key modifications it would get hung up before the install & say something like "The source you're trying to install from cannot be found, insert disc or choose location" or something. The Microsoft Fix Its did not work but their failure to work pointed me in the right direction.

    One of the 2 or 3 Fix Its I tried displayed an error code about a particular registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{DFEAF54 1-F3E1-4c24-ACAC-99C30715084A}. It would say "Could not open, etc., etc., etc., Access Denied." The permissions were all whacked out & I couldn't delete the key manually by right clicking on it then going to delete. For those of you who don't know, click on the start button in the bottom right hand corner, go up to RUN, type in regedit, then hit enter. It will launch the registry editor. As always be careful with registry modification & do make a backup before trying stuff like this. Otherwise u may end up with a non-usable/ seriously corrupted drive or something.

    So I navigated to the key & had to do some tedious work to reassign the permissions & ownership of the key. & should you read this & have the EXACT same issue you will have to go through each of the 8 subkeys & reassign the permissions & owner if they aren't what they're supposed to be. & one of them ("MiscStatus") has yet another subkey called "1.". Go through each one starting at the bottom at the lowest level, right click on the name of the subkey, go to permissions, look up at the top under Group & User Names, & click Remove till there are none left. Then click ADD then type in whatever your user name is that you're logged in with. It took me a while to figure out what my user name is. I don't log in, my computer just starts up. So for me all I typed in was "Yaz," my user name I chose long ago when I 1st got my laptop. Your user name by itself is all you type in. No other characters. I am the administrator so there were no issues. Then underneath I clicked on the 1st box on the left & assigned myself full control over the subkey. Then click Advanced & make sure neither of the 2 inheritable boxes are checked. Click on the Owner tab at the top & make sure an owner is assigned & that it's your login name.

    After doing this for all 9 of the subkeys I was able to just right click on {DFEAF541-F3E1-4c24-ACAC-99C30715084A} & go to delete & IT WORKED! Then I finally launched Silverlight installer & it worked with no further problems. Hopefully this helps some people out. There are a lot of dumb, obvious suggestions out there (just like with the Vista Windows Update not working) & it's nice to be able to figure out how to resolve it this time in an hour or two as opposed to about a year last time there was a registry related issue that nothing would fix other than manually deleting the associated bad keys myself that were left behind by all the uninstallers, Fix Its, & other programs & solutions that did nothing but waste more time.

    Sincerely,

    Mr. Yazen J. Qafisheh
     
    Mr. Yazen J. Qafisheh, Feb 27, 2012
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.