cdrom.sys corrupt in Win7 - need help to fix

Discussion in 'Windows 64 Bit' started by Jim McCants, Feb 27, 2010.

  1. Jim McCants

    Jim McCants Guest

    Yesterday Win7 decided to no longer show my 2 LiteOn DVDRW drives. I've
    tried to re-install/repair the driver (6.1.7600.16385) and everytime I get
    the same response = my current driver is good. BUT, then when I check with
    Device Manager, it shows that the drives are not working. Can anyone help me
    get a new cdrom.sys installed into the system32/drivers folder?

    Booting up with the Win7 DVD will work. But I can't find the cdrom.sys on
    the disk. No other repair options are there to get this fixed.

    Help would certainly be appreciated. I don't want to have to start all over
    with a full format and installation.

    Thank you very much!

    Jim McCants
     
    Jim McCants, Feb 27, 2010
    #1
    1. Advertisements

  2. Jim McCants

    R. C. White Guest

    Hi, Jim.

    Have you tried the System File Checker? sfc /scannow

    See http://support.microsoft.com/kb/929833
    How to use the System File Checker tool to troubleshoot missing or corrupted
    system files on Windows Vista or on Windows 7

    RC
    --
    R. C. White, CPA
    San Marcos, TX

    Microsoft Windows MVP
    Windows Live Mail 2009 (14.0.8089.0726) in Win7 Ultimate x64
     
    R. C. White, Feb 27, 2010
    #2
    1. Advertisements

  3. Jim McCants

    Tom Guest

    Did you per chance install any of the software that came with the drives as
    well? I have seen where it can hose any drivers that are needed fore use
    from Windows? If so, remove them all in their entirety, then uninstall all
    drivers while in the device manager by right clicking on the devices and
    then delete the drive(s) from the device manager. Reboot, then try and
    update the device manager by having it search for the best driver after
    those device(s) reappear after the reboot. If that doesn't work, see if
    Lite-on's website has the driver for the operating system for your
    particular model updated.

    If Lite-on's solution is a no-go, then try using the sfc /scannow in the
    start/run (or in a command prompt), then see what happens. You may also want
    to check and see if the drive(s) have a well seated connection as well, by
    reseating them; that would be the last resort, then try again to update the
    drivers again.
     
    Tom, Feb 27, 2010
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.