check disk not working

Discussion in 'Windows Vista Performance' started by michael56555, May 5, 2008.

  1. michael56555

    michael56555 Guest

    Check disk will not run at startup. Runs in read only mode without a
    problem. Have tried sfc /scannow. Have replaced autochk file. Have tried
    from elevated prompt, drive c: properties, as well as in safe mode. Tried
    Vista x64.com tutorial methods. Have searched the web with no luck.
    Any suggestions?
    Mike

    Lenovo R61
    T8300 duo processor
    2 gb ram
    100 gb, 7200 rpm hard drive
    4gb readyboost
    Windows Vista Business
    SP 1 not installed (another major issue for another post)
     
    michael56555, May 5, 2008
    #1
    1. Advertisements

  2. michael56555

    t-4-2 Guest

    Hello michael56555,
    " not working" or " with no luck" will not help us to help you. What
    will help us is to tell us the procedures you used attempting to run
    check disk, and what did the screen say i.e. what did the command prompt
    say after you type in the command.
    Show us how you type the check disk command.
     
    t-4-2, May 6, 2008
    #2
    1. Advertisements

  3. michael56555

    michael56555 Guest

    There is not much else to tell. There are no error messages. When setting
    it up for check disk, it gives the normal Can not run... would you like to
    schedule it for the next reboot. Then it just doesn't start. The machine
    boots normally. This happens whether using the properties box or elevated
    command prompt, in safe mode or normal operating mode, whether booting into
    safe mode or from safe mode to normal, or from safe mode to safe mode. Tried
    with UAC enabled and disabled.

    I described in my first post what procedures I attempted. Not sure that I
    need to describe each individual action for each attempt.
     
    michael56555, May 6, 2008
    #3
  4. michael56555

    t-4-2 Guest

    Ok, when you were asked if you wanted to run disk check at boot, did
    you type y as in yes ?
     
    t-4-2, May 6, 2008
    #4
  5. michael56555

    michael56555 Guest

    Ok, when checking the disk for errors with check disk, I usually go to My
    Computer left click on C: drive (I am left handed and have buttons
    switched...before you ask) go to the tools tab, click on "This option will
    check the volume for errors" click the check now button, click th
    eAutomatically fix file system errors. Then click start where it tells me it
    can't and would I like to schedule it at restart. I click yes and restart
    the computer.

    When the computer restarts, it starts normally and does not run check disk.

    If I run it from the elevated prompt, I type in chkdsk /f in the search area
    of the start button. I left click on the file presented at the top of the
    box and select "run as administrator. (this part is a new problem) it
    starts in read only mode and tells me that the "F" switch was not selected.

    If i execute it from the Run box, I type in chkdsk /f and it asks me if i
    want to schedule it at the next computer start. I type in "y" and then
    restart the computer. Check disk does not run and it boots normally.

    If I try these functions in safe mode, the same thing happens.

    I have run chkdsk (or scandsk) since Dos 3.1.... I am computer literate
    enough to do all the normal things.

    Running it in read-only mode now tells me I have unindexed files so I need
    to get this issue straightened out .

    Scannow cfe finds no problems. Replacing the autochk file did not help.
    Went through x64.com tutorial..that didn't help. Nothing I have found online
    has produced a solution.

    I created a bootable CD when I bought the computer, but can't figure out how
    to get a D: prompt because it starts the Lenovo recovery and diagnostic
    functions. Running them doesn't find anything wrong.

    I have not tried pulling a chkdsk.exe off of my old XP machine...maybe that
    will work.
    Thanks,
    Mike



    Any help would be appreciated.
     
    michael56555, May 8, 2008
    #5
  6. michael56555

    t-4-2 Guest

    Hello michael,
    Bear with me. Try it my way :-
    Start menu > search box, type cmd > right click (I'm right handed) cmd
    at top > click Run as Admin > command prompt appears ( see screenshot
    below) > now you can type chkdsk /f at the prompt. Does it work for you
    this time ?
    Please click the link to see screenshot.
    'ImageGrotto: Free Image and Screenshot Hosting'
    (http://imagegrotto.com/view-command_prompt10666.JPG)
     
    t-4-2, May 8, 2008
    #6
  7. michael56555

    t-4-2 Guest

    Here is a screenshot with better illustration. Please click the link.

    'ImageGrotto: Free Image and Screenshot Hosting'
    (http://imagegrotto.com/view-cmd310668.JPG)
     
    t-4-2, May 8, 2008
    #7
  8. michael56555

    t-4-2 Guest

    Here is a better screenshot for illustration

    'ImageGrotto: Free Image and Screenshot Hosting
    (http://imagegrotto.com/view-cmd310678.JPG
     
    t-4-2, May 8, 2008
    #8
  9. michael56555

    michael56555 Guest

    I have run chkdsk /f from the cmd prompt as you describe with the same results.

    However, I went back to the C: properties and clicked on Fix errors and the
    second box to fix disk errors. This time when I reboot, I get this:
    Checking file system on C:
    Type of the file system is NTFS
    Cannot open volume for direct access

    I ran an elevated command prompt and ran chkdsk /x/r to force dismount the
    drive and get the same result with the can't access comment.

    I enabled the boot log but do not see anywhere that it is loading check
    disk. Perhaps it doesn't start recording until the drive is mounted. Any
    ideas?
    Mike
     
    michael56555, May 8, 2008
    #9
  10. michael56555

    t-4-2 Guest

    Hello michael
    I'm stumped. I'll try to look for answer. Meanwhile here is a link --
    a LONG list --- for you

    'Search The Knowledge Base
    (http://support.microsoft.com/search...+run&catalog=LCID=1033&1033comm=1&spid=global
     
    t-4-2, May 8, 2008
    #10
  11. michael56555

    t-4-2 Guest

    t-4-2, May 8, 2008
    #11
  12. michael56555

    michael56555 Guest

    The problem: Something is loading before the check disk program.

    The work-around: Schedule the check disk run, then go to Run, msconfig, boot
    tab and click on Safe boot with the "minimal" button selected. Scan Disk ran
    just fine.

    I don't know why it wouldn't run when booting to safe mode.

    I don't know what is process is starting that is preventing it. I will have
    to check what I have installed lately. It is not my anti-virus. Hope this
    helps.

    Thank you for your help.
    Mike
     
    michael56555, May 8, 2008
    #12
  13. michael56555

    GreggMack Guest

    michael56555 and t-4-2,

    I have been following this closely, as I have had the same situation as
    michael56555, and I have also tried every single method that he has tried
    right up until this point. Here is where we now diverge - michael56555 is at
    least now getting:

    Checking file system on C:
    Type of the file system is NTFS
    Cannot open volume for direct access

    I'm still getting nothing more than what appears to be a "normal boot". I
    do sometimes hear 3 very faint "boop - boop - boop" sounds, like it has
    encountered something that it wants to tell me about - but that's just after
    I log in, not while it's booting up.

    I have a Dell XPS-M1530 laptop with Vista Home Premium, and as best I can
    tell it came with SP1 installed.

    I'll keep scouring through this stuff until I find a solution. I am unable
    to run Diskeeper 2008 Premium Pro on this partition - and I only bought that
    expensive program to run on this laptop.

    Thanks
    Gregg
     
    GreggMack, May 8, 2008
    #13
  14. michael56555

    michael56555 Guest

    Greg,
    I didn't get the message until I set it to check for disk errors as well as
    file errors. When I just asked it to check for file errors it appear to just
    boot normally. You may try checking for both to see if you get the message.
    If you haven't yet, I would try my msconfig solution to see if that works. I
    have seen where others could not do a boot time defrag and I bet the problem
    has the same roots. Let me know if the msconfig solution worked for you as
    it did for me.
    Mike
     
    michael56555, May 8, 2008
    #14
  15. michael56555

    GreggMack Guest

    Mike,

    I have searched back through this thread and can not find your "msconfig"
    solution.

    To recap, here's what i have tried:

    Method 1: Right-click on C: drive -> choose Properties -> Fix Errors (I
    think that's what it is.... I'm on an XP machine right now) -> and checked
    BOTH boxes.

    Method 2: Start -> type "cmd" in the search field -> right click on cmd at
    the top -> choose Run as Administrator -> Command Promp appears -> type
    chkdsk /f (and I've tried "chkdsk C: /r") -> respond by typing y and Enter.

    Method 3: Went through an excellent x64.com tutorial by Blink that had me
    make a change in Regedit and then replace the autochk.exe file.

    I won't be home for several more hours to try the "msconfig" solution, and
    I'll have to try to locate it first.

    Thanks!
    Gregg
     
    GreggMack, May 8, 2008
    #15
  16. michael56555

    michael56555 Guest

    Greg,
    This thread has gotten way to long. The solution that worked for me:

    The problem: A process is loading before the check disk program.

    The work-around: Schedule the check disk run, then go to Run and type in
    msconfig. Go to the boot tab and click on Safe boot with the "minimal" button
    selected. Scan Disk ran (for me) just fine.

    I don't know why it wouldn't run when booting to safe mode.

    I don't know what is process is starting that is preventing it. I will have
    to check what I have installed lately. It is not my anti-virus.
    Hope this helps.

    Mike
     
    michael56555, May 9, 2008
    #16
  17. michael56555

    michael56555 Guest

    Greg,
    This thread is getting way too long! Below is what worked for me:

    The problem: A process or program is loading before the check disk program.

    The work-around: Schedule the check disk run, then go to Run and type in
    msconfig Go to the boot tab and click on Safe boot with the "minimal" button
    selected. Reboot and scan Disk should run.
    just fine.

    I don't know why it wouldn't run when booting to safe mode.

    Not sure what is process is starting that is preventing it from running. I
    will have
    to check what I have installed lately. It is not my anti-virus. Hope this
    helps.
    Mike
     
    michael56555, May 9, 2008
    #17
  18. michael56555

    t-4-2 Guest

    Hello Michael
    So happy that you have solved the problem. I have a wild speculation
    it's not what you had installed lately, it's what you had FAILED t
    install, i.e. SP1
     
    t-4-2, May 9, 2008
    #18
  19. michael56555

    t-4-2 Guest

    What I'm trying to say is something got messed up during installing an
    un-installing SP1
     
    t-4-2, May 9, 2008
    #19
  20. michael56555

    GreggMack Guest

    Mike,

    I agree this has gotten way too long, but this message should end it all..
    I have fixed my laptop!

    Let's call you msconfig "minimal boot" as Method #4 - it worked for you, but
    not for me.

    Method #5 - from the x54.com forums, I saw a suggestion by RJCC that he used
    to fix his HP laptop. It got me started down the same path, but I was not
    presented with the same options on my Dell laptop. Here's how it went:
    - Restart the PC and as is begins to come back up, immediately start hitting
    the F8 key at least once every second.
    - This gets you into the DOS-looking screen with several different boot
    options.
    - Choose "Repair Your Computer"
    - Selected a keyboard layout (US)
    - Used the pull-down menu to select my User Name and entered my password.
    - Selected the top option named "Startup Repair".
    - The rest was all automatic - it did report that it was repairing disk
    errors, but gave no indication of what it had found, or what it ended up
    doing.
    - It never did run chkdsk on the next or subsequent boots, but it did unlock
    the "Dirty Bit".
    - Now I can Diskeeper 2008 can run automatic, as well as manual,
    defragmenter on my C: drive.
    - That solved my problem!
     
    GreggMack, May 10, 2008
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.