checksum errors reading data from network share

Discussion in 'Windows Vista Networking' started by Dave, May 30, 2007.

  1. Dave

    Dave Guest

    I have a Vista machine that uses a network share from an XP Pro system
    running thru a 1G Netgear switch.

    I am having some sort of I/O errors reading and possibly writing files
    from/to a network share that results in validation and checksum errors.
    However I copied a large 26G file to the network share, and the file
    checksumed fine on the machine that owns the share. I think the error
    happens only when reading from the XP share.

    In particular, Acronis TI cannot validate a large 26G backup file created on
    the network share however if I backup locally and then copy the file to the
    network share then the XP machine can validate the file.

    MD5 also checksumed the file copy just fine running on the machine that owns
    the share matching the original but MD5 repeatedly gets different checksums
    against the network share from the origin machine.

    So it seems that file copy to the share works OK but Acronis TI and the MD5
    programs get errors reading from the share.

    I get no OS or event log complaints and I have extensively run memtest86 and
    chkdsk against the machines and all the drives with no issues whatsoever.

    Has anyone else seen problems like this?

    Anyone have suggestions on determining if it is the gear or MSFT software?
    Odd that file copy of the 26G file works fine in both directions (to the
    share and back again) and still verifies and checksums the same but reading
    the file from the share appparently gets errors in data that are not
    detected by the OS and so fails to checksum.

    *** Is there anyway to turn checksums on for the data packets at either the
    lower or upper layers of the IP stack or SMB protocol so the block is resent
    if checksum is bad???

    *** Would somehow using IPV6 between the machines be possible or help?

    Thanks,
    Dave
     
    Dave, May 30, 2007
    #1
    1. Advertisements

  2. Dave

    Dave Guest

    MSFT folks. Is this possibly an issue with Vista?

    I have a 26G file from a backup that I can consistently copy to the XP owned
    share and it checksums fine but when I copy it back from XP to Vista the
    file is always corrupted per the checksum.

    If I repeatedly checksum the file on Vista it get a consistent checksum
    helping rule out memory issues on Vista and I have run memtest386 as well as
    chkdsk that show no issues.

    Please comment or make suggestions. Thanks.

    - Dave
     
    Dave, May 31, 2007
    #2
    1. Advertisements

  3. Dave

    Dave Guest

    Looks like it was not Acronis' nor Vista or XP problem at all.

    I have narrowed the problem down to my Intel Pro/1000 GT OEM card.

    Acronis originally had the problem but I also had problems when I copied
    large files to my Vista machine from a network share on my XP machine.

    Files copied from Vista to the XP machine that had the Intel card copied
    fine and always checksummed. Files copied from the network share to the
    Vista machine would sometimes be corrupted.

    I made 6 copies of a 100M file on the XP network share and then would copy
    them from there to a local Vista directory. 1 or 2 of them would normally be
    corrupt.

    Using another ethernet adapter the problem went away.

    Intel support first told me that I had to use the original Cat5 cable and
    that Cat5e was specifically NOT supported per their web site and when I
    asked for the reference was shown a paragraph that said the card supported
    Cat5. I had to explain they did not even make the old Cat5 cable anymore and
    that the old spec was not even a standard anymore and had been replaced by
    the Cat5e (for "e"hanced) specification.

    Then I was told by another support person that I had the OEM version of the
    adapter and had downloaded the retail driver and that was probably why it
    did not work and was given an example that this OEM card would not run in
    an HP laptop at which point I had to explain that was probably because
    laptops don't have PCI slots and he said it was just an example.

    They proceeded to blame everything else under the sun and just ignored the
    fact that things worked if I did not use their enet card and told me that if
    I could get to the internet then that proved the card worked fine which I
    explained was an absurd conclusion.

    Also explains why remote desktop would often disconnect with a checksum
    error while I was playing a streaming video on my XP machine and watching it
    on the Vista machine. Was because of the volume of data that would finally
    be corrupted by the Intel card.

    Anyway. I am going to go buy another 1G enet card and will never use Intel
    again as their support has not a clue.

    - Dave
     
    Dave, Jun 1, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.