Chkdsk Hangs every time. Disk reports OK?

Discussion in 'Windows Vista General Discussion' started by Adam, Jun 7, 2008.

  1. Adam

    Adam Guest

    Hi All,

    On Vista Home Premium, I've set Chkdsk to run but each time it hangs
    about three quarters of the way through step 5, at the same cluster
    each time. I've run the harddisk tests (SMART, surface scan etc) from
    the computer recovery console and it passes every test OK.

    If this a physical problem with the drive or a file system one? If
    it's the latter why can't Chkdsk fix it? It's a new computer should I
    go through the hassle of returning it to the manufacturer?

    Thanks a lot,
    Adam

    P.S. History: it's a brand new Lenovo laptop. When I first switched it
    on, it gave me that "Vista didn't shut down properly last time"
    screen, but apart from that everything seemed OK until I got most of
    the way through all the security updates, cleaning up all the bundled
    software etc and Windows Update blankly refused to install SP1. I
    tried a system restore and that told me there was a disk error and to
    run Chkdsk. Chkdsk refused to run (something about the drive being
    locked) and in the end I did a factory reset. This is OK in that now
    all the updates have installed and there are no more errors, but I
    wanted to double check the disk, so invoked Chkdsk and... see above.
     
    Adam, Jun 7, 2008
    #1
    1. Advertisements

  2. Adam

    Adam Guest

    I've also tried downloading the Western Digital hard disc diagnostics,
    but they're not available for use with Vista :((

    Adam
     
    Adam, Jun 7, 2008
    #2
    1. Advertisements

  3. Adam

    Malke Guest

    "Brand new Lenovo laptop" + problems right out of the box = call Lenovo tech
    support immediately for repair/replacement.

    Malke
     
    Malke, Jun 7, 2008
    #3
  4. Adam

    solon fox Guest


    Stage 5 is verifying freespace. You may have a lot of freespace and
    chkdsk may appear to freeze yet still be working. Is the hard drive
    light blinking, or does it stop? If chkdsk will continue to fix
    problems, but sometimes if it finds too many, it needs to start over
    and will loop. I've seen chkdsk run all day and all night in some
    cases. If there doesn't appear to be any hard drive activity, then I
    would be concerned -- although, it can pause for several minutes while
    it maxes the cpu and memory with no apparent hard drive activity.

    One could remove the drive and run chkdsk with the drive as a slave to
    another, or one could download additional drive verification utilities
    from the drive manufacturer; but, since it is under warranty I'd call
    tech support and complain. Let them figure it out or ship you a new
    drive or a new laptop.

    I wouldn't fret about SP1 not installing. As you've probably learned,
    there are lots of reasons that SP1 doesn't install; certain hardware,
    drivers, OEM utilities or other software incompatibilities will
    prevent SP1 from automatically downloading and installing. As those
    problems are resolved, you will receive updates through Windows Update
    and eventually SP1 too.

    -solon fox
     
    solon fox, Jun 7, 2008
    #4
  5. Adam

    Adam Guest

    Yes. The trouble is... I've already done that. This laptop is a new
    (different model) replacement for another broken (different problem)
    Lenovo :(

    It was a real hassle trying to convince them there was anything wrong
    with that one - and the symptoms were *way* more serious (it wouldn't
    turn on!). I don't have much faith in tech support either finding any
    problem or solving it :(

    Thanks,
    Adam
     
    Adam, Jun 7, 2008
    #5
  6. Adam

    Adam Guest

    Yes, the light stops. I left it in that state over night and nothing
    changed, so it seems pretty likely that chkdsk crashed.

    [snip]
    Unfortunately Western Digital don't support Vista with their
    diagnostic tools :(
    I tried the DOS-based ISO image but that seems to think it's running
    from a floppy and keeps referring to not being able to find files on
    A:.

    I seem to be at a dead end :(

    Adam
     
    Adam, Jun 7, 2008
    #6
  7. It sounds like you set the option to force Chkdsk to scan the surface
    of each sector. Have you first tried the much faster and simpler
    option of simply "fixing errors" without checking the surface of every
    sector?

    I suspect some clusters are simply cross-linked. NTFS should normally
    fix these easily at the expense of losing whatever is in these
    clusters. Chkdsk can actually out smart itself and hang at the same
    place each time where if set to the simpler option simply fly through
    the drive and actually fix it. If something is truly wrong with one or
    more clusters those are useless at this point anyway.
     
    Adam Albright, Jun 7, 2008
    #7
  8. Adam

    Adam Guest

    Yes, that runs through fine.

    Do you mean if I do the short chkdsk, then a following long chkdsk
    might work all the way through?

    I'm hoping that my problem is a quirk with chkdsk rather than
    something wrong with my disc!

    Thanks,
    Adam
     
    Adam, Jun 7, 2008
    #8
  9. Unfortunately Western Digital don't support Vista with their
    diagnostic tools :(
    I tried the DOS-based ISO image but that seems to think it's running
    from a floppy and keeps referring to not being able to find files on
    A:.

    I seem to be at a dead end :(

    ____________________________________________________

    There must be a way to use the WD diagnostics without a floppy drive, as I
    had to use it when one of my Raptors was showing a SMART error. I must have
    used the CD image, as I do not have a floppy drive on my main desktop PC,
    and it was before I bought a USB floppy drive. I /may/ have used the UBCD,
    but I doubt it. It may be worth you trying it though.

    http://www.ultimatebootcd.com/

    ss.
     
    Synapse Syndrome, Jun 7, 2008
    #9
  10. Adam

    Adam Guest

    Well, if there is, I haven't worked out how! I've asked WD tech
    support though...
    Great, thanks for that. Although none of the three WD apps on that CD
    worked (one caused a kernel panic, one just hangs half way through the
    licence screen and the last one can't find a disc to check), I finally
    got ViVard working and did a complete check of the disc surface
    without any problems showing up :)

    Cheers,
    Adam
     
    Adam, Jun 8, 2008
    #10
  11. Great, thanks for that. Although none of the three WD apps on that CD
    worked (one caused a kernel panic, one just hangs half way through the
    licence screen and the last one can't find a disc to check), I finally
    got ViVard working and did a complete check of the disc surface
    without any problems showing up :)

    -------------------------------------------------------------------------------
    No problem. I just thought of a reason why the other apps were not working
    on your laptop. They may need the SATA controller be put in Legacy IDE
    mode, so that the controller pretends to the OS (in this case the DOS or
    Linux based OSs on the CD) that the drives are IDE drives. That may be
    necessary for the Floppy Emulation to work, but I am not certain. I am also
    not sure that doing this is even possible on the ThinkPad BIOS (my X31 and
    X40 have IDE drives). Most probably not.

    ss.
     
    Synapse Syndrome, Jun 8, 2008
    #11
  12. Adam

    jersnav Guest

    Hi,
    I am having this exact same problem.

    Chkdsk freezes during the surface scan (step 5) 83% of the way through.

    Did you ever resolve this?

    Thank you,
    Jeremy

     
    jersnav, Aug 12, 2008
    #12
  13. Adam

    Chad Guest

    Did you ever get a resolution to this issue?

    I'm having a similar issue on my new Lenovo ThinkPad T61.

    It worked great for a couple of weeks, and then frooze on my at least once a
    day three days in a row.

    During the course of troubleshooting, I decided to do a full disk check. It
    freezes every time during stage 5 (the free space scan) at 80%. It's not
    always exactly the same cluster number, but in the ballpark. I leave it for
    hours and the cluster number doesn't change, so it seems to be locked up.

    The problem is I still don't know if it's really the hard drive or something
    else.

    Other things I've done:
    - Run all the PC Doctor tests, including the drive tests - passed both when
    running from boot and running under Vista
    - Run a memory tester from Microsoft all night long - no lock up
    - Installed utilities to monitor CPU and other temperaturs - no apparent
    heat problems
    - Run a drive fitness testing utility from the drive's manufacturer
    (Hitachi) - no errors

    I'm just about out of ideas. Why would it pass the drive manufacturers tests
    and yet dskchk can't get through it without freezing?

    Anyone?
     
    Chad, Sep 27, 2008
    #13
  14. Adam

    Larry Guest

    I am experiencing the same problem with a brand new HP 9700t laptop. Has
    anyone come up with a resolution to this yet?

    My scenario is...

    System - Brand new HP Pavilion dv9700t CTO laptop
    hdd - 320GB
    mem - 3GB
    BIOS - Phoenix BIOS (HP ver. F.58 A - currently the latest and which btw is
    extremely locked without many options)
    OS - Vista Ultimate SP1 64-bit

    I have removed the HP recovery partition and increased the C partition to
    the full 320GB with Parted Magic. I am not experiencing any problem when
    booted to Windows, everything works great. Chkdsk /r works fine when I slave
    the hdd to another OS(Vista or XP). My problem is when I attempt to run
    chkdsk /r as a scheduled task on reboot. All stages progess fine thru to the
    5th step and then I have gone as far as leaving the system running for 48hrs
    at step 5 to see if it would eventually complete - no luck.

    My hunch is that this is a Vista issue possible with the amount of memory
    and the BIOS of manufacturer.

    Any insight is much appreciated.

     
    Larry, Sep 28, 2008
    #14
  15. Adam

    Chad Guest

    It's the system drive, so in order to lock the volume Windows schedules it to
    run on reboot. So I can't see how any files are being modified.

    Other ideas out there?

    I too am starting to suspect a Windows memory leak or something, but I don't
    have anything to base that on really.

    Chad
     
    Chad, Sep 28, 2008
    #15
  16. Adam

    Jon Guest




    My guess would be that the main issue here is just the size of the system
    drive. In this age of super mega-sized drives, it's easy to forget just how
    much space say a 320gb drive really is. Checking the freespace on a drive
    has always been a notoriously lengthy process. While hard drives have
    exponentially increased in size the algorithm for checking freespace has
    not, I would suspect, undergone a comparable change.

    So the only thing I can suggest is to try splitting up your hard drive into
    smaller, more manageable partitions, and then to retry the freespace check
    with those smaller 'chunks'.
     
    Jon, Sep 28, 2008
    #16
  17. Adam

    Chad Guest

    Okay, thanks to both Jon (who sort of confirmed my suspition that this might
    just be a software problem) and Stubby, who suggested twice that I run it
    from the repair console (though the first time for a reason that didn't make
    sense to me).

    I didn't know how to get into the Repair Console (Recovery Environment?),
    but one time I did press F8 on boot and selected Safe Mode with command
    prompt or something like that, thinking that might be close. CHKDSK froze in
    the same way that time.

    Then I started reading online about booting from your Vista install disc and
    selecting the option to repair things. Well, Thinkpads don't come with a
    Vista install disc; they only give you discs (and/or the ability to make
    discs) that will restore the hard drive to the factory state, but no repair
    options.

    I messed around in Vista trying to create a boot CD, but could find no such
    options.

    Finally I found a place to download an image of the Vista Recovery Disc
    (follow links from
    http://www.downloadsquad.com/2008/0...ion-cd-you-can-still-download-a-vista-recover).

    I burned a recovery disc, booted from that, ran chkdsk from a command prompt
    window in there, and it actually completed! With no errors! (Except one at
    the end about not being able to write out the log, no doubt because it had to
    unmount the volume first.)

    So I'm now satisfied that the intermittent system freezes I was experiencing
    are not related to my hard drive (or any other hardware, given all the other
    tests I've run).

    Thanks for your help.
    Chad
     
    Chad, Sep 29, 2008
    #17
  18. Adam

    Larry Guest

    Okay, okay, it appears that running chkdsk from the recovery cd is a viable
    alternative and/or workaround, but the root cause is still unanswered and is
    likely a memory, bios and large partition issue.

    I have successfully ran chkdsk /r by booting to the Vista recovery cd, as a
    matter of fact the chkdsk /r completed inside of an hour on my 320GB hdd. I
    can live with this scenario but I hope to see a resolution by microsoft in
    the future.

    Thanks for the suggestions.
     
    Larry, Sep 29, 2008
    #18
  19. Adam

    Tim Guest

    I have run into the same issue, however when I try to do the same thing you
    did, I run into a brick wall: the drive is write protected. Can I use "attrib
    -R" and then run the "chkdsk /r" command? I know that all of the Windows up
    until Vista has the attrib.exe option to use to fix the Write-Protection.
    Or... would I need to log into Vista and disable UAC?

    Thanks,
    -Tim
     
    Tim, Nov 18, 2008
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.