Civ IV with Vista?

Discussion in 'Windows Vista Games' started by Jack B, Aug 13, 2007.

  1. Jack B

    Jack B Guest

    I just loaded my old copy of Civ IV on my newer Vista machine, and it isn't
    working. Vista tells me there are compatibility porblems and I should
    contact Firaxis. I see in this forum that Civ IV is on the list of games
    that work in Vista. I tried loading patch 1.61, but that doesn't seem to
    work either.

    Does anyone know what I need to do?

    Thanks,

    Jack
     
    Jack B, Aug 13, 2007
    #1
    1. Advertisements

  2. Jack B

    Carl Guest

    run as administrator, and if that fails, use compatibility mode for XPSP2
     
    Carl, Aug 14, 2007
    #2
    1. Advertisements

  3. Jack B

    geekmd Guest

    Hey there,

    Just ran into the same problem with Civ IV. It is fixable. When you
    first install the game - don't look for a Windows comaptability fix -
    just start the game - go to Advanced and run auto-update. After that -
    go to the Firaxis website and the support section for game startup.
    There should be an error message you get about missing DX3_DLL.32 or
    something - the Firaxis site will direct you to the DirectX 9.0c update
    needed to run the game on Vista. Thank GOD I found this - I am going on
    a cruise with in-laws next week and would go insane without some good
    games to play on my laptop.

    Good luck with the fix.

    Craig
     
    geekmd, Aug 14, 2007
    #3
  4. Jack B

    Jack B Guest

    When I try and start the game, it asks for the correct disk (which is
    already in the drive).

    I get the same result after I switched to compatibility mode for Svc Pack 2.

    Jack
     
    Jack B, Aug 14, 2007
    #4
  5. Jack B

    geekmd Guest

    The Disks are labeled incorrectly. The INSTALL disk is needed to play -
    NOT the PLAY disk. - it is also posted on the firaxis site that they
    screwed up the disk labelling. :)

    Good luck.
     
    geekmd, Aug 16, 2007
    #5
  6. Jack B

    Tizzy Guest

    I haven't had any problems with Civ IV running on vista, I'm running it on
    the utimate 64-bit version with no problems at all. All I did was ignore the
    compatibility problems and immediately run the auto updater. Afterwards, it
    never showed any compatibility messages, and it's worked with no problems at
    all.
     
    Tizzy, Aug 19, 2007
    #6
  7. Jack B

    Jack B Guest

    How do you run the auto updater? When I try to run the game, I get a
    message that the wrong disk is in. I've tried both disks and get the same
    message.
     
    Jack B, Aug 19, 2007
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.