Client Computer Name settings after upgrade

Discussion in 'Server Migration' started by Joan, Jul 6, 2004.

  1. Joan

    Joan Guest

    What do I need to do to get clients to automatically change their DNS suffix
    to match new AD domain? The suffix is not automatically changing, even after
    reboot. Have to change manually. Old suffic was abc.com, new suffix is
    us.corp.abc.com.

    No one has had problems logging on, but we do get the error that computer
    and user in different forest.
    And, because not changing, client machines not self-registering in DNS. Once
    suffix is changed manually and client rebooted, they do register. Also, some
    are registering with old suffix, so they show up in reverse zone but with
    old suffix, so they don't show up in forward zone.

    Also, the Domain Name in My Computer, Computer Name still shows the NetBIOS
    name.

    Still running NT DHCP, which is giving out DC IP correctly for DNS. Is that
    somehow related?

    Do not have any GPO configured to give out new suffix. Does that need to be
    done?

    Thanks,
    Regards,
    Joan
     
    Joan, Jul 6, 2004
    #1
    1. Advertisements

  2. Hi Joan,

    Thanks for your posting here.

    You can try to use script to change the DNS suffix:

    1. Create a file with the .vbs extension (for example, C:\add.vbs).
    2. Add the following three lines to the file:

    SET WSHShell = CreateObject("WScript.Shell")
    WSHShell.RegWrite
    "HKLM\System\CurrentControlSet\Services\TCPIP\Parameters\domain",
    "domain.com", "REG_SZ"
    WSHShell.RegWrite
    "HKLM\System\CurrentControlSet\Services\TCPIP\Parameters\NV domain",
    "domain.com", "REG_SZ"

    (the second line and third line start with "WSHShell.RegWrite" and ends
    with "REG_SZ")

    3. Double-click the file to run or at a command prompt, type "C:\add.vbs"
    (without the quotation marks)

    In addition, you can also try to use GPO.

    1. Create a new group policy at domain level.
    2. Select Computer Configuration
    3. Expand Administrative Templates
    4. Expand System
    5. Expand DNS Client
    6. Enable "Primary DNS Suffix" and type your domain DNS name.

    Wish it helps.

    Regards,
    Bob Qin
    Product Support Services
    Microsoft Corporation

    Get Secure! - www.microsoft.com/security

    ====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Bob Qin [MSFT], Jul 7, 2004
    #2
    1. Advertisements

  3. Joan

    Joan Guest

    Hi Bob,

    Thank you!

    Regards,
    Joan
     
    Joan, Jul 7, 2004
    #3
  4. My pleasure!

    Regards,
    Bob Qin
    Product Support Services
    Microsoft Corporation

    Get Secure! - www.microsoft.com/security

    ====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    ====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Bob Qin [MSFT], Jul 8, 2004
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.