Cluster service do not start after restart.

Discussion in 'Clustering' started by Jason, Aug 16, 2005.

  1. Jason

    Jason Guest

    Hi I have a compaq CL 380 cluster server with windows 2000 ad srvr installed.
    We are using MS SQL 2000 on this cluster. Yesterday we updated one node with
    the latest security patches and restarted. But after restart, the cluster
    service do no start. I get a error in the event log,..

    Event Type: Error
    Event Source: ClusSvc
    Event Category: (128)
    Event ID: 1234
    Description:
    The Cluster service account does not have the following required user rights:

    Act as part of the operating system
    Lock pages in memory
    Manage auditing and security log
    These user rights were granted to the Cluster service account during cluster
    setup and must not be removed.
    User Action
    Assign these rights to the Cluster service account. One way to do this is to
    use Local Security Settings (Secpol.msc). Another way is to edit the Group
    Policy object that is associated with the Cluster service account's user
    object in Active Directory.

    If you have already assigned these rights to the Cluster service account,
    and the user rights appear to be removed, a Group Policy object might be
    removing the rights. Check with your domain administrator to find out if this
    is happening.

    But this account has all these rights always. But still it doesn't start.
    Any idea?
     
    Jason, Aug 16, 2005
    #1
    1. Advertisements

  2. The message is always correct. Are your machines affected by group policy by
    chance? Maybe a GPO to restrict the service accounts?

    Did you change the service account by chance? Look at the computers local
    security, you will see that the message is correct.

    Cheers,

    Rod

    MVP - Windows Server - Clustering
    http://www.nw-america.com - Clustering Website
    http://www.msmvps.com/clustering - Blog
    http://www.clusterhelp.com - Cluster Training
    http://msmvps.com/clustering/archive/2005/07/20/58233.aspx NYC Clustering
    class
     
    Rodney R. Fournier [MVP], Aug 16, 2005
    #2
    1. Advertisements

  3. Jason

    Jason Guest

    Hi, I have checked both the servers . And the node which does not work, has
    the these rights but the node which works now does not have 'manage auditing
    and security log' right. Now on the DC, on defauld domain controller policy I
    have given these rights to this accout but still I get the same error message.
     
    Jason, Aug 16, 2005
    #3
  4. Rodney R. Fournier [MVP], Aug 16, 2005
    #4
  5. Jason

    Jason Guest

    Hi Thanks,
    Today morning it started working again. I this the changes I made on the
    domain controller policy took effect after some time.
     
    Jason, Aug 17, 2005
    #5
  6. Rodney R. Fournier [MVP], Aug 17, 2005
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.