Cmd: ipconfig /flushdns fails to clear/flush DNS Cache in Vista 64-bit

Discussion in 'Windows Vista General Discussion' started by Susan, Jul 28, 2009.

  1. Susan

    Susan Guest

    Vista Ultimate 64-bit; IE8; Firefox; DNS Cache...

    Before replacing my wireless-N router with a different brand/model
    wireless-G router a tech suggested clearing the DNS cache. I ran a Cmd.exe
    line as administrator and typed 'ipconfig /flushdns' and got 'Could not
    flush the DNS Resolver Cache: Function failed during execution.' MS said
    this failed because I was using Windows. I then tried the same from Safe
    Mode but it failed the same way.

    How can I successfully clear this cache? I would like to do it once just to
    be certain that there isn't some relationship between it and my old
    wireless-N router that is causing to websites that I can enter but not log
    into successfully. If clearing this cause has no effect on the problem I
    will install the new router and go from there. One other router borrowed
    passed the website logons successfully--hard wired with no router works too.

    What can you tell me about this DNS Resolver Cache? Can it get corrupted
    and/or fill up and never flushed out automatically? Thanks.
     
    Susan, Jul 28, 2009
    #1
    1. Advertisements

  2. Susan

    Flavius Guest

    1.Ipconfig command like whole internet may work only "safe mode with
    networking" and of course in normal mode not in classic "safe mode"
    see:http://www.vistax64.com/tutorials/88009-advanced-boot-options.html

    2.If this command not working you have stopped or corrupted DNS Client
    service -make sure this service is started and set to AUTO -more details
    about this service 'Windows Vista Service Pack 2 Services Information -
    DNS Client' (http://www.blackviper.com/WinVista/Services/DNS_Client.htm)
     
    Flavius, Jul 28, 2009
    #2
    1. Advertisements

  3. Susan

    Rick Rogers Guest

    Hi,

    You shouldn't have to flush the resolver cache for the switch, however to
    properly do it you must run an elevated command prompt. Type CMD into a
    start/search line, then right click the link in the menu and choose 'run as
    administrator'. Click continue at the uac prompt, then run ipconfig
    /flushdns from this prompt.
     
    Rick Rogers, Jul 28, 2009
    #3
  4. Susan

    Susan Guest

    This is simply a third different way of getting the same result I've been
    getting: 'Could not flush the DNS Resolver Cache: Function failed during
    execution.' It is proving I have a problem of some sort or am still not
    running it properly with Vista 64-bit? I haven't had a chance to look into
    the suggestions/info Flavius made in his reply--I will. Thanks.
     
    Susan, Jul 28, 2009
    #4
  5. Susan

    Susan Guest

    I just tried a fourth way, Safe Mode with Networking, and get the same
    result. I'm either not getting the right results because there is a problem
    that I need/want to correct or I'm still not running it correctly. I think
    Flavius suggesting checking the Service end of things might be a good idea.
    I've been known to upset the OS various ways in the past. I'll have to look
    into this later today--not now.
     
    Susan, Jul 28, 2009
    #5
  6. Susan

    Rick Rogers Guest

    Hi,

    Try running ipconfig /release first. then /renew afterwards.
     
    Rick Rogers, Jul 29, 2009
    #6
  7. Susan

    Susan Guest

    Flavius, you pegged this one. I found the DNS client service disabled. I
    disabled it probably after a suggestion from someone that I didn't need the
    service and that it might "speed things up" somewhere. Anyway, for the sake
    of this thread I have enabled it as 'Automatic' and 'ipconfig /flushdns' now
    produces "Successfully flushed the DNS Resolver Cache. Fixing this
    'problem' did not affect the main problem though in another thread but here
    now too: I cannot properly complete login to 'gamecrazy.com' with my current
    Netgear-N router. Thank you for your help here. I will be continuing the
    router problem in a new thread in windows.vista.networking_sharing.
     
    Susan, Jul 29, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.