Command & Conquer first decade problem

Discussion in 'Windows Vista Games' started by Stefan S, Jan 18, 2008.

  1. Stefan S

    Stefan S Guest

    Hello

    I have some problem with som games in first decade
    red allert 2 gets "fatal string error" at start and quits
    tiberian sun and generals doesn´t recognize the cd.

    I´m running windows vista home premium swedish version.


    Stefan
     
    Stefan S, Jan 18, 2008
    #1
    1. Advertisements

  2. Did you tick "Run As Administrator" in the properties (tag
    Compatibility) of the program shortcut?

    --
    @[email protected] Might, Courage, Vision, SINCERITY.
    / v \ Simplicity is Beauty! May the Force and Farce be with you!
    /( _ )\ (Xubuntu 7.04) Linux 2.6.23.14
    ^ ^ 20:13:01 up 2 days 23:02 0 users load average: 1.00 1.00 1.00
    ? ? (CSSA):
    http://www.swd.gov.hk/tc/index/site_pubsvc/page_socsecu/sub_addressesa/
     
    Man-wai Chang ToDie, Jan 18, 2008
    #2
    1. Advertisements

  3. Stefan S

    Andy [YaYa] Guest

    Heh, funny thing about Red Alert 2, it crashes, and for once it probably has
    nothing to do with Windows Vista. I used to run this pack on my Windows XP
    box and got the same crash a few minutes after starting this game.

    Look at http://support.ea.com for any patches for C&C Decade. Red Alert 2
    just crashes on some systems, not sure why.

    As for TS and Generals, I have no idea why they don't see the CD/DVD. Might
    try reinstalling the whole game on your system.

    -A.
     
    Andy [YaYa], Jan 18, 2008
    #3
  4. Stefan S

    Stefan S Guest

    Thanks a lot!!

    Red alert 2 and general works but tiberian sun still doesn´t work.
    Do you have another tip like that?
     
    Stefan S, Jan 18, 2008
    #4
  5. Stefan S

    VRG Scotty Guest

    Try Running in winxp sp2 compatibility mode
     
    VRG Scotty, Jan 18, 2008
    #5
  6. Red alert 2 and general works but tiberian sun still doesn´t work.

    I bought the C&C:Saga (which includes C&C: The First Arcade) and I could
    run all of its games, and I am using 64-bit Vi$ta Ultimate.

    Puzzling... just use Administrator to run *ALL* games. Check all
    shortcuts's compatibility tab in their properties.

    --
    @[email protected] Might, Courage, Vision, SINCERITY.
    / v \ Simplicity is Beauty! May the Force and Farce be with you!
    /( _ )\ (Xubuntu 7.04) Linux 2.6.23.14
    ^ ^ 13:19:01 up 3 days 16:08 0 users load average: 1.00 1.00 1.00
    ? ? (CSSA):
    http://www.swd.gov.hk/tc/index/site_pubsvc/page_socsecu/sub_addressesa/
     
    Man-wai Chang ToDie, Jan 19, 2008
    #6
  7. Do you have another tip like that?

    DO NOT apply the First Decade patch. It might causee C&C:General to fail
    to load under Vi$ta. :)

    --
    @[email protected] Might, Courage, Vision, SINCERITY.
    / v \ Simplicity is Beauty! May the Force and Farce be with you!
    /( _ )\ (Xubuntu 7.04) Linux 2.6.23.14
    ^ ^ 13:21:01 up 3 days 16:10 0 users load average: 1.04 1.01 1.00
    ? ? (CSSA):
    http://www.swd.gov.hk/tc/index/site_pubsvc/page_socsecu/sub_addressesa/
     
    Man-wai Chang ToDie, Jan 19, 2008
    #7
  8. Stefan S

    Franco6985 Guest

    Ok, at first I couldnt go on the game at all. Then I read the pos
    above and did run as administrator as xp or whatever

    Now I can't get on either Tiberium Sun or Yuri's Revenge. It keep
    telling me that there is no cd in the DVD-ROM when there is and othe
    games still run.

    Any help would be appreciated please :
     
    Franco6985, Feb 28, 2009
    #8
  9. Stefan S

    Fynix Guest

    I had the problems with red alert 2 and tiberian sun.

    What I did that fixed it was set program comatibility to xp sp2 (didn't
    fix it at first)...

    Then went right to the game.exe files and ran it as administrator.
    Works after that. So I think it IS a vista issue. Mind you I'm on x64 so
    that might have an effect on it....
     
    Fynix, Jul 23, 2009
    #9
  10. Stefan S

    generalWar Guest

    hi everyone
    i already install command N conquer 3, but it cant running. th
    mesaange promp
    "pls insert DVD command N conquer 3
    how i'm gonna fix thi

    genera
     
    generalWar, Oct 30, 2009
    #10
  11. Stefan S

    BuLLsh1T Guest

    Ive had same problem, I run vista ulti x64, had generals and ZH workin
    but i got the string error with ra2 and yuri's revenge
    Fix: find Ra2.exe click properties>security>special permissions>chec
    full contro
    In compatibility mode tab check run as administrator
    Same applies to the executable for yuris revenge

    Cheers
     
    BuLLsh1T, Nov 12, 2009
    #11
  12. Stefan S

    Taylorman Guest

    Ok I cant even install the first decade. WHen I hit install, it says
    setup.exe has quit working. Ive tried running it in administrator mode,
    but it still doesnt work.

    Taylor
     
    Taylorman, Mar 29, 2010
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.