companyweb and companyweb.myname.local

Discussion in 'Windows Small Business Server' started by sylvie, Jan 7, 2005.

  1. sylvie

    sylvie Guest

    Hi to all,

    first of all, excuse my english as it isn't my mother language.
    I have got an english version of SBS2003 and that's why it's easier for me
    to read this newsgroup.

    Here is my problem :
    I have set recently install my SBS and I can't reach my CompanyWeb from XP
    client (it's ok from 98 client).
    I ping the server with "companyweb.myname.local" it was ok
    I tried to connect using companyweb.myname.local and then it was ok.

    What is wrong, I checked in the client and the DNS point to the server IP.

    Many thanks for your help
    Regards
    Sylvie
     
    sylvie, Jan 7, 2005
    #1
    1. Advertisements

  2. Can you ping companyweb (by itself)?

    Is there a host header on the companyweb site that says 'companyweb'?
    There should already be a host header for 'companyweb.myname.local'. If
    there isn't one for companyweb, add it.

    Chris Puckett, MCSE
    Microsoft Small Business Server Support


    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------
     
    Chris Puckett [MSFT], Jan 7, 2005
    #2
    1. Advertisements

  3. sylvie

    sylvie Guest

    Many thanks to reply so quickly,

    I will try to give you more details but it's 9h30 in the evening I'm at home
    now I will be able to do some test only tomorrow (I'm in France).

    I have ping companyweb alone without success (I hope I speak the same : I
    did it from the "DOS" prompt), when I do it with the companyweb.myname.local
    I see the Ip of the server answering.

    If I try HTTP://companyweb I have the screen that say that it is impossible
    to see the page (no server)

    Where do I find a host header for companyweb ? Where to add it?

    Regards

    Sylvie
     
    sylvie, Jan 7, 2005
    #3
  4. If you cannot ping companyweb and see the IP of the server returned, that
    will be part of the problem.

    See if you can access http://companyweb from the server itself. If so, it
    is something on the client.
    On the client, check the IP settings of the nic, click the Advanced button,
    and click the DNS tab. Check to see if any dns suffixes are being added.
    If so, remove them and test the ping again.

    You can find the host header in the IIS MMC.
    View the properties of the companyweb site.
    On the web site tab, click the Advanced button.
    You will see the host headers on this page.

    I'll be away for the weekend, so I'll check back on Monday (US time) to see
    how it went.

    Chris Puckett, MCSE
    Microsoft Small Business Server Support


    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------
     
    Chris Puckett [MSFT], Jan 7, 2005
    #4
  5. sylvie

    sylvie Guest

    I tried from the server and I know that it work from there, I have also
    checked my nic and IP server but I didn't find what can be wrong (by the way
    I give the IP to my computer, no DHCP server)
    Anyway tomorrow is a new day maybe something will catch my eye, I will let
    you know.
    Many thanks and have a good weekend.

    Regards

    Sylvie
     
    sylvie, Jan 7, 2005
    #5
  6. Hi Sylvie,

    Although Chris is enjoying his well deserved weekend, there are plenty of
    others here who might be able to help you. Try his suggestions and post
    back.

    --
    Regards,

    Marina
    Microsoft SBS-MVP
    One of the Magical M&M's
     
    Marina Roos [SBS-MVP], Jan 8, 2005
    #6
  7. sylvie

    sylvie Guest

    Hello Marina,

    So here I am after the checking :
    No, I can't ping companyweb from clients using windows XP
    Yes, from the server it works, also from client using windows 98 se
    IP server is Ok, no dns suffixe added
    Here is what I found :
    Multiple identities for this web site
    IP address TCP port Host Header value
    server IP 80 companyweb
    server IP 80
    companyweb.myname.local


    What do you think about it ?
    Is there anything else to check?

    Sylvie
     
    sylvie, Jan 8, 2005
    #7
  8. Hi Sylvie,

    Can you post the ipconfig/all from the server and one from a client?

    --
    Regards,

    Marina
    Microsoft SBS-MVP
    One of the Magical M&M's
     
    Marina Roos [SBS-MVP], Jan 8, 2005
    #8
  9. sylvie

    sylvie Guest

    Hi Marina,
    the server write :

    Windows configuration IP :
    Host Name : Server
    Primarys DNS suffixe : myname.local
    Node type : hybrid
    IP routing enable : no
    Wins proxy enable : no
    DNS suffix search list : myname.local

    Ethernet adaptater server local area connection :
    Connection specific DNS suffix :
    description : Intel(R) pro/1000
    Physical address : 00-C0-9F-30-AA-2B
    DHCP enable : no
    IP address : IP server (type XXX.XXX.1.2)
    subnet mask : 255.255.255.0
    Default gateway : IP gateway (type XXX.XXX.1.1)
    DNS server : IP server
    Primary wins server : IP server

    the client write :

    Windows configuration IP :
    Host Name : SylviePrimarys DNS suffixe :
    Node type : hybrid
    IP routing enable : no
    Wins proxy enable : no

    Ethernet adaptater server local area connection :
    Connection specific DNS suffix :
    description : gvc-realtek ethernet 10/100
    Physical address : 00-C0-A8-82-B1-1C
    DHCP enable : no
    IP address : IP sylvie (type XXX.XXX.1.11)
    subnet mask : 255.255.255.0
    Default gateway : IP gateway (type XXX.XXX.1.1)
    DNS server : IP server


    As I'm new in such forum I don't know what is normal to write (such as IP
    address) even if it seems without any risk, so tell me if you need exact IP
    and I will give you.

    Thanks

    Sylvie
     
    sylvie, Jan 8, 2005
    #9
  10. Hi Sylvie,

    If you are using private IP's, please just post the whole ipconfig. With
    ipconfig/all>ip.txt you can copy and paste the contents of ip.txt in here.

    --
    Regards,

    Marina
    Microsoft SBS-MVP
    One of the Magical M&M's
     
    Marina Roos [SBS-MVP], Jan 8, 2005
    #10
  11. sylvie

    sylvie Guest

    Hi Marina
    I don't know exactly what you call a private IP but anyway here is the print
    of my client (sorry but it's in french, server will be in english)

    Configuration IP de Windows
    Nom de l'hôte . . . . . . . . . . : Sylvie
    Suffixe DNS principal . . . . . . :
    Type de nœud . . . . . . . . . . : Hybride
    Routage IP activé . . . . . . . . : Non
    Proxy WINS activé . . . . . . . . : Non

    Carte Ethernet Connexion au réseau local:
    Suffixe DNS propre à la connexion :
    Description . . . . . . . . . . . : GVC-REALTEK Ethernet 10/100 PCI
    Adapter
    Adresse physique . . . . . . . . .: 00-C0-A8-82-B1-1C
    DHCP activé. . . . . . . . . . . : Non
    Adresse IP. . . . . . . . . . . . : 192.168.1.11
    Masque de sous-réseau . . . . . . : 255.255.255.0
    Passerelle par défaut . . . . . . : 192.168.1.1
    Serveurs DNS . . . . . . . . . . : 192.168.1.2

    here is the print of the server :

    Windows IP Configuration
    Host Name . . . . . . . . . . . . : server
    Primary Dns Suffix . . . . . . . : myname.local
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : myname.local

    Ethernet adapter Server Local Area Connection:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
    Physical Address. . . . . . . . . : 00-C0-9F-30-AA-2B
    DHCP Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.1.2
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DNS Servers . . . . . . . . . . . : 192.168.1.2
    Primary WINS Server . . . . . . . : 192.168.1.2

    It was quickier to do that way, thanks.
    I'm going home now so I will see result from there but I will not be able to
    check anything more, so maybe I will come back to you only on monday now.

    Regards
    Sylvie
     
    sylvie, Jan 8, 2005
    #11
  12. Hi Sylvie,

    You are missing some information on the clients. It should get these from
    the SBS DHCP server automatically. Check in DHCP server, Scope options, that
    006 and 044 are pointing to the server IP 192.168.1.2. 003 should point to
    your router at 192.168.1.1. 015 should have your local AD domain name and
    046 should have 0x8.
    Let your clients get the IP and DNS automatically.

    --
    Regards,

    Marina
    Microsoft SBS-MVP
    One of the Magical M&M's
     
    Marina Roos [SBS-MVP], Jan 8, 2005
    #12
  13. I'm guessing the router is doing DHCP but the clients have manual DNS
    entries.

    Why do people try to make their life hard? :)
     
    SuperGumby [SBS MVP], Jan 8, 2005
    #13
  14. BUGGER

    Then I looked at it again, I believe 'non' is french for no, right?
     
    SuperGumby [SBS MVP], Jan 8, 2005
    #14
  15. :D Right SuperGumby. 'Non' in French is 'No' in English. "Oui" means 'Yes'.

    --
    Regards,

    Marina
    Microsoft SBS-MVP
    One of the Magical M&M's
     
    Marina Roos [SBS-MVP], Jan 8, 2005
    #15
  16. sylvie

    sylvie Guest

    Hi,
    all the client have manual IP but the routeur (netgear gd834) is not server
    of DHCP.

    Marina,
    I'm sorry to not translate but happy to see you understand it.

    I understand that your advice is to use the DHCP server from SBS.
    One more question :
    from where do I correct it (From what Ihave read on other post it seems to
    be very important to make all changes from main wisard even if it takes more
    time ?)
    I need to forbiden from some station (windows 98) to go to internet and I
    used the firewall from the router (I have only one NIC in the server SBS)
    that's why I wanted to have permanent IP on the station.


    Thanks and best regards
    Sylvie
     
    sylvie, Jan 9, 2005
    #16
  17. Hi Sylvie,

    I know how the French speak English, but your writing is absolutely clear to
    me ;-)
    Yes, SBS is much happier if it can do the DHCP serving. You can still have
    that one W98 client on a static IP, as long as it is an IP that you choose
    from the exclusion set.

    First you will have to turn off the DHCP server on the router. Then check
    the DHCP server, Scope options from ServerManagement, Advanced Management,
    Services and Applications, DHCP.

    For example your scope would be192.168.1.0 and the range would be
    192.168.1.1 - 192.168.1.254.
    There will automatically be an exclusion for the static IP's (like server,
    printer etcetera) for 192.168.1.1-192.168.1.9.
    You can add another exclusion for your static client machines.
    Then the Scope options: 003 would be pointing to your router 192.168.1.1,
    006 and 044 to your server IP 192.168.1.2, 015 would have your local AD
    domain name and 046 should have 0x8.

    Make sure the DHCP server service is set to automatic and started. You might
    have to refresh the DHCP view to get it starting.

    --
    Regards,

    Marina
    Microsoft SBS-MVP
    One of the Magical M&M's
     
    Marina Roos [SBS-MVP], Jan 9, 2005
    #17
  18. sylvie

    sylvie Guest

    Hi Marina,

    Many thanks for your advices, I will change my actual configuration (without
    any DHCP server) to a DHCP server managed by SBS.

    However, and I don't understand, all the settings in the scope was as you
    describe it has to be.

    Best regards
    Sylvie

     
    sylvie, Jan 10, 2005
    #18
  19. Hi Sylvie,

    That is just great. Than you shouldn't have any problem to start the SBS
    DHCP server when you have shut down the router DHCP. The DHCP settings have
    been setup by the SBS setup automagically ;-).

    --
    Regards,

    Marina
    Microsoft SBS-MVP
    One of the Magical M&M's

     
    Marina Roos [SBS-MVP], Jan 10, 2005
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.