Companyweb - Problems access via VPN (separate subnet)

Discussion in 'Windows Small Business Server' started by Ken-T, Feb 10, 2006.

  1. Ken-T

    Ken-T Guest

    Hi,

    On SBS Premium, Companyweb at full SQL, all is working fine from inside our
    office network, all pc's in domain, all on same subnet.
    We do not use ISA or have SBS webserver connected/publishesd to Internet.

    We have a few small external offices connected via DSL/VPN to our DSL router.
    Our net is abc.def.ghk.nnn External subnets are abc.def.zyk.nnn
    abc.def.kzk.nnn
    and so on. (last two blocks of network addresses differ to ours)

    All external users are set with correct DNS, SBS as primary, their local
    router as secondary, all set with correct local dns lookups etc.

    All works fine, they can access the Server folders, security works, can ping
    and lookup internal addresses..... but......

    None of the external users can open Companyweb or even default web page,
    either by name or IP. (even tried sites/IP's on local users IE as trusted).

    It seems that our Companyweb will only allow access from our internal subnet.

    Have checked IIS security setting for Companyweb and default web on port 80,
    both show as allow to all IP's.


    Could anyone please give a tip as to where the problem may be?


    Thanks in advance for any input.

    Ken
     
    Ken-T, Feb 10, 2006
    #1
    1. Advertisements

  2. I have the exact same problem, I can access the website from my internal
    network and OWA from the internet, I just cannot access the pages from my
    VPN's IP addresses. I acually had this all working at one point but for
    some reason its not working at all now. I know that this is not the typical
    MTU problem because I can access other websites over my VPN on the same
    network.

    Thanks!

    Chris Edwards
     
    Chris Edwards, Mar 14, 2006
    #2
    1. Advertisements

  3. Ken-T

    Ken-T Guest

    Chris,

    further testing seems to indicate that we have both a problem and a goof.

    The problem : After much testing, it seems the problem is at least partly
    due to router issues on the VPN. We are using Draytek routers set to VPN with
    L2TP/IP-SEC. Tests with the VPN set to PPTP showed no problem with HTTP
    (also tested to an Apache server inside our net) - seems that UNC file
    transfers from server shares were also more stable/faster.
    The issue can be replicated here, all good on PPTP and poor on L2TP so
    router manufacturers are looking into the matter. Will try to remember to
    post if they come up with anything.

    The goof : erm..... oops.... PC clients coming in on the VPN need to have
    Client for MS Networks enabled (yes, sorry, I did test from a pc at home with
    it disabled).
    Then check by calling by server IP rather than Companyweb (to avoid DNS
    issues).



    Ken
     
    Ken-T, Mar 14, 2006
    #3
  4. Well unfortunately this solution did not help me , I still cannot get to my
    internal webpages, maybe someone else has an idea.

    Chris Edwards
     
    Chris Edwards, Mar 15, 2006
    #4
  5. Ken-T

    Ken-T Guest

    So your VPN clients have no problem opening web pages on a non-SBS system
    inside your network? Ouch.
    Sounds like an expert needed - but in the meantime, have you tried creating
    a simple web page under IIS and seeing if VPN clients can open that?
    Also, maybe try it with firewalls/ ISA off to see if it may just be a port
    issue on client side?
     
    Ken-T, Mar 15, 2006
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.