Compatability with XP Pro and Home Networking

Discussion in 'Windows Media Center' started by MN_Wild_1, Jul 7, 2006.

  1. MN_Wild_1

    MN_Wild_1 Guest

    My home computer currently has XP Pro on it and I'm looking at purchasing a
    laptop that has Media Center Edition on it. If I purchase this, and I hook
    it up to a router, will my XP Pro computer be able to link (network) with the
    Media Center laptop? This is important for file sharing from one computer to
    the other without having to burn a CD and then switch the data manually to my
    home PC. Please let me know if this is possible. I will be purchasing the
    laptop within the week.
     
    MN_Wild_1, Jul 7, 2006
    #1
    1. Advertisements

  2. Yes, no problems at all. Especially if you create matching accounts (username and passwords) on each machine.
     
    Doug Knox MS-MVP, Jul 7, 2006
    #2
    1. Advertisements

  3. MN_Wild_1

    frankll Guest

    Doug, strange reading your reply. I'm having this very problem today. I
    believe your answer since when I first got my laptop (WXPMCE) about a week
    ago I successfully set it up on my existing wireless home network and was
    able to get files moved/shared. However, today I can't get access to MSHome
    computers over this same network. I've done some research and was able to
    ping all the computer ip addresses from each other; however, I still get the
    message Mshome not accessible ... Network path was not found. Any ideas
    about what might have happened? Thanks!
     
    frankll, Jul 17, 2006
    #3
  4. If you can ping the other computers you need to check any installed firewall (on all computers), including the Windows Firewall and ensure that File and Print sharing is allowed. Additionally, as I mentioned, having duplicate username/passwords on all machines facilitates access. You do need to actually log into the accounts, at least once.
     
    Doug Knox MS-MVP, Jul 17, 2006
    #4
  5. MN_Wild_1

    frankll Guest

    Doug, I've turned off all firewall's--Windows and third party. When I set my
    laptop up using "Network Connections" I did specify print and file sharing
    was to be allowed; however, I checked "Programs Access and Defauts" and found
    a MSWXPMCE component called "Printer and File Sharing" which was unchecked.
    I assumed this might have been the problem so I checked it, went throught the
    network connection setup again with all computers on, etc. and it did not
    resolve the problem. There appears to be a lot of discussion in other
    postings where others are having networking problems with Media Center. I am
    puzzled. As I mentioned I was able to share files without any problems. I
    wondering if there might be a problem with a recent MCE update!?

    Thanks for your continuing help!
     
    frankll, Jul 17, 2006
    #5
  6. Not that I'm aware of. I've got 3 MCE 2005 machines running here, with a mixture of XP Pro and Vista machines and I'm not seeing any problems, and all machines are fully up to date.

    Have you tried accessing the Administrative Shares? \\<machinename>\c$ and etc? By default, these are turned on, and you'll be prompted for an Administrator level username/password, unless you already have a matching username and password on the destination computer.
     
    Doug Knox MS-MVP, Jul 17, 2006
    #6
  7. And if you're using ZoneAlarm (and maybe other firewalls), you need to add
    the other PC's IP addresses to the "Trusted Zone".

    Dana Cline - MCE MVP

    If you can ping the other computers you need to check any installed firewall
    (on all computers), including the Windows Firewall and ensure that File and
    Print sharing is allowed. Additionally, as I mentioned, having duplicate
    username/passwords on all machines facilitates access. You do need to
    actually log into the accounts, at least once.

    --
    Doug Knox, MS-MVP Windows Media Center\Windows Powered Smart
    Display\Security
    Win 95/98/Me/XP Tweaks and Fixes
    http://www.dougknox.com
     
    Dana Cline - MVP, Jul 17, 2006
    #7
  8. MN_Wild_1

    frankll Guest

    Thanks Doug. While waiting I decided to try simply setting up a new
    workgroup. When I did this, I was able to access my desktop where a lot of
    the data files that I want to migrate to my new laptop. I hope this is cure
    and the last time you'll need to hear from me. I appreciate you timely
    responses and your willing to help!!!

    Lee
     
    frankll, Jul 17, 2006
    #8
  9. MN_Wild_1

    frankll Guest

    Thanks Dana. I do use ZoneAlarm on two of the three computers I'm trying to
    network and I have added the new laptop's IP address to the trusted zones on
    the others. As noted in my reply to Doug, I started over and set up a new
    workgroup and this seems to have solved my problem. Thanks for your
    willingness to help!
     
    frankll, Jul 17, 2006
    #9
  10. Glad you're up and working. Odd that you'd have to create a new workgroup, but.............
     
    Doug Knox MS-MVP, Jul 17, 2006
    #10
  11. It's weird that you had to create a new workgroup, but we'll remember that
    for future issues.

    Dana Cline - MCE MVP
     
    Dana Cline - MVP, Jul 18, 2006
    #11
  12. MN_Wild_1

    Dennis Guest

    Hi Doug,

    I just found this site and this thread. At this point I'm REALLY, REALLY
    FRUSTRATED!

    I just bought a Toshiba A105 laptop with XP MCE installed. I want to set up
    a simple LAN at home consisting of a desktop system with XP Pro installed,
    the laptop both connected to the internet through a Linksys BEFSX41 Broadband
    Firewall Router.

    Here's what I did:
    1. I'm able to connect to the internet from both systemsafter configuring
    the router.
    2. I disabled the antivirus software and Zone Alarm Pro firewall on each
    system.
    3. I used the Network Setup Wizard on each system to assign them both to
    the same workgroup.
    4. I disabled Windows Firewall and on TCP/IP under WINS I selected "Enable
    NetBIOS over TCP/IP".
    5. I enabled print and file sharing and setup a "Share" folder on each
    system.

    When I go to "Other Places" under Network Connections and select My Network
    Places on each computer and select "View Workgroup Computers" under Network
    Tasks I can see each system on the XP Pro desktop system and nothing on the
    MCE laptop only a message that says:
    "<workgroup> not accessable. You might not have permission to use this
    network resource. Contact the administrator of this server to find out if
    you have access permissions.

    I thought about doing an "upgrade" from MCE to Pro but Toshiba tells me if I
    do this, I will probably disable several of the drivers that the laptop needs
    to work, so that's out.

    If I can't make this work it looks like my only solution is to take the
    laptop back and buy one (for about $1K more!!!!) with XP Pro loaded.

    I don't get this. I consider myself to be very computer and networking
    savvy, but this blows! I hope that someone has some thoughts and/or ideas.

    The funny thing is that I bought a Mac the day before I bought the laptop
    because I wanted to get away from these type of problems associated with
    Windows,but had "buyers remorse" and returned it and got the laptop instead.
    As I tell my friends, "First thought... Best Thought."

    TIA for any help.

    Kind regards.

    The list of servers for this workgroup is not currently available."
     
    Dennis, Sep 6, 2006
    #12
  13. In a Workgroup environment:

    1) For LAN access to shared resources, use matching username/password combinations on both machines. Ensure that both accounts are logged into at least once, and that both have passwords. Blank passwords do not work by default.

    2) Disable Simple File Sharing (Windows Explorer, Tools, Folder Options, View tab and scroll all the way down). By default this is turned on in XP Pro and MCE (since its built on Pro).

    3) If you don't use matching username and password combo's you'll have to set Everyone permissions on the shared resources and use GPEDIT.MSC to change one setting. Let Everyone include Anonymous (but this is bad practice unless you really have to have it). In GPEDIT this is found in Local Computer Policy, Windows Settings, Security Settings, Local Policies, Security Options, Network Access: Let Everyone permissions apply to anonymous users.
     
    Doug Knox MS-MVP, Sep 6, 2006
    #13
  14. And once you get it working with Doug's info, when you restart Zone Alarm
    you need to go add both machines (or your entire 256-PC range) to the
    Trusted Zone.

    Dana Cline - MCE MVP
     
    Dana Cline - MVP, Sep 6, 2006
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.