Computer shows update as not been installed when update not applicable.

Discussion in 'Update Services' started by Zonky, Oct 22, 2007.

  1. Zonky

    Zonky Guest

    I have one computer in wsus 3 showing that 1 update has not been installed,
    when it is in a group that the update is not required.

    To expand on this, the computer was originally added to a group .Net 2.0 by
    mistake, and .net 2.0 was scheduled to be installed on it, downloaded and
    wasiting for its install time.

    The miustake was noticed and the computer as moved to a 1.1 .Net group.

    Since that time, it still marks 1 update as not installed (the .net 2.0)
    despite it not being approved.

    I have tried deleting the computer completely and re-adding it to the .1.1
    group with a /detectnow but this still leaves the .net 2.0 update as not
    been installed.

    How can i fix this?
     
    Zonky, Oct 22, 2007
    #1
    1. Advertisements

  2. Updates normally show as "not installed" even if they are not approved for a
    particular group. Is this not happening for the other computers in that group?
    What sort of report are you doing?

    Harry.
     
    Harry Johnston [MVP], Oct 23, 2007
    #2
    1. Advertisements

  3. Zonky

    Zonky Guest

    I should clarify. It lists .net Update as 'needed' and with a warning
    triangle in the Update Services MMC.

    In the Computer Report it says it is "not approved" and "not installed"

    It is the only update visible when i run a report for 'needed' on this
    computer.

    Z.
     
    Zonky, Oct 23, 2007
    #3
  4. Yes, that's normal. "Needed" in this context means "applicable and not
    installed" and doesn't take approvals into consideration.

    Harry.
     
    Harry Johnston [MVP], Oct 23, 2007
    #4
  5. Zonky

    DevilsPGD Guest

    In message <#> "Harry Johnston
    Horrible GUI design that... *sigh*
     
    DevilsPGD, Oct 23, 2007
    #5
  6. Zonky

    Zonky Guest

    Yet, one other member of the 1.1 .net group shows 100% and .net 2.0 as not
    installed?
     
    Zonky, Oct 23, 2007
    #6
  7. Zonky

    Zonky Guest

    That could well be the case, however, in this group, there is one other
    server, and it shows the same update as Installed/Not Applicable rather
    than Needed.

    Clearly the result is inconsistent!

    (The update is unapproved for the 1.1 Group.)

    Z.
     
    Zonky, Oct 23, 2007
    #7
  8. Yep, but it's the other machine that's behaving anomalously. Perhaps you should
    doublecheck that it hasn't inadvertently acquired .NET 2 at some point?

    ... actually I'm assuming here that the update you're refering to is the .NET
    installation itself and not one of the updates to it. What is the update title?

    What OS are the machines running?

    Harry.
     
    Harry Johnston [MVP], Oct 25, 2007
    #8
  9. Zonky

    Zonky Guest

    Hmm. Well spotted. The other machine does have .Net 2 installed, although
    it should have.

    Z.
     
    Zonky, Oct 28, 2007
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.