\\computername doesn't work (while \\ip do)

Discussion in 'Windows Vista Networking' started by tjoff, Aug 6, 2007.

  1. tjoff

    tjoff Guest

    Got a problem which I've searched for and many seem to have the same problem
    but have yet to see an answer to it.

    typing \\ip (i.e. 192.168.100.xxx) works great, every time. But typing the
    computername instead, like \\media does not.

    I got it working by disabling the firewall before and found out that the
    "Registreringstjänst för Datornamn för Windows Collaboration" (thats swedish
    - my attempt to translate it would be "Registrationsservice for computernames
    for Windows Collaboration" (not a big fan of localized software)) exception
    in the firewall resolved it.

    Problem is I restored my computer using System Restore due to a faulty
    driver and since then I haven't been able to get access to this again. Even
    with the firewall completely off.
    I have enabled file-sharing in the network properties and the \\ip do work
    (and always had).

    Don't know if something got messed up in the system restore but as said,
    this is a common problem so there should atleast be some solution to it.
     
    tjoff, Aug 6, 2007
    #1
    1. Advertisements

  2. If you can map using IP but name, this is name resolution issue. Have you enabled the NetBIOS over TCP/IP? This link may help too,

    Vista Name Resolution IssuesWindows Vista requires an open port 139 and NetBIOS enabled on the server to map a server share through a VPN connection - very poor for security! ...
    http://www.chicagotech.net/vista/vistanameissues.htm


    Bob Lin, MS-MVP, MCSE & CNE
    Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
    How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
    Got a problem which I've searched for and many seem to have the same problem
    but have yet to see an answer to it.

    typing \\ip (i.e. 192.168.100.xxx) works great, every time. But typing the
    computername instead, like \\media does not.

    I got it working by disabling the firewall before and found out that the
    "Registreringstjänst för Datornamn för Windows Collaboration" (thats swedish
    - my attempt to translate it would be "Registrationsservice for computernames
    for Windows Collaboration" (not a big fan of localized software)) exception
    in the firewall resolved it.

    Problem is I restored my computer using System Restore due to a faulty
    driver and since then I haven't been able to get access to this again. Even
    with the firewall completely off.
    I have enabled file-sharing in the network properties and the \\ip do work
    (and always had).

    Don't know if something got messed up in the system restore but as said,
    this is a common problem so there should atleast be some solution to it.
     
    Robert L [MVP - Networking], Aug 7, 2007
    #2
    1. Advertisements

  3. tjoff

    tjoff Guest

    Thanks.
    NetBIOS is enabled and haven't got to work yet.

    My workaround is typing the computernames and the corresponding IPs in the
    hosts file. An ugly "solution" that I really don't like but will have to do
    until I can fix this.
     
    tjoff, Aug 7, 2007
    #3
  4. tjoff

    tjoff Guest

    Oh, and it's not on a VPN, just an open LAN with a disabled firewall (for
    testing purposes). Still no go.
     
    tjoff, Aug 7, 2007
    #4
  5. Post back with the result of ipconfig /all may help.

    Bob Lin, MS-MVP, MCSE & CNE
    Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
    How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
    Oh, and it's not on a VPN, just an open LAN with a disabled firewall (for
    testing purposes). Still no go.
     
    Robert L [MVP - Networking], Aug 7, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.