Cookies blocked. Must accept all cookies to Sign In

Discussion in 'Internet Explorer' started by angbob, Sep 19, 2007.

  1. angbob

    angbob Guest

    I don't know what I changed recently, but IE7 started complaining that I'm
    blocking cookies. I claim I'm not.

    I stopped all antivirus and antispy software. Windows firewall is on.

    I click the Sign In button on
    http://www.microsoft.com/communities/newsgroups/en-us/. This produces the
    no-cookies complaint unless I set to accept all cookies. Even Low blocks
    cookies.

    On the Security tab in Internet Options, Internet is at Medium-high.

    I'm using Firefox to enter this post. Its "Accept cookies from sites" is on.

    Any thoughts on what I should look for?
    (Windows XP Home SP2)
     
    angbob, Sep 19, 2007
    #1
    1. Advertisements

  2. angbob

    Don Varnau Guest

    Hi,
    In the case of microsoft sites, you may have to specifically allow cookies
    from:
    msn.com
    live.com
    passport.com
    passport.net
    microsoft.com
    hotmail.com
    It may help to clear any existing cookies from those sites.

    Hope this helps,
    Don
    [MS MVP- IE]
     
    Don Varnau, Sep 19, 2007
    #2
    1. Advertisements

  3. angbob

    angbob Guest

    Thanks, Don!

    That did it. I never did anything explicit to disallow those sites, but
    somewhere along the line I must have done something implicit, e.g. install
    some anti-spy program. I'm running Spybot, WinPatrol, NOD32,
    SUPERAntispyware, and ErrorKiller.

    Incidentally, I'm using Firefox to enter this reply. When I signed in, I
    got the message "Cookies blocked. Must accept all cookies to Sign In in
    Internet Explorer General", but I'm signed in OK.

    Regards, Bob


     
    angbob, Sep 19, 2007
    #3
  4. angbob

    Joe Guest

    I am having similar problems with cookies and Internet Explorer 7. I am
    using Windows XP, still with SP 2. Recently, I started having problems on
    sites that required cookies to be activated. Things had been fine on all of
    these sites, and I did not make any changes. I even went as far as setting
    my options to accept all cookies, but this did not help. I tried using
    Firefox, and it works without a problem. Your previous response was not
    helpfult to me in that the problem is not just on Microsoft sites. It's
    happened on Amazon, TV guide, etc. Any other thoughts?

     
    Joe, Jan 7, 2009
    #4
  5. angbob

    Don Varnau Guest

    Hi,
    1. You've cleared all cookies, right?
    2. Clear the Temporary Internet Files.
    3. Make sure that the computer's date, time and time zone are correct.
    4. If you're accessing the troublesome sites via an Internet Shortcut
    (Favorites) type in the URL- bypass the Favorite. If that helps, delete the
    Favorite and create a new one.
    5. Take a close look at any third-party security/privacy programs that are
    running. See if a cookie manager/cookie blocker/privacy feature has been
    turned on. CCleaner installed? Disable its cookie manager.
    6.Access Task Manager from Ctrl-Alt-Delete. Any programs running you had
    forgotten about which might be blocking cookies?
    7. You may have a corrupted Cookies folder. Export any cookies you wish to
    save
    (IE> File> Import and Export)

    You can't delete your cookies folder when logged in as yourself. Logout then
    login as administrator or another user with administrator privileges, make
    sure that you can see hidden and system files (Folder
    Options> View) then delete the affected Cookies folder from Windows
    Explorer. Restart. Import cookies if you saved them.
    -
    Hope this helps,
    Don
    [MS MVP- IE]

     
    Don Varnau, Jan 7, 2009
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.