Could not discover the state of the system. 0x800706BE

Discussion in 'Windows Update' started by bartduncan, Nov 5, 2009.

  1. bartduncan

    bartduncan Guest

    I have a new install of Windows Server 2008 R2. I can't add or remove roles
    or features. In the event log (Apps &
    Services\Microsoft\Windows\ServerManager), I get error 1601 (see below).
    Another post
    (http://social.technet.microsoft.com...r/thread/7216345c-fc73-4bc1-9b54-dcfe224ba59e)
    with a similar error suggested that this might be due to a corrupt CBS store.
    I downloaded the System Update Readiness Tool, but the CheckSUR.log file
    says "No errors detected". Any other suggestions? I'm stuck...


    Log Name: Microsoft-Windows-ServerManager/Operational
    Source: Microsoft-Windows-ServerManager
    Date: 11/4/2009 3:07:50 PM
    Event ID: 1601
    Task Category: None
    Level: Error
    Keywords:
    Description:
    Could not discover the state of the system. An unexpected exception was found:
    System.Runtime.InteropServices.COMException (0x800706BE): The remote
    procedure call failed. (Exception from HRESULT: 0x800706BE)
    at
    System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32
    errorCode, IntPtr errorInfo)
    at Microsoft.Windows.ServerManager.ComponentInstaller.ThrowHResult(Int32
    hr)
    at
    Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package)
    at
    Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
    at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
    at Microsoft.Windows.ServerManager.Common.Provider.RefreshDiscovery()
    at Microsoft.Windows.ServerManager.LocalResult.PerformDiscovery()
    at
    Microsoft.Windows.ServerManager.ServerManagerModel.CreateLocalResult(RefreshType refreshType)
    at
    Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)
     
    bartduncan, Nov 5, 2009
    #1
    1. Advertisements

  2. bartduncan

    bartduncan Guest

    This is a clean WS 2008 R2 install. All I've done is (a) join a domain, (b)
    enable Remote Desktop, then (c) install Windows Updates.

    Possibly related: I reviewed my update history and noticed that there was
    one failed update, for "Windows Update Agent 7.4.7600.226". The details
    linked to http://support.microsoft.com/kb/949104. I downloaded the WS 2008
    R2 x64 version of this package and re-ran it, but the progress bar hung at
    ~75% after a few minutes, and it has been stuck in that state for over an
    hour. The Back/Next/Cancel buttons are all greyed out, so I can't do
    anything with the dialog.

    The system event log says that the Windows Modules Installer service crashed
    around the time that the progress bar stopped moving. The app event log
    shows these crash details:

    Faulting application name: TrustedInstaller.exe, version: 6.1.7600.16385,
    time stamp: 0x4a5bc4b0
    Faulting module name: ntdll.dll, version: 6.1.7600.16385, time stamp:
    0x4a5be02b
    Exception code: 0xc00000fd
    Fault offset: 0x00000000000529f0
    Faulting process id: 0x178
    Faulting application start time: 0x01ca5da12cff7330
    Faulting application path: C:\Windows\servicing\TrustedInstaller.exe
    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
    Report Id: 863f5e93-c995-11de-b89d-0019b9369aca
    P1: TrustedInstaller.exe
    P2: 6.1.7600.16385
    P3: 4a5bc4b0
    P4: ntdll.dll
    P5: 6.1.7600.16385
    P6: 4a5be02b
    P7: c00000fd
    P8: 0000000000055237

    I restarted the Windows Modules Installer service (it promptly crashed
    again), and shortly after that the Windows Update Agent Installer wizard
    failed with this message: "Install failed with following error number:
    0x8024000b" I don't know if the failure message is related to me restarting
    the service.
     
    bartduncan, Nov 5, 2009
    #2
    1. Advertisements

  3. bartduncan

    Peter Foldes Guest

    Peter Foldes, Nov 5, 2009
    #3
  4. [[Forwarded to WinServer General & Security via crosspost]]
     
    PA Bear [MS MVP], Nov 5, 2009
    #4
  5. bartduncan

    mathew3 Guest

    I have also a (recently installed) Windows 2008 R2 Server experiencing the
    same problem. I would reinstall the server, but the server is a second
    Domain Controller (no rolls). When I try to remove AD with dcpromo I got the
    following error:

    Installationsprogramm für die Active Directory-Domänendienste
    Es konnte nicht festgestellt werden, ob Active
    Directory-Domänendienste-Binärdateien installiert wurden. Fehler: Der
    Remoteprozeduraufruf ist fehlgeschlagen.

    That means the binary files for AD-services could not be found and then
    rpc-call has an error.

    The other symtoms are like tom@hotmail got:

    - The Role and Features tabs in servermanager display 'Error' insted
    of the usual list. Error details gives : Unexpeected error refreshing
    Server Manager: The remo procedurecall faild (Exception from HRESULT:
    0x800706BE
    - trying to list installed features in Powershell
    PS C:\Users\xxx> Import-Module servermanager
    PS C:\Users\xxx> Get-WindowsFeature
    (errors in german)
    Get-WindowsFeature : Fehler bei der Initialisierung.
    Bei Zeile:1 Zeichen:19
    + Get-WindowsFeature <<<<
    + CategoryInfo : OperationStopped: :)) [Get-WindowsFeature],
    COMException
    + FullyQualifiedErrorId :
    DiscoveryFailed,Microsoft.Windows.ServerManager.Commands.GetWindowsFeatureCommand

    In the eventlog I found this event:
    Name der fehlerhaften Anwendung: TrustedInstaller.exe, Version:
    6.1.7600.16385, Zeitstempel: 0x4a5bc4b0
    Name des fehlerhaften Moduls: ntdll.dll, Version: 6.1.7600.16385,
    Zeitstempel: 0x4a5be02b
    Ausnahmecode: 0xc00000fd
    Fehleroffset: 0x00000000000529f0
    ID des fehlerhaften Prozesses: 0xea4
    Startzeit der fehlerhaften Anwendung: 0x01ca6b60587f1e5e
    Pfad der fehlerhaften Anwendung: C:\Windows\servicing\TrustedInstaller.exe
    Pfad des fehlerhaften Moduls: C:\Windows\SYSTEM32\ntdll.dll
    Berichtskennung: a26f622d-d753-11de-92ef-000c29e27d97

    I already did run the Microsodt System readyness tool. Output:

    =================================
    Checking System Update Readiness.
    Binary Version 6.1.7600.20532
    Package Version 6.0
    2009-11-22 11:29
    Checking Windows Servicing Packages
    Checking Package Manifests and Catalogs
    Checking Package Watchlist
    Checking Component Watchlist
    Checking Packages
    Checking Component Store
    Summary:
    Seconds executed: 128
    No errors detected
    (w) Unable to get system disk
    properties 0x0000045D IOCTL_STORAGE_QUERY_PROPERTY Disk Cache

    A line in CBS.log at the time the error first occures:
    2009-11-12 18:36:34, Info CBS Failed to get session
    package state for package:
    Package_2_for_KB974571~31bf3856ad364e35~amd64~~6.1.1.1 [HRESULT = 0x80070490
    - ERROR_NOT_FOUND]

    After searching for many hours i cant find a clou on how to solve this
    issue.
     
    mathew3, Nov 22, 2009
    #5

  6. Have you tried a manual install instead?

    http://support.microsoft.com/?kbid=974571
     
    Robert Aldwinckle, Nov 22, 2009
    #6
  7. bartduncan

    M Raymond Guest

    After hours of searching it is amazing to find that others have that same
    exact problem.
    Al I did Is Join the server to the domain as a Member Server.

    Has anyone found anything yet?

     
    M Raymond, Nov 25, 2009
    #7
  8. bartduncan

    kaspik Guest

    same problem here after installing updates...

    HP DL380 G6 with proliant support pack for w2k8R2 ... no applications, just
    Hyper-V role...

    What is your configuration?

    kaspik

     
    kaspik, Nov 26, 2009
    #8
  9. bartduncan

    kaspik Guest

    And also I have installed APC PowerChute Business Edition
    Agent+Console+Server and Microsoft System Center Virtual Machine Manager Agent

    do you have anything same as me?

    kaspik

     
    kaspik, Nov 26, 2009
    #9
  10. bartduncan

    Appollo Guest

    I am seeing the exact same thing on my HyperV server and unfortuantely i need
    to get clustering going within the next few days :(

    so it looks like a reinstall arrgghh !!

    i find it hard to belive that noone at MS has any info on this though
     
    Appollo, Dec 11, 2009
    #10
  11. bartduncan

    kaspik Guest

    There is a difference in this file..
    Package_for_KB974431_RTM~31bf3856ad364e35~amd64~~6.1.1.5.mum located at
    windows\servicing\packages\

    on working servers is totally different...

    Can you someone try to change it with different one? I cannot do it, because
    it is production server, and it can be probably done only using recovery
    console or safe mode (file is locked)...

    I suppose that failure is caused by update KB974431. Maybe uninstall will
    also help, but i dont see any update in installed updates. :(.
     
    kaspik, Jan 5, 2010
    #11
  12. bartduncan

    kaspik Guest

    Problem solved...

    just replace package_for_kb974431_rtm~31bf3856ad364e35~amd64~~6.1.1.5.mum
    file located at c:\windows\servicing\packages with the same file from
    functional server. Or you can have this file from update. You can download it
    here http://support.microsoft.com/kb/974431/en-us/ and unpack it: Just rename
    Windows6.1-KB974431-x64.msu to Windows6.1-KB974431-x64.cab ... open it, open
    Windows6.1-KB974431-x64.cab inside and there you will find
    package_for_kb974431_rtm~31bf3856ad364e35~amd64~~6.1.1.5.mum

    you will also have to take ownership over old file and also you will have to
    set proper permissions on c:\windows\servicing\packages folder - in order to
    rename old file and copy the new one.

    cheers

    kaspik
     
    kaspik, Jan 12, 2010
    #12
  13. bartduncan

    D.Ilyin Guest

    D.Ilyin, Jan 29, 2010
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.