CPU Utilization of 35% + All of the time

Discussion in 'Windows Vista Performance' started by bobneedshelp, Dec 3, 2006.

  1. bobneedshelp

    bobneedshelp Guest

    I have an AMD Athlon 64 X2 Dual Core Processor 4400+ 2.2 GHz. One of the
    cores show a 3% use and the other shows a 35%+ use all of the time. I've
    turned off off-line files.

    It doesn't appear to show me what processors are using this CPU. It looks
    like in the task manager that I am only using the 3%.

    Thoughts?
     
    bobneedshelp, Dec 3, 2006
    #1
    1. Advertisements

  2. bobneedshelp

    Martin Stein Guest

    Try to click on 'show processes from all users' below in the processes tab.
    Which process is the bad one?
     
    Martin Stein, Dec 7, 2006
    #2
    1. Advertisements

  3. bobneedshelp

    bobneedshelp Guest

    Can anyone with a dual core let me know if the CPU Usage History graphs seem
    to be correct for both cores?
     
    bobneedshelp, Dec 15, 2006
    #3
  4. bobneedshelp

    bobneedshelp Guest

    I set up a test user and disconnected all devices. Basically just a stand
    alone PC. After the indexer completed, there was nothing running that I
    could see other than some basic processes. No network activity (obviously)
    and no writing to disk other than the Resource Monitor. Still it appears
    that 75% of one of the cores is being utilized by a process that isn't listed.

    Thoughts?
     
    bobneedshelp, Dec 15, 2006
    #4
  5. bobneedshelp

    Toby Broom Guest

    Tried showing processes from all users?
     
    Toby Broom, Dec 15, 2006
    #5
  6. bobneedshelp

    Toby Broom Guest

    The 100% is across both core so it will look less than the actual for that
    core.

    After this I say use Performance monitor, Form the process group add % User
    Time <All Instances>

    you can the go through 1-by-1 looking for thing with high utilization.
     
    Toby Broom, Dec 15, 2006
    #6
  7. bobneedshelp

    bobneedshelp Guest

    Process (% User Time) is 3% or less.

    Processor (% Processor Time) is 30-35% (Instance = _Total).

    I'm not familiar with the Performance Monitor. What do I look at next? It
    doesn't look like any of the Processes consume much of the CPU. It looks
    like the Total Processor time is high however.
     
    bobneedshelp, Dec 16, 2006
    #7
  8. bobneedshelp

    bobneedshelp Guest

    It looks like % Interrupt Time on core 1 is 70%. On the other core it is
    less than 3%. I guess this means that there is some device(s) like a mouse,
    disk drivers, NIC, etc. causing this issue. How can I find this?
     
    bobneedshelp, Dec 16, 2006
    #8
  9. bobneedshelp

    bobneedshelp Guest

    The Interrupts/sec is sustained over 1000. I've compared this value to
    System: Systems Calls/sec. I don't think this is a hardware issue because it
    didn't exhibit this issue with WindowsXP; therefore, I think it must be a
    driver issue. Any thoughts on how to track this down?
     
    bobneedshelp, Dec 16, 2006
    #9
  10. bobneedshelp

    Toby Broom Guest

    I suppose you can disable the devices from device manager and see if that
    has an effect on the CPU load.

    The results explain why your weren't seeing anything in task manager.

    I suspect USB things?
     
    Toby Broom, Dec 16, 2006
    #10
  11. bobneedshelp

    bobneedshelp Guest

    I removed all USB devices and disabled the items that I thought were save to
    disable. These include a RAID controller, network card, etc. The remaining
    items would be like mouse, disk drive, keyboard, video card. If I disable
    any of these, I'm not sure how to enable them.

    Any other thoughts as to what I should try next?
     
    bobneedshelp, Dec 17, 2006
    #11
  12. bobneedshelp

    Toby Broom Guest

    Still not fixed?

    I dunno then, I think your stuffed, if a clean install doesn't fix your
    problem then I suppose you need wait for some updated drivers?

    Toby
     
    Toby Broom, Dec 17, 2006
    #12
  13. bobneedshelp

    bobneedshelp Guest

    Anyone know how I can troubleshoot where the interrupts are coming from?
     
    bobneedshelp, Mar 4, 2007
    #13
  14. bobneedshelp

    bobneedshelp Guest

    I solved this issue by turning off the IEEE 1394 (firewire) port in my BIOS.
    The interrupts disappeared and the CPU utilization went down to almost
    nothing.
     
    bobneedshelp, Mar 19, 2007
    #14
  15. bobneedshelp

    bobneedshelp Guest

    I solved this issue by turning off the firewire (IEEE 1394) port in my BIOS.
     
    bobneedshelp, Mar 29, 2007
    #15
  16. bobneedshelp

    Spunkymanker Guest

    I am having the same problem here.. Vista ultimate x64, AMD X2 3800+
    processor. Everything is running sluggish, and when I look in task
    manager, the graph for core #1 shows about 2-5% utilization, and core #2
    is 95%-100%. Task manager always shows 46%-56% utilization overall,
    which would correlate with the graphs. System idle process shows 95%,
    and nothing else seems to ever take up more than 2-3% if I watch it for
    a bit. Resource monitor shows two processes taking up user time, but
    they are averaging about 3% each. Process explorer from
    microsoft/sysinternals also agrees with this, nothing shows using any
    cpu time at all. It even does this in safe mode.
    I tried disabling firewire 1394 in bios (and I was using an external fw
    drive) but that did not help. I have an ATI radeon 3850 manufactured by
    Diamond, and a netgear gigabit network adapter. No other add-on cards
    in this HP system.

    Anyone have any further ideas? I'm feeling like a reinstall with x32
    vista may be in order, but I hate doing that.
     
    Spunkymanker, May 5, 2008
    #16
  17. bobneedshelp

    sam Guest

    I also just started having this problem except I am at 50%. After abiut 3
    minutes my PC is locked up with no responses.
     
    sam, May 5, 2008
    #17
  18. bobneedshelp

    Spunkymanker Guest

    In my case, the system never locks up or shows any odd behavior other
    than just running slow. Applications take twice as long to load, games
    just don't work, and videos are choppy.
     
    Spunkymanker, May 5, 2008
    #18
  19. bobneedshelp

    Spunkymanker Guest

    Update:
    Removing my new ATI Radeon 3850 Pci-E card fixes the problem. This is
    not an acceptable solution.
    Process explorer shows that all of the cpu utilization is coming from
    hardware interrupts. I did a little more searching online, and I have
    found a "solution"
    Disabling the "Microsoft High Definition audio" device in device
    manager instantly makes cpu utilization drop to normal levels - 2-3%.
    Everything seems to be working wonderfully now.
     
    Spunkymanker, May 6, 2008
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.