Critical XP Updates from Feb. - All fail to install

Discussion in 'Windows Update' started by Confused_in_PA, Feb 14, 2005.

  1. KB888302
    KB890047
    KB873333
    KB867282
    KB891781
    KB887472
    KB888113
    KB885250

    None of these install. I tried to manual download the hotfixes and install
    them myself, but I get the following error:
    I accept the liscence agreement, etc, and it copies everything to a temp
    directory. Then when it tries to copy the file out of the temp, it can't. I
    get a standard "Setup cannot copy the file branches.inf. Ensure that the
    location specificied below is correct, or change it and insert 'Windows XP
    Hotfix Source Files' in the drive you specifiy."
    I have checked and the temporary directory does exist and does have the file
    branches.inf, which I can manually copy anywhere I want to. However, when I
    do so and then change the target location to the new copy, it still doesn't
    work.

    I'm confused and somewhat frustrated, and I'd like to get these things
    installed before I get infected with lord knows what. Anyone have any ideas?

    Thanks.
     
    Confused_in_PA, Feb 14, 2005
    #1
    1. Advertisements

  2. Confused_in_PA

    BobB Guest

    Same thing happened to me just now. Confused in CA.
     
    BobB, Feb 14, 2005
    #2
    1. Advertisements

  3. Confused_in_PA

    Orionlion82 Guest

    I third that, except its been happening to me since november, and I have 14
    updates failing
     
    Orionlion82, Feb 14, 2005
    #3
  4. The log file (I'm just posting one...they were all essentially the same) for
    KB890047 is:

    [KB890047.log]
    0.922:
    ================================================================================
    0.922: 2005/02/08 22:32:32.500 (local)
    0.922:
    C:\WINDOWS\SoftwareDistribution\Download\S-1-5-18\a49aedcb2c5d43b116b387dcf18540ae\update\update.exe (version 5.5.33.0)
    0.937: Service Pack started with following command line: /si
    /ParentInfo:f3acc2a59e71754ab674e16e47da1a65
    1.156: ---- Old Information In The Registry ------
    1.156: Source:C:\Config.Msi\b911d6.rbf (2.0.0.275)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b911de.rbf (8.0.0.912)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b911df.rbf (8.0.0.251)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b911ee.rbf (8.0.0.912)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b911f0.rbf (8.0.0.912)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b911fd.rbf (8.0.0.912)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b9120a.rbf (8.0.0.251)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b9120e.rbf (8.0.0.912)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b91217.rbf (8.0.0.912)
    1.156: Destination:
    1.156: ---- New Information In The Registry ------
    1.156: Source:C:\Config.Msi\b911d6.rbf (2.0.0.275)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b911de.rbf (8.0.0.912)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b911df.rbf (8.0.0.251)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b911ee.rbf (8.0.0.912)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b911f0.rbf (8.0.0.912)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b911fd.rbf (8.0.0.912)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b9120a.rbf (8.0.0.251)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b9120e.rbf (8.0.0.912)
    1.156: Destination:
    1.156: Source:C:\Config.Msi\b91217.rbf (8.0.0.912)
    1.156: Destination:
    1.156: SetProductTypes: InfProductBuildType=BuildType.Sel
    1.156: SetAltOsLoaderPath: No section uses DirId 65701; done.
    1.187: CreateUninstall = 1,Directory = C:\WINDOWS\$NtUninstallKB890047$
    1.187: LoadFileQueues: SetupGetSourceFileLocation for halmacpi.dll failed:
    0xe0000102
    1.187: ref tag c:\windows\system32\sp4.cab does not exist
    1.187: ref tag c:\windows\system32\sp3.cab does not exist
    1.187: ref tag c:\windows\system32\sp2.cab does not exist
    1.187: ref tag c:\windows\system32\sp1.cab does not exist
    1.187: ref tag c:\windows\system32\driver.cab does not exist
    1.187: ref tag c:\windows\system32\fp40ext.cab does not exist
    1.187: ref tag c:\windows\system32\fp40ext1.cab does not exist
    1.187: ref tag c:\windows\system32\wms4.cab does not exist
    1.187: ref tag c:\windows\system32\wms41.cab does not exist
    1.187: ref tag c:\windows\system32\ims.cab does not exist
    1.203: ref tag c:\windows\system32\ims1.cab does not exist
    1.203: ref tag c:\windows\system32\ins.cab does not exist
    1.203: ref tag c:\windows\system32\ins1.cab does not exist
    1.203: Starting AnalyzeComponents
    1.203: AnalyzePhaseZero used 0 ticks
    1.203: No c:\windows\INF\updtblk.inf file.
    1.203: OEM file scan used 0 ticks
    1.203: AnalyzePhaseOne: used 0 ticks
    1.203: AnalyzeComponents: Hotpatch analysis disabled; skipping.
    1.203: AnalyzeComponents: Hotpatching is disabled.
    1.203: FindFirstFile c:\windows\$hf_mig$\*.*
    1.203: KB890047 Setup encountered an error: The update.ver file is not
    correct.
    1.422: AnalyzeForBranching used 219 ticks.
    1.469: AnalyzePhaseTwo used 47 ticks
    1.469: AnalyzePhaseThree used 0 ticks
    1.562: AnalyzePhaseFive used 93 ticks
    1.562: AnalyzePhaseSix used 0 ticks
    1.562: AnalyzeComponents used 359 ticks
    1.562: Downloading 2 files
    1.562: bPatchMode = TRUE
    1.562: Inventory complete: ReturnStatus=0, 375 ticks
    1.562: Num Ticks for invent : 375
    1.765: [dumpDownloadTask] Update.exe posting request file to download a
    total of 588111 bytes (588111 bytes in patches and 0 bytes in fallbacks)
    1.781: [dumpDownloadTask] Returning 0xf200
    1.781: dumpDownloadTask returned 0xf200 (more files to download)
    1.828: KB890047 installation did not complete.
    1.828: Update.exe extended error code = 0xf200
    1.344:
    ================================================================================
    1.344: 2005/02/08 22:36:22.796 (local)
    1.344:
    C:\WINDOWS\SoftwareDistribution\Download\S-1-5-18\a49aedcb2c5d43b116b387dcf18540ae\update\update.exe (version 5.5.33.0)
    1.344: Service Pack started with following command line: /si
    /ParentInfo:66b3a53b8dfccd4ab5b30c3629aba3d8
    1.734: ---- Old Information In The Registry ------
    1.734: Source:C:\Config.Msi\b911d6.rbf (2.0.0.275)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b911de.rbf (8.0.0.912)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b911df.rbf (8.0.0.251)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b911ee.rbf (8.0.0.912)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b911f0.rbf (8.0.0.912)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b911fd.rbf (8.0.0.912)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b9120a.rbf (8.0.0.251)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b9120e.rbf (8.0.0.912)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b91217.rbf (8.0.0.912)
    1.734: Destination:
    1.734: ---- New Information In The Registry ------
    1.734: Source:C:\Config.Msi\b911d6.rbf (2.0.0.275)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b911de.rbf (8.0.0.912)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b911df.rbf (8.0.0.251)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b911ee.rbf (8.0.0.912)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b911f0.rbf (8.0.0.912)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b911fd.rbf (8.0.0.912)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b9120a.rbf (8.0.0.251)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b9120e.rbf (8.0.0.912)
    1.734: Destination:
    1.734: Source:C:\Config.Msi\b91217.rbf (8.0.0.912)
    1.734: Destination:
    1.734: SetProductTypes: InfProductBuildType=BuildType.Sel
    1.734: SetAltOsLoaderPath: No section uses DirId 65701; done.
    1.765: Express: 588,111 bytes were downloaded.
    2.953: [PatchFilesFromResponseBlob] returning STATUS_READY_TO_INSTALL
    3.031: KB890047 installation did not complete.
    3.031: Update.exe extended error code = 0xf201
    1.203:
    ================================================================================
    1.203: 2005/02/09 01:39:57.500 (local)
    1.203:
    C:\WINDOWS\SoftwareDistribution\Download\e85f60fa51e40d03873c40d08cf4725c\update\update.exe (version 5.5.33.0)
    1.203: Failed To Enable SE_SHUTDOWN_PRIVILEGE
    1.203: Service Pack started with following command line: /quiet /norestart
    /er /ParentInfo:ce330690f3c9ce4a94ff61ca34413159
    1.625: ---- Old Information In The Registry ------
    1.625: Source:C:\Config.Msi\b911d6.rbf (2.0.0.275)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b911de.rbf (8.0.0.912)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b911df.rbf (8.0.0.251)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b911ee.rbf (8.0.0.912)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b911f0.rbf (8.0.0.912)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b911fd.rbf (8.0.0.912)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b9120a.rbf (8.0.0.251)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b9120e.rbf (8.0.0.912)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b91217.rbf (8.0.0.912)
    1.625: Destination:
    1.625: ---- New Information In The Registry ------
    1.625: Source:C:\Config.Msi\b911d6.rbf (2.0.0.275)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b911de.rbf (8.0.0.912)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b911df.rbf (8.0.0.251)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b911ee.rbf (8.0.0.912)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b911f0.rbf (8.0.0.912)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b911fd.rbf (8.0.0.912)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b9120a.rbf (8.0.0.251)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b9120e.rbf (8.0.0.912)
    1.625: Destination:
    1.625: Source:C:\Config.Msi\b91217.rbf (8.0.0.912)
    1.625: Destination:
    1.625: SetProductTypes: InfProductBuildType=BuildType.Sel
    1.625: SetAltOsLoaderPath: No section uses DirId 65701; done.
    1.656: CreateUninstall = 1,Directory = C:\WINDOWS\$NtUninstallKB890047$
    1.656: LoadFileQueues: SetupGetSourceFileLocation for halmacpi.dll failed:
    0xe0000102
    1.687: ref tag c:\windows\system32\sp4.cab does not exist
    1.703: ref tag c:\windows\system32\sp3.cab does not exist
    1.703: ref tag c:\windows\system32\sp2.cab does not exist
    1.703: ref tag c:\windows\system32\sp1.cab does not exist
    1.703: ref tag c:\windows\system32\driver.cab does not exist
    1.703: ref tag c:\windows\system32\fp40ext.cab does not exist
    1.703: ref tag c:\windows\system32\fp40ext1.cab does not exist
    1.703: ref tag c:\windows\system32\wms4.cab does not exist
    1.703: ref tag c:\windows\system32\wms41.cab does not exist
    1.703: ref tag c:\windows\system32\ims.cab does not exist
    1.703: ref tag c:\windows\system32\ims1.cab does not exist
    1.703: ref tag c:\windows\system32\ins.cab does not exist
    1.703: ref tag c:\windows\system32\ins1.cab does not exist
    1.703: Starting AnalyzeComponents
    1.703: AnalyzePhaseZero used 0 ticks
    1.703: No c:\windows\INF\updtblk.inf file.
    1.703: OEM file scan used 0 ticks
    1.703: AnalyzePhaseOne: used 0 ticks
    1.703: AnalyzeComponents: Hotpatch analysis disabled; skipping.
    1.703: AnalyzeComponents: Hotpatching is disabled.
    1.703: FindFirstFile c:\windows\$hf_mig$\*.*
    1.703: KB890047 Setup encountered an error: The update.ver file is not
    correct.
    1.703: KB890047 Setup encountered an error: The update.ver file is not
    correct.
    1.718: KB890047 Setup encountered an error: The update.ver file is not
    correct.
    1.718: KB890047 Setup encountered an error: The update.ver file is not
    correct.
    1.718: KB890047 Setup encountered an error: The update.ver file is not
    correct.
    1.718: KB890047 Setup encountered an error: The update.ver file is not
    correct.
    2.015: AnalyzeForBranching used 297 ticks.
    2.281: AnalyzePhaseTwo used 266 ticks
    2.281: AnalyzePhaseThree used 0 ticks
    2.296: AnalyzePhaseFive used 0 ticks
    2.296: AnalyzePhaseSix used 0 ticks
    2.312: AnalyzeComponents used 609 ticks
    2.312: Downloading 0 files
    2.312: bPatchMode = TRUE
    2.312: Inventory complete: ReturnStatus=0, 656 ticks
    2.312: Num Ticks for invent : 656
    2.312: DoInstallation: LoadOrInstallBranchesInf failed to install;
    error=0x00000005.
    2.328: Access is denied.
    2.328: KB890047 installation did not complete.
    2.328: Update.exe extended error code = 0x5
     
    Confused_in_PA, Feb 14, 2005
    #4
  5. Ok, here is the fix that works for me (found after 6 hours of trawling the
    forums).

    I would still appreciate someone from Microsoft posting with some
    explanation of why this fix works/what the problem was.

    Fix:
    "KenV writes this fix which worked for me and others:

    One possibility, will take about a minute to do.

    Look in the C:\Windows\inf directory for a file called branches.inf. If there,
    right click the file, check properties, and CLEAR the read only box if
    checked. Then try to install the Windows updates to SP2.

    Ken"

    Hope this works for the rest of you guys. Good luck.
     
    Confused_in_PA, Feb 14, 2005
    #5
  6. Confused_in_PA

    Orionlion82 Guest

    YOU- Are a hero!
    I sure diddnt write protect it, but maybe well get another patch that
    unchecks the box for everyone?
    The following updates were installed successfully:


    Security Update for Windows XP (KB873339)
    Critical Update for Windows XP (KB886185)
    Security Update for Windows XP (KB885836)
    Security Update for Windows XP (KB890175)
    Security Update for Windows XP (KB885835)
    Security Update for Windows XP (KB888302)
    Security Update for Windows XP (KB890047)
    Security Update for Windows Messenger (KB887472)
    Security Update for Windows XP (KB885250)
    Security Update for Windows XP (KB891781)
    Cumulative Security Update for Internet Explorer for Windows XP (KB867282)
    Security Update for Windows XP (KB888113)
    Security Update for Windows XP (KB873333)
     
    Orionlion82, Feb 14, 2005
    #6
  7. Confused_in_PA

    trillium Guest

    I had a somewhat different experience with the same batch of updates:
    COMPLETE DISASTER!! After I rebooted, it didn't recognize the password
    I've been using so long my fingers type it automatically. After hours
    of disbelief and trying everything I could think of, I've blown the
    drive.

    I installed the new Messenger right before that; nothing else for quite
    a while. Didn't do anything else unusual.

    I typed the password in the userid box just to confirm the keys work. I
    tried userid and password for Messenger, on a lark that maybe they got
    confused. Oh, and: CAPS WAS NOT ON.
     
    trillium, Feb 14, 2005
    #7
  8. Confused_in_PA

    Jane Guest

    I am having the same problem trying to download and install the updates. I
    looked in C:\Windows\, but can't find inf dirctory or branches.inf. Jane
     
    Jane, Feb 14, 2005
    #8
  9. Hi

    It is a hidden folder, so unless you have configured Explorer
    to show hidden files and folders, you will not see it when
    browsing the file system.

    You can do the following to open the inf folder:

    From Start/Run, type this exact text:

    %windir%\inf

    and then press OK.
     
    Torgeir Bakken \(MVP\), Feb 14, 2005
    #9
  10. Confused_in_PA

    Jane Guest

    Found the file called branches, clicked properties, but the Read Only box was
    not checked. Any more ideas?
     
    Jane, Feb 14, 2005
    #10
  11. Confused_in_PA

    Byrd Guest

    I am in the same boat on a brand new Dell w OEM SP2. When I first had
    updates a few weeks ago, I found here a fix to reinstall SP2 for
    ADMIN/Programers direct from MSFT site and deleted OEM version. That worked
    for those updates. Now I am stuck unable to install new updates on 5 of
    these machines. I have tried to work around the branches.inf, but my read
    only was not checked- I tried to check, uncheck, apply, with no luck. I also
    found a post that suggested deleting exemptions to proxy server and that
    didn't help, either. Any ideas?
    Thanks
    Byrd
    I
     
    Byrd, Feb 14, 2005
    #11
  12. Confused_in_PA

    cjd Guest

    same as jane here. box was unchecked...and all of these updates either won't
    download, or the one that does download, won't install. (sorry also posted
    earlier today)
    Critical Update for Office XP on Windows XP Service Pack 2 (KB885884)
    Security Update for Windows XP (KB888302)
    Security Update for Windows XP (KB890047)
    Security Update for Windows Messenger (KB887472)
    Security Update for Windows XP (KB885250)
    Security Update for Windows XP (KB891781)
    Cumulative Security Update for Internet Explorer for Windows XP (KB867282)
    Security Update for Windows XP (KB888113)
    Security Update for Windows XP (KB873333)
    -cjd
     
    cjd, Feb 15, 2005
    #12
  13. Confused_in_PA

    airhostie Guest

    Same exact issues here in MI: I went to the Microsoft download home and
    searched each file by kb number. Click on the update for XP, when prompted
    to download select "open" not save. Will install in the right place. When
    the installer is finished, check box to prevent restart. Go back and search
    next kb number. It was somewhat time consuming,but not as bad as you would
    think. At least they are finally installed. The only one I couldn't find
    this way was KB886903 (the NET Framework security update). I did run across
    it after some searching, but can't remember how I fell into this one, sorry.
     
    airhostie, Feb 15, 2005
    #13
  14. Hi

    Error 0x80072F78 is
    ERROR_HTTP_INVALID_SERVER_RESPONSE
    The server response could not be parsed.

    Rename (or just delete) the SoftwareDistribution folder and
    see if it helps.

    You can use the procedure described here:

    http://v5.windowsupdate.microsoft.com/v5consumer/showarticle.aspx?articleid=21&ln=en

    Note that a side effect of renaming or deleting the SoftwareDistribution
    folder is that you lose your WU v5 History listing (not critical).

    (later on, you can just delete the renamed SoftwareDistribution
    folder)

    If the above didn't help:

    You might need to use proxycfg.exe (see link above) to either set or
    remove a proxy server configuration on the client, or if possible, you
    may want/need to create an anonymous access rule for Windows Update
    site on the proxy server:

    Open a command prompt (Start/Run and then "cmd.exe" without the
    quotes").

    Run this command to see what proxy configuration WU uses:

    proxycfg

    If you don't have a proxy, you will need status

    Direct access (no proxy server).


    If it reports anything else, to set direct access:

    proxycfg -d


    To get more help on proxycfg if you need to configure it to use
    a proxy server or Internet Explorer's settings:

    proxycfg -?


    If you are behind a ISA server, this one might be relevant also:

    You experience problems when you access the Windows Update Version 5
    Web site through a server that is running ISA Server
    http://support.microsoft.com/?id=885819

    and

    XP Windows Update Error 0x8024402C / 0x80072f78 when behind a
    Microsoft ISA server
    http://www.electrosonics.net/technotes/xperror0x8024402C.htm
     
    Torgeir Bakken \(MVP\), Feb 15, 2005
    #14
  15. Confused_in_PA

    Byrd Guest

    Good News, All! This worked for me:

    http://v5.windowsupdate.microsoft.com/v5consumer/showarticle.aspx?articleid=11&ln=en

    Print | Close
    When searching for available updates on the Windows Update site, you see the
    0x80248013 error

    Problem description

    This error may occur if there is a content mismatch in the DataStore or
    Download folder.

    Applicable operating systems
    • Windows 2000
    • Windows XP
    • Windows Server 2003

    Resolutions
    1. Stop the Automatic Updates service, clear the contents of the DataStore
    and Download folders, and restart the Automatic Updates service.
    1. Stop the Automatic Updates Service.
    1. Click Start.
    2. Choose Run.
    3. In the Run box, type services.msc.
    4. Click OK.
    5. Right-click the Automatic Updates service.
    6. Select Properties.
    7. Under Service status, click Stop.
    8. Click OK.
    2. Delete the Contents of the DataStore and Download folders.
    1. Click Start.
    2. Choose Run.
    3. In the Run box, type %windir%\SoftwareDistribution.
    4. Click OK.
    5. Delete the contents of both the DataStore and Download folders.
    3. Start the Automatic Updates Service
    1. Click Start.
    2. Choose Run.
    3. In the Run box, type services.msc.
    4. Click OK.
    5. Right-click the Automatic Updates service.
    6. Select Properties.
    7. Under Service status, click Start.
    8. Click OK.


    Did this resolve your problem?







    Your answer is anonymous and is used to help improve content on this site.
     
    Byrd, Feb 15, 2005
    #15
  16. Confused_in_PA

    cjd Guest

    i ran proxycfg and I'm direct
    I deleted what was in softwaredistribution folder and started stopped
    automatic update service, etc. Still get the same error...

    The following updates were not installed.
    Critical Update for Office XP on Windows XP Service Pack 2 (KB885884)
    Security Update for Windows XP (KB888302)
    Security Update for Windows XP (KB890047)
    Security Update for Windows Messenger (KB887472)
    Security Update for Windows XP (KB885250)
    Security Update for Windows XP (KB891781)
    Cumulative Security Update for Internet Explorer for Windows XP (KB867282)
    Security Update for Windows XP (KB888113)
    Security Update for Windows XP (KB873333)
     
    cjd, Feb 18, 2005
    #16
  17. Confused_in_PA

    Guttz Guest

    Try following:
    Check ReadOnly flags on WINDOWS and INF directories.
    Especially try to install with branches.inf file as not hidden(ie uncheck
    hidden file option in addition to read only).
    To me it seems either something in SP2 or in updates after SP2 all setup
    files seem to check hidden option instead of read only.
     
    Guttz, Mar 7, 2005
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.