Crysis Demo

Discussion in 'Windows Vista Games' started by vladsky, Oct 27, 2007.

  1. vladsky

    vladsky Guest

    It's a spectacular directx 10 Demo with both the 32- and 64-bit
    executables, but the 64-bit runs slightly smoother on my rig; everything
    on high, no AA -- framerate varies between 30-50 FPS.

    vladsky


    --
    vladsky

    -Life is strange, but there's nothing else [Vladsky]-
    _______________
    Asus P5K Premium
    Intel Core2Duo E6850
    Asus 8800GTS 640 megs DDR3
    4 x 2 gigs Patriot DDR2 6400 5-5-5-12
    Thermaltake ToughPower 750W
    4 x WD320 (YS) SATA2 HDD set as AHCI
    APC Back-UPS 1300XS
     
    vladsky, Oct 27, 2007
    #1
    1. Advertisements

  2. vladsky

    coolchris Guest

    Wheres the 64 bit version please?


    --
    coolchris

    *Dual Core E6550*
    *Asus P5K Motherboard*
    *2GB DDR2 800 SDRAM*
    *GForce 8600GTS 512mb*
    *Auzentech XMeridian 7.1 on Onkyo605 Rxer:cool:*
    *37" TV/Monitor @ 1360x768:eek:*
     
    coolchris, Oct 28, 2007
    #2
    1. Advertisements

  3. vladsky

    vladsky Guest

    If you did a default install, it will be the file "crysis.exe" in this
    directory:

    C:\Program Files (x86)\Electronic Arts\Crytek\Crysis SP Demo\Bin64

    (the 32-bit version is in the "Bin32" folder)

    Vladsky


    --
    vladsky

    -Life is strange, but there's nothing else [Vladsky]-
    _______________
    Asus P5K Premium
    Intel Core2Duo E6850
    Asus 8800GTS 640 megs DDR3
    4 x 2 gigs Patriot DDR2 6400 5-5-5-12
    Thermaltake ToughPower 750W
    4 x WD320 (YS) SATA2 HDD set as AHCI
    APC Back-UPS 1300XS
     
    vladsky, Oct 28, 2007
    #3
  4. vladsky

    RiverDog Guest

    Careful, this is not the experience a lot of us are having with this demo.
    Many of us with hight end rigs are not able to run at very high settings in
    DX10 and 64 bit especially with SLi. You need to make sure you have the
    169.04 driver and keep your eyes open for more updates to the driver over
    the next week or two. Also Nvidia forums have some other suggestions to help
    out. The game does look great, however.

    RiverDog
     
    RiverDog, Oct 31, 2007
    #4
  5. vladsky

    vladsky Guest


    Read what I said, I said "high", not "very high", and I added "NO"
    antialiasing.... and I run this in 1280x1024. Additionally, SLI does
    not work so far with this demo with even the 169.04 drivers.

    vladsky


    --
    vladsky

    -Life is strange, but there's nothing else [Vladsky]-
    _______________
    Asus P5K Premium
    Intel Core2Duo E6850
    Asus 8800GTS 640 megs DDR3
    4 x 2 gigs Patriot DDR2 6400 5-5-5-12
    Thermaltake ToughPower 750W
    4 x WD320 (YS) SATA2 HDD set as AHCI
    APC Back-UPS 1300XS
     
    vladsky, Oct 31, 2007
    #5
  6. Thanks for the info about the driver issue
     
    Dean O'Connell, Oct 31, 2007
    #6
  7. vladsky

    blowhead Guest

    Hi i got a problem installing the cryis demo. When the install is finished i
    got a message that i have to install a important update. Then i get
    redirected to the windows download center were i can download the driver.
    (http://www.microsoft.com/downloads/...89H7uj9LtlXOnODd60XZwMqlgqRr/w==#Instructions)
    When i do so i get a message the update isnt fit for my system (vista home
    premium 64-bit). Untill now crysis doesnt works. Help pls
     
    blowhead, Nov 2, 2007
    #7
  8. Lucky you! Even afterI upgraded to the beta Nvidia driver 169.4 I get
    nothing but a black screen and a program that does not respond. I am
    using Vista Home Premium 64bit and I have a Evga 8800 GTS video card.
    Back to Unreal Tournament. :-(

    Al
     
    Alfred Kaufmann, Nov 4, 2007
    #8
  9. vladsky

    Gaza Guest

    I'm running much the same Vista Home Premium 64bit and MSI 8800 GTS 640meg
    video card
    but run Nvidia driver 163.69, tried the beta Nvidia driver 169.4 & got the
    same black screen
    went back to 163.69 & the game was find...




    ---
    avast! Antivirus: Outbound message clean.
    Virus Database (VPS): 071107-0, 07/11/2007
    Tested on: 8/11/2007 9:10:23 PM
    avast! - copyright (c) 1988-2007 ALWIL Software.
    http://www.avast.com
     
    Gaza, Nov 8, 2007
    #9
  10. I would try 163.69 but I don't have it. :-( I just downloaded 169.09
    and still get the same black screen and no sound.

    Al
     
    Alfred Kaufmann, Nov 17, 2007
    #10
  11. I tried another beta driver and Crysis failed. I decided to uninstall
    all the Nvidia software on my system and then downloaded everything
    from the Nvidia website and re-installed. Crysis now works for me. :)
    Looks like a nice game.

    Al
     
    Alfred Kaufmann, Nov 23, 2007
    #11
  12. vladsky

    Masees2004 Guest

    I have very slaw preformance on 8800GTS with Vista any advice for???
     
    Masees2004, Nov 27, 2007
    #12
  13. vladsky

    dzomlija Guest

    I've just purchased and installed the retail of Crysis, and this puppy
    runs sweet, even with the "low end" graphics that I do have.

    Does anyone know of a built-in facility where I can benchmark it to
    determine my framerates?


    --
    dzomlija

    ____________________________________
    Peter Alexander Dzomlija
    Do you hear, huh? The Alpha and The Omega? Death and Rebirth? -And as
    you die, so shall I be Reborn-...

    - ASUS A8N32-SLI-Deluxe
    - AMD Atlon 64 Dual-Core 4800+
    - 4GB DDR400
    - 128MB ASUS nVidia 6600 PCI-Express
    - Thermaltake Tai-Chi Watercooled Chassis
    - 1207GB Total Formatted Storage
    - Vista Ultimate x64
    - CodeGear Delphi 2007'http://dzomlija.spaces.live.com/' (http://dzomlija.spaces.live.com/)
     
    dzomlija, Nov 27, 2007
    #13
  14. vladsky

    Andy [YaYa] Guest

    How much RAM?
    (Get 2gigs or more)

    How much free HD space?

    Defragged your HD recently?

    HDs are CHEAP, buy 2 of the same make, install them and setup as a RAID-0 D:
    drive, install Crysis on there so it'll load faster.

    drop your resolution? (Cheapest way)

    uninstall and get a game that isn't Crysis?

    -A.
     
    Andy [YaYa], Nov 29, 2007
    #14
  15. vladsky

    Masees2004 Guest

    I’m have problems with my sound drivers and that’s causing
    the slow performance. Thanx for the support friend.
    By the way where I live it’s not cheap to by such things even my
    PC is considered a very good one. When I bought my 8800 GTX people
    stated to talk that I must be a rich man to by stuff like this but the
    real deal is I’m not such one.


    --
    Masees2004

    3Ghz P4 CPU - 2GB ram - 500 GB storage - 8800GTS - ASUS Intel 945 PCIX
    MB. P5PL2 - X-fi Extreme Music

    Not very good spec. Will be improved soon.
     
    Masees2004, Nov 30, 2007
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.