Data Execution Protection - wth?

Discussion in 'Windows Vista Performance' started by Cuisi, Aug 12, 2008.

  1. Cuisi

    Cuisi Guest

    I have used the command prompt to disable DEP, or so I though
    (bcdedit.exe/set nx AlwaysOff). But if I use the favorites folder of
    of the start menu without starting internet explorer beforehand
    -still- get the DEP error message and IE will not start

    A minor inconvenience, granted. But how can I be getting a DEP erro
    when I have it turned off... I don't understand

    I started searching for answers and stumbled on this forum. Nice plac
    :). Wasn't sure which topic this question was for, so if this is th
    wrong one, I apologize

    Cuis
     
    Cuisi, Aug 12, 2008
    #1
    1. Advertisements

  2. Cuisi

    LeftFoot Guest

    Let me suggest that you might want to find out what's causing the DEP
    exception in the first place and correct it, instead of turning off DEP.

    From the sound of it, the problem is almost certainly being caused by an
    extension / add-on for IE7. Did you try the Manage Add-Ons dialog in IE7 yet
    to see if you can find the culprit?
     
    LeftFoot, Aug 12, 2008
    #2
    1. Advertisements

  3. Cuisi

    Cuisi Guest

    I see, I did notice (after I wrote this) that some bookmarks work
    without error. I'll look at those add-ons and try to determine what's
    going on.
     
    Cuisi, Aug 12, 2008
    #3
  4. Cuisi

    Cuisi Guest

    Well, I looked at the add-on manager, but I'm at a loss as far as tryin
    to determine which one might be the problem. I still don't understan
    how dep is shutting down IE7 when it is suposed to be off though ??
     
    Cuisi, Aug 13, 2008
    #4
  5. Cuisi

    Ian D Guest

    There's also an Execute Bit setting in BIOS for Intel CPUs. If you
    have a recent Intel CPU, did you try disabling that setting?
     
    Ian D, Aug 13, 2008
    #5
  6. Cuisi

    Brink Guest

    Hello Cuisi,

    IE7 has a separate DEP option as well for security.

    To test and see what add-on is causing this problem in IE7, see this
    tutorial.

    http://www.vistax64.com/tutorials/114310-internet-explorer-reset.html


    To turn DEP off in IE7 as well, see Option Two in this tutorial.

    http://www.vistax64.com/tutorials/120778-dep-enable-disable.html

    Hope this helps,
    Shawn


    --
    Brink

    *There are no dumb questions, just the people that do not ask
    them.*
    '*VISTA FORUMS*' (http://www.vistax64.com)
    *Please post feedback to help others.*
     
    Brink, Aug 13, 2008
    #6
  7. Cuisi

    Cuisi Guest

    Thanks for the replies. I checked the IE option and it says it is off.
    But I'm not sure if the default it is using when opening favorites is 6
    bit or 32 bit as I seem to have both versions on this system. Somethin
    else for me to look at..
     
    Cuisi, Aug 13, 2008
    #7
  8. Cuisi

    Brink Guest

    Cuisi

    It should be the 32 bit IE7 it uses by default. "C:\Program File
    (x86)\Internet Explorer\iexplore.exe"

    --
    Brin

    *There are no dumb questions, just the people that do not as
    them.*
    '*VISTA FORUMS*' (http://www.vistax64.com)
    *Please post feedback to help others.*
     
    Brink, Aug 14, 2008
    #8
  9. Cuisi

    Cuisi Guest

    Yes, you're right it is 32 by default. So I'm even more at a loss then
    I was, since I have it turned off there (as it shows in that tutorial)
    as well as having it off in the OS settings. Yet it still kicks in and
    shuts down IE 7 when I click some links in my favorites folder.

    Here is something else I noticed. It only kills it if I have no
    instance of the browser running and go straight to my favorites. If I
    have it running and go to my favorites, it starts a new browser window
    and goes straight there with no problems at all. I give up, I'll just
    start the browser before I go to my favorites I guess.
     
    Cuisi, Aug 15, 2008
    #9
  10. Cuisi

    Brink Guest

    Brink, Aug 15, 2008
    #10
  11. Cuisi

    Ian D Guest

    DEP is always on for 64 bit versions of Windows.

    Explanation here:

    http://support.microsoft.com/kb/929605
     
    Ian D, Aug 17, 2008
    #11
  12. Cuisi

    Brink Guest

    In addition, this is only for the 64 bit drivers and programs and no
    for Vista itself though

    --
    Brin

    *There are no dumb questions, just the people that do not as
    them.*
    '*VISTA FORUMS*' (http://www.vistax64.com)
    *Please post feedback to help others.*
     
    Brink, Aug 17, 2008
    #12
  13. Cuisi

    Cuisi Guest

    Well, if it is only for 64 bit apps, that leaves me as confused as ever

    But for the record, the link you posted takes me to an article abou
    RAM reporting less than 4 Gb with 4 Gb installed, nothing about DEP..
     
    Cuisi, Aug 18, 2008
    #13
  14. Cuisi

    SgtBaxter Guest

    DEP isn't only for 32 bit applications

    DEP is always on for 64 bit applications, you cannot turn it off.
    wouldn't turn it off for 32 bit apps, especially web browsers

    --
    SgtBaxte

    [email protected] - Asus P5Q Deluxe - 8GB Corsair Dominator @ 1066 - 2x 750G
    Seagate - Asus 4850 - CoolerMaster RealPower Pro 850W - Cosmos 1000
    CoolerMaster V8 CPU Cooler
     
    SgtBaxter, Aug 18, 2008
    #14
  15. Cuisi

    amlandreau Guest

    Hi Cuisi,
    As an information, on my system DEP is on for all programs and calling
    Favorites sites directly without IE loaded , does not lead to data execution
    protection alert.
    I am running Vista Ultimate + SP1 + all upates installed. Good luck for your
    quest.
    André
     
    amlandreau, Aug 18, 2008
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.