DCOM 10010 error and "Snap-In failed To initialize"

Discussion in 'Windows Server' started by Lazyl, Feb 8, 2006.

  1. Lazyl

    Lazyl Guest

    The OS is Windows server 2003 SAS.

    The following patches was installed:
    -Security Update for Windows Server 2003 (KB912919)
    - Update for Windows Server 2003 (KB910437)
    - Cumulative Security Update for Internet Explorer for Windows Server 2003
    (KB905915)
    - Security Update for Windows Server 2003 (KB908

    The software UPS Worldship 7.0 was removed.

    Several errors occur aftre this:
    Cannot run RDP.
    Cannot Open administrative tools "snap-in failed to initialize"
    And most important
    DCOM error EVENTID: 10010
    The server {BA126AE5-2166-11D1-B1D0-00805FC1270E} did not register with DCOM
    within the required timeout.

    Tried several searches but nothing matches.
     
    Lazyl, Feb 8, 2006
    #1
    1. Advertisements

  2. Lazyl

    Daytymer Guest

    Lazyl,

    I have several servers that are getting the DCOM did not register error. The
    only reference to this error is for WindowsNT and has to do with a registry
    edit. You can see this info at http://support.microsoft.com/kb/q187146/. I
    tried this on 2003 server and it does nothing.

    Here is what I did. Take the entire server id including the {} and do a
    search of the registry. This will tell you what program is causing the
    problem. In my case it was mdm.exe (machine debug manager). Open Component
    services and expand the tree to open DCOM Config. (Control
    Panel/Administrative Tools/ Component Services) Check the properties of
    whatever program you have found in the registry. On the identity tab the the
    'launching user' apply and then check you event log.

    Hope this helps. I don't have any info on the snap-in problem.

    Daytymer
     
    Daytymer, Feb 9, 2006
    #2
    1. Advertisements

  3. Lazyl

    Lazyl Guest

    That could be the answer but since I can't open DCOM Config its is impossible
    to say, it's catch 22.

    /Patrik
     
    Lazyl, Feb 10, 2006
    #3
  4. Lazyl

    Daytymer Guest

    Lazyl

    Have you tried opening it from a dos window? dcomcnfg

    Daytymer
     
    Daytymer, Feb 10, 2006
    #4
  5. Lazyl

    Daytymer Guest

    Daytymer, Feb 10, 2006
    #5
  6. Lazyl

    Lazyl Guest

    Problem solved! The file atl.dll was missing from system32, don't know what
    actually happened but restoring the file solved all of my problems.
     
    Lazyl, Feb 10, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.