dcom prob- connected to wmi prob- dcomcnfg red x in component serv

Discussion in 'Windows Small Business Server' started by monalisaj, May 3, 2005.

  1. monalisaj

    monalisaj Guest

    Oh boy- I installed I don't really know if this is what sstarted it or not
    but I installed sus on our sbs2003 which created a problem with share point
    services-do not know if that had anything to do with this problem but it
    wasn't until i did those things that I began getting a dcom error in event
    viewer: Event Type: Error
    Event Source: DCOM
    Event Category: None
    Event ID: 10010
    Date: 5/3/2005
    Time: 12:06:45 PM
    User: NT AUTHORITY\NETWORK SERVICE
    Computer: SERVER1
    Description:
    The server {73E709EA-5D93-4B2E-BBB0-99B7938DA9E4} did not register with DCOM
    within the required timeout

    I tracked the server above to be the Microsoft WMI Provider Subsystem Host
    using the dcomcnfg tool. I don't know if it was something I did there in
    maybe permissions or something else but now there is a red x in the dcomcnfg
    tool on My Computer. Also when I use the wmi control properties in my
    computer services and applications this is what I get:
    Failed to initialize all required wmi classes:
    W32_Processor: Windows Server execution failed
    Win32_WMISetting Successful
    Security Information Successful
    Win32_Operating System: Server execution failed.

    This morning while trying to fix this by uninstalling sus and sharepoint
    (the sptimer had started cpu load 100%, etc-tried the hotfix it didn't work),
    in an attempt to fix the component services problems, Exchange Server went
    down as well and the info store would not mount- I fixed Exchange- but there
    is still a problem with IIS and I need to re-install sharepoint and sus but
    can't until I fix this other problem with component services and wmi. I have
    searched the microsoft site but can't seem to find the right info- though I
    have gone through a lot of tech articles and performed the steps etc. Is
    there anybody out there that can tell me what I need to do to fix the
    underlying problems which are with wmi- dcom/component services?

    Please and Thanks. Lisa
     
    monalisaj, May 3, 2005
    #1
    1. Advertisements

  2. Hi Lisa - I've had good luck solving DCOM errors by clicking the link in the
    error message and following the recommended steps. Another good source on
    this one is
    http://eventid.net/display.asp?eventid=10010&eventno=508&source=DCOM&phase=1.
    Also, there are a couple of KBs that come up. Some mention Citrix, so if
    you're running that, search support.microsoft.com. Otherwise, a start would
    be http://support.microsoft.com/default.aspx?scid=kb;en-us;839880.

    You can search the registry for the GUID in the message, which will point
    you to the program that's generating the error.
     
    Dave Nickason [SBS MVP], May 3, 2005
    #2
    1. Advertisements

  3. monalisaj

    monalisaj Guest

    Sorry I posted thsis again because I forgot to check the box to notify me of
    replies-Lisa
    The server {73E709EA-5D93-4B2E-BBB0-99B7938DA9E4} did not register with
    I am going back in to work and will try your other suggestions as well.
    Thanks, Lisa



     
    monalisaj, May 3, 2005
    #3
  4. monalisaj

    monalisaj Guest

    The server {73E709EA-5D93-4B2E-BBB0-99B7938DA9E4} did not register with
    I am going back in to work and will try your other suggestions as well.
    Thanks, Lisa
     
    monalisaj, May 3, 2005
    #4
  5. It's in Administrative Tools -> Component Services. Expand Comonent
    Services -> Computers -> My Computer -> DCOM Config. But I might be
    misunderstanding you, because I think Run -> dcomcnfg should bring up the
    same thing. If that console won't open, you might have to troubleshoot
    that - if there's a way to set the permissions in the registry, it's not
    readily apparent to me.
     
    Dave Nickason [SBS MVP], May 4, 2005
    #5
  6. monalisaj

    monalisaj Guest

    I added the local service and network service as suggested and the dcom error
    every 5 seconds stopped almost immediately. After a few more adjustments I
    am now able to run wmi cotrol without getting the 2 errors i mentioned as
    well- after that I was able to get more errors that were showing up in event
    viewer (application and system) fixed too.
    I still have the red on my computer in component services, but even that was
    acting a bit better- I now can open the ttransaction editor as far as trying
    to open the transavtion list- I still get an error when I try to open the
    com* part of componenet servies. And I still cannot get to launch and access
    settings though the dcom component, or pull those up for each different item
    listed there. I can't remember what the error was at this time (not at work
    ight now), think it may have had something to do with a catalog. But If you
    have any more idea or suggestions for those problems I would appreciate it.
    I didn't get a chance to go through the endpoint mapper document you led me
    to but things are looking much better for the server today than they did
    yesterday, and I thank you for helping me get it this far back. Lisa
     
    monalisaj, May 4, 2005
    #6
  7. I don't have any specific suggestions to fix the problem, but what I would
    do is when you get back, search the specific error at support.microsoft.com
    and eventid.net. If there are links in the error log, don't forget to check
    those - as I've said, most of my DCOM problems have found solutions that
    way. Otherwise, post back the specifics of the error.
     
    Dave Nickason [SBS MVP], May 4, 2005
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.