dcpromo failed because domain controller name not unique

Discussion in 'Active Directory' started by bsaima, Oct 21, 2006.

  1. bsaima

    bsaima Guest

    Hi,

    I am trying to restore AD in test Lab.

    I got the backup of system state data from a DC In Live inviornment.

    In Test lab I installed server 2003 and run dcpromo and configure it as FSMO
    same like in live environnment

    I restored the AD Backup on Member server in folder c:\NTDSRestore

    Member server name is NEWDC.

    When I am trying to run DCPROMO /ADV switch

    It copy all NTDS folder and SYSVOL folder files but at the end when it try
    to restart netlogon services it gives an error 1168

    "Operation failed because domain controller name not unique".

    Any suggestions will be helpfull

    Cheers.
     
    bsaima, Oct 21, 2006
    #1
    1. Advertisements

  2. Hello,

    the Domain you created in the test lab is not the same as the product one,
    even if you put the same name.
    So, when you are restoring on the 2nd server, the existing domain is
    detected and conflicting (SID are not indenticals)

    So, You have to restore your AD Backup directly on the lab DC, or on the
    other server without any existing domain!

    Bye.
     
    Thierry DEMAN [MVP], Oct 21, 2006
    #2
    1. Advertisements

  3. bsaima

    Saima Guest

    HI Thierry,

    Many Thanks for your reply.

    But the problem is I cant restore AD on DC in test lab.

    Because hardware is not the same in test Lab and company cant efford the
    same hardware for test Lab.

    as system state contains the system and registery files along with AD.

    when I try to restore system state data it crashes the system.

    Any suggestion to overcome this problem.

    Regards,
    Saima
     
    Saima, Oct 23, 2006
    #3
  4. Hello,

    DCPROMO with ADV option allow you to restore AD from backup without
    restoring other elements from system state.

    The problem seems to be that you have prepared a destination domain before
    restoring it !

    Bye.
     
    Thierry DEMAN [MVP], Oct 23, 2006
    #4
  5. bsaima

    Saima Guest

    Hi Thierry,

    I tried it but now its giving me error related to DNS.

    error generated when server trying to contact DNS Server to locate srv
    records to locate domain controller for domain.

    The query was for the SRV record for _ldap._tcp.dc._msdcs.subsea7.net

    this server is in test lab have no connection to prod LAN.

    I am not sure How I can overcome this DNS issue.

    Any Help is highlly appreciated.

    Regards,
    Saima.
     
    Saima, Oct 23, 2006
    #5
  6. To have a functional AD, Servers must be connected to a network (Hub or
    switch !)
    The DNS service can be installed on the server and the Tcpip configuration
    must point to itself.
     
    Thierry DEMAN [MVP], Oct 23, 2006
    #6
  7. bsaima

    Saima Guest

    Hi Thierry,

    Tried That but still same error its looking for domain controller for this
    domain to authenticate user to install AD on new server.


    Regards,
    Saima.
     
    Saima, Oct 24, 2006
    #7
  8. Have you tried "authoritative restore" ?
     
    Thierry DEMAN [MVP], Oct 25, 2006
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.