Dear Microsoft - UAC (.png & wmp) issues should be addressed.

Discussion in 'Windows Vista Administration' started by JSandPC, Jun 22, 2007.

  1. Currently today I have found the search engine for this discussion website is
    broken, keeps responding to searches with "term not found".

    Hope someone reads this and knows who to contact (webmaster) to fix.

    Thanks
     
    JK of Seattle, Jan 25, 2008
    #81
    1. Advertisements

  2. JSandPC

    IkidUnot Guest

    While I'm putting together the list of stuff installed on that PC, let me say
    again that in my case the WMP problem started from one day to the next, with
    no changes made to the system (nothing had been installed for at least two
    weeks - and no windows updates, either). In fact, the way I found out that
    we had a problem wasn't with WMP, it was with Windows Movie Maker (WMM). At
    the time we were using it daily tweaking a slide show we were working on, and
    it just stopped working, so I thought there was a problem with the .wmv file
    and tried to check by using WMP.

    And Jim: I've never installed Quicktime or Bejeweled on this PC, so there
    goes a couple of possible commons.
    Since then, WMM has started working again but I don't know when that
    happened, because I hadn't tried using it probably from October until about 2
    weeks before Christmas, when I had to finish that slide show.
    Does your WMM work?

    Keep thinking...
    --
    -me.
    Let this forum know if this helps or if you figure out the problem, so
    others can benefit. As far as I know the "notify me of replies"
    does not work, so do not count on this feature.
     
    IkidUnot, Jan 26, 2008
    #82
    1. Advertisements

  3. JSandPC

    IkidUnot Guest

    Zach:

    On an "undisturbed" installation of Vista (I'm using Premium), can you tell
    us the file version info. for WMP.dll? I don't know if we'd all be so lucky
    that this would be the culprit on all of our systems, but thought it was
    worth a shot.
    I presume that there are no apps out there that would normally
    disturb/replace/etc this file (other than the ones you've mentioned). Was
    that a case where the app had included a file that was inadvertently named
    wmp.dll, or did they think they needed to update wmp.dll, and replaced it to
    do so, thus messing things up?
    --
    -me.
    Let this forum know if this helps or if you figure out the problem, so
    others can benefit. As far as I know the "notify me of replies"
    does not work, so do not count on this feature.
     
    IkidUnot, Jan 26, 2008
    #83
  4. JSandPC

    IkidUnot Guest

    Here's my list...

    Key:
    + came installed on the PC
    * installed well before problems started
    ** installed well after problems started
    ----------------------------------------
    Computer: HP dv9000c notebook
    OS: Windows Vista Home Premium +
    Adobe Flash Player ActiveX (uninstalled & newest version installed this week)
    Adobe Acrobat Reader
    Adobe Shockwave player +
    Ankh (a game - won't work on Vista, uninstalled today)
    Avira Antivir Personal Edition Classic *
    Big Kahuna Reef **
    Conexant HD Audio +
    Crazy Machines **
    Disney Pixar Ratatouille **
    DivX codec +
    Gamehouse Super Games collection
    Google Toolbar
    Google Updater
    HP stuff (all +):
    Connections
    Customer Experience Enhancements
    Easy Setup Core & Frontend
    Help and Support
    QuickLaunch Buttons 6.10 B9
    QuickPlay 3.0
    Total Care Advisor
    Update
    Wireless Assistant
    NetworkAssistant
    IrFanView *
    Java
    Kensington Mouseworks * (uninstalled)
    Luxor
    Microsoft Office Home & Student 2007 trial + (uninstalled)
    Microsoft Office Enterprise 2007
    MSXML 4.0 SP2 (KB936181)
    muvee autoProducer 5.0 +
    My HP Games (wildtangent) +
    NVIDIA drivers +
    Quilt Pro 2
    Roxio CD/DVD Basic v9 + (never worked, except the labeler app; wish I knew
    why!)
    Soft Data Fax Modem with SmartCP *
    Synaptics Pointing Device Driver (for touchpad) +


    --
    -Steve.
    Let this forum know if this helps or if you figure out the problem, so
    others can benefit. As far as I know the "notify me of replies"
    does not work, so do not count on this feature.
     
    IkidUnot, Jan 27, 2008
    #84
  5. JSandPC

    zachd [MSFT] Guest

    Thanks, that's helpful. Did you have or uninstall Norton on this system?
    That's been found on two systems so far.

    It doesn't appear to be codec related so far, knock on wood.

    The default Vista wmp.dll is 11.0.6000.6324. It would be difficult for an
    application to *replace* that directly. What one very bad app did was to
    install a private copy of wmp.dll elsewhere on the system. This shouldn't
    be the case for you - if you *did* have this problem, WMP would actually
    crash instead of not launching. You could check for this condition by
    searching for wmp.dll on your system.
     
    zachd [MSFT], Jan 27, 2008
    #85
  6. JSandPC

    JSandPC Guest

    Hi IkidUnot,

    Just tried WMM with UAC on. Worked for me.

    Thanks for your list of programs. The ones that match my situation are
    Java, the Adobe stuff, and the HP Pre-loaded stuff.

    One question for you. "Did the HP Total Care Advisor" ever stop working or
    displaying images properly? Mine did at one time and I forgot what the
    solution was, but it's working now. I was just wondering if the fix for this
    could have caused something to happen to IE and WMP.

    Thank you,

    Jim
     
    JSandPC, Jan 27, 2008
    #86
  7. JSandPC

    zachd [MSFT] Guest

    More questions:
    ===
    What is set for:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\MIME\Database\Content Type\image/x-png
    CLSID =
    Image Filter CLSID =

    HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\MIMEAssociations\image/x-png
    UserChoice =

    And for those CLSID's - which binary is associated with it?

    HKEY_CLASSES_ROOT\CLSID\{nnnnnnnn-nnnn-nnnn-nnnn-nnnnnnnnnnnn}\InprocServer32
    = ?
    ===

    Thanks for any help you can provide. =)
     
    zachd [MSFT], Jan 28, 2008
    #87
  8. JSandPC

    zachd [MSFT] Guest

    Thanks, that feedback about Norton may be interesting - that's the second
    time that's been mentioned. It looks like the codecs aren't the source of
    this so far, which is nice.

    Would you mind retrying ProcMon but this time filtering down to wmp.dll and
    mfplat.dll? Everything in wmplayer.exe seemed to look right.

    Also, I'm potentially interested in coming by with a USB memory stick to
    get:
    * your HKEY_CLASSES_ROOT registry
    * your HKEY_CURRENT_USER\Software registry
    * a full (unfiltered) ProcMon log of WMP failing (UAC on) and succeeding
    (UAC off)

    The last by itself will be massive data but likely should point to the
    culprit, knock on wood.

    It's also probably possible to ZIP or RAR those files up into more easily
    transferable packages if you want to go that route, but I don't want to
    impose. I greatly appreciate the help and data you've been providing.

    (The above requests for information are applicable to anyone hitting this
    issue, so do feel free to share if you have that data: I *am* very
    interested here.)

    Thanks,
    -Zach
     
    zachd [MSFT], Jan 28, 2008
    #88
  9. JSandPC

    zachd [MSFT] Guest

    So looking at Jim's process monitor logs, we may have found the smoking gun-
    what are the permissions for:
    HKEY_CLASSES_ROOT\
    Typelib\{6BF52A50-394A-11D3-B153-00C04F79FAA6}\1.0\0\win32
    on your system?

    On Jim's system, this was inaccessible (access denied) with UAC on. Since
    that key missing will indeed break the player, this may be the failure point
    on your system. Now, if this *is* what is broken, that only potentially
    fixes you up and doesn't necessarily figure out the source, but it would be
    a nice step forward if I'm correct in my educated guess here.

    Thanks for any information here.

    -Zach
     
    zachd [MSFT], Jan 28, 2008
    #89
  10. Zach

    See my reply to Wez dated same as this post

    Thanks for your help

    JK
     
    JK of Seattle, Jan 29, 2008
    #90
  11. WEZ:

    Thank-You for the insight to the problem I had with png images not
    displaying in IE7. This problem was also causing the stack-overflow problem
    in google maps.

    I too adjusted your entries for HKCU to mirror my HKCR\MIME registry items.
    Similar to what JSandPC did.

    Interestingly all the HKCR\MIME entries were mirrored in
    HKCU\Software\Classes\VirtualStore but none of the entries had values set :[

    If you would like to compare my registry items above to yours they are
    located at:

    http://www.yourartisans.com/png/HKCR-MIME.reg
    http://www.yourartisans.com/png/HKCU-Software-Classes-VirtualStore.reg

    Not sure what place the virtual store plays in the system.

    My updated version of your registry is located at:

    http://www.yourartisans.com/png/My-png-fix-ie7-vista.reg

    THANK-YOU Wez !! -- THANK-YOU Wez !! -- THANK-YOU Wez !!

    I'm sure this is only a bandaid for just png images, since all of the
    HKCR\MIME entries are not populated/mirrored in HKCU. But HAY! png's display,
    even in my outlook junk mail ;))

    JK
     
    JK of Seattle, Jan 29, 2008
    #91
  12. JSandPC

    zachd [MSFT] Guest

    Hm, OK - that seems like a hack designed to work around something denying
    read permissions to the HKEY_CLASSES_ROOT hive. I'm very displeased that
    something is causing this state and would love to know what is causing this
    condition.

    If you set the following registry keys:
    ======
    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Classes\Typelib\{6BF52A50-394A-11D3-B153-00C04F79FAA6}\1.0]
    @="Windows Media Player"

    [HKEY_CURRENT_USER\Software\Classes\Typelib\{6BF52A50-394A-11D3-B153-00C04F79FAA6}\1.0\0\win32]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
    00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,77,00,6d,00,\
    70,00,2e,00,64,00,6c,00,6c,00,00,00

    [HKEY_CURRENT_USER\Software\Classes\Typelib\{6BF52A50-394A-11D3-B153-00C04F79FAA6}\1.0\FLAGS]
    @="0"
    ===
    , can you then access Windows Media Player normally?

    Given the data on the PNG issue, this would potentially tie together:
    something is causing HKCR reads to fail for the UAC'd user, and the current
    newsgroup solutions are to simply hack around this failure.

    My registry suggestion above is rather a hack - it's just to determine if
    I'm correct in my diagnosis so far. But if I'm right, it should actually
    work. I do not recommend anyone set this on a machine that does *not* have
    this problem, as setting HKCU\Software\Classes setting is generally a very
    very bad idea, and this is no exception.

    -Zach

     
    zachd [MSFT], Jan 30, 2008
    #92
  13. JSandPC

    zachd [MSFT] Guest

    OK, we have initial verification now on Jim's machine that this hack does
    actually fix the "Windows Media Player not working under UAC" issue. Can
    anyone else confirm?

    Thus we now get into: who or what is locking down access to:
    HKEY_CLASSES_ROOT\ Typelib\{6BF52A50-394A-11D3-B153-00C04F79FAA6}
    ? I'm assuming there is some common set of bad or removed software on
    machines with this problem. As far as I'm aware, the permissions on this
    key and subkeys are correct(?).

    I would be very interested in knowing the installed and uninstalled set of
    software of machines that encounter this problem to understand what might be
    the actual culprit here.



     
    zachd [MSFT], Jan 30, 2008
    #93
  14. JSandPC

    JSandPC Guest

    I have a question for everyone.

    Did your computer come pre-loaded with Norton Internet Security Suite?

    If you uninstalled it, was it uninstalled using the traditional "Add/Remove"
    or did you use the special "Norton Removal Tool" found online from Symantec?

    Jim
     
    JSandPC, Jan 30, 2008
    #94
  15. JSandPC

    LuvMyLaptop Guest

    My laptop, HP dv9000 with Vista Home Premium purchased mid-Feb
    2007, came loaded with Norton Internet Security. My husband removed it with
    the Norton Removal Tool, and some other 'helpers' which he cannot remember at
    this time. As you probably know, Norton is terrible to try and get out of
    your system. Once it was removed, we installed Trend Micro. My problems
    with .png images not displaying probably started happening a month or so
    after Norton was removed. I don't remember the exact time frame.

    Sorry I don't interact much with your discussions - I am much more of a
    novice than proficient when it comes to discussing the 'guts' of the pc. But
    I have been reading every post and am hoping for a positive resolution to
    this problem soon. I have been using Firefox, but I would reallly rather go
    back to IE7 if this ever gets resolved. One thing I do find interesting is
    that my husband's user account on my laptop does not have any problems
    whatsoever.....
     
    LuvMyLaptop, Jan 31, 2008
    #95
  16. Norten came pre-installed for trial period, then I removed it (add/remove)
    when it started asking for money. It was constantly getting in my way. Is
    there a special tool ? If so then the add/remove avenue should have alerted
    user of the need for the special tools, right ? Otherwise pooh pooh on
    symantec.

    JK
     
    JK of Seattle, Jan 31, 2008
    #96
  17. Zach

    I do not have a problem with wmp, so I did not attemp the reg entries. I'm
    confident enough to make IE7 my default browser again. But I'm concerned that
    the registry Hack I modified from Wez is just a band-aid to what was
    corrupted by an as yet identified application overwriting the registry during
    add/remove/update of an application.

    JK

     
    JK of Seattle, Jan 31, 2008
    #97
  18. JSandPC

    IkidUnot Guest

    Jim:

    1) I'm not much of the type to use HP Total Care Advisor types of things, so
    I couldn't tell you if it stopped working or not. From the few times that
    I've run it, I can tell you that I didn't see anything that looked out of the
    ordinary.

    2) Since you've got an HP, I'll assume that mine also came with Norton
    installed, but to be honest, I just can't remember. I'll have to go back and
    look at the list of stuff that's in the software directory when I'm in front
    of that computer.
    I can tell you that I would have un-installed that software pretty much
    right after turning on the computer out of the box (don't care for it, in
    case you can't tell). Since I'm unaware of a tool from Symantec to perform
    the removal (til now), I would have used the Windows normal method (the
    artist formerly known as "Add/Remove Programs").
    Can you tell us more about Symantec's removal tool, namely:
    What's the difference between removing with this tool vs uninstalling the
    "normal" way?
    Would it be beneficial to run the tool "a long time" after having removed
    the NIS suite?

    (slightly ot: I assume your system also came with Roxio CD/DVD Basic v9.
    Did this ever work on your computer? I'd like to figure out why this won't
    work on mine.)
     
    IkidUnot, Feb 12, 2008
    #98
  19. JSandPC

    JSandPC Guest

    Steve,

    Thanks for the follow-up info. I dont think using the Norton Uninstall tool
    would have any benefit at this point. I only asked that question, because I
    used the tool and was having the .png/wmp issue. Others have indicated that
    they uninstalled using either/or/both methods (Add/Remove and/or Tool), so I
    dont think one has any advantage over the other. Furthermore, we're not even
    sure what program caused this issue. I was just grasping at straws to see
    what may have caused the issue.

    As far as Roxio, mine opens up fine and it appears I can access all the
    utilities. I did not attempt to burn a cd/dvd, but I opened and played
    around with the "Creator Basic", "Express Labeler", and "MyDVD Basic V9".
    They all opened. Is your problem with opening the applications? If not, let
    me know what your issue was and I will try to duplicate it on mine.

    This HP/Compaq and Vista has been virtually flawless, with the exception of
    the .png/wmp issue. Now that Zach is involved, that does not seem to be much
    of an issue anymore. We "band-aided" the problem by copying certain Root
    keys to the HKCU. It's not a permanent fix, but now I have .png's in IE and
    WMP opens without a hitch. Well...I guess it is a permanent fix for me,
    because the fact that our fix was a "band-aid" is transparent to me. I have
    been running with UAC enabled for about 3 weeks now and no worries.

    Jim
     
    JSandPC, Feb 13, 2008
    #99
  20. JSandPC

    zachd [MSFT] Guest

    Right now I'm most interested in anybody *new* who's hitting the problem.
    Hopefully you all are the last vestiges of the problem. *knock on wood*
     
    zachd [MSFT], Feb 13, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.