Debug Remote machine (windows server 2008 installed) with fire wir

Discussion in 'Windows Vista Drivers' started by ariels, Nov 19, 2008.

  1. ariels

    ariels Guest

    I am trying to debug my driver via windbg on remote machine :
    Here some details :
    1. Host machine : windows xp is installed and the fire wire is recognized as
    host controller.
    2. Test machine :
    2.1 windows 2008 installed.
    2.2 The Windows Boot Loader is configured to boot : (via bcdedit tool)
    2.2.1 debug : enabled
    2.2.2 debugtype : 1394
    2.2.3 channel : 10
    The problem i am facing with is that :
    windows fails to load the fire wire device driver when its (OS) configured
    to work in debug mode.

    NOTE : if i am not changing the OS Boot Loader , the OS successfuly loads
    the fire wire device driver as host controller.

    Please advice .
    Thanks,
    Smutko Ariel.
     
    ariels, Nov 19, 2008
    #1
    1. Advertisements

  2. ariels

    Don Burn Guest

    If you make the debug 1394 the OS takes the firewire controller for
    debugging this is expected behavior. So if you are trying to debug a
    firewire device, use serial for debugging.


    --
    Don Burn (MVP, Windows DDK)
    Windows Filesystem and Driver Consulting
    Website: http://www.windrvr.com
    Blog: http://msmvps.com/blogs/WinDrvr
    Remove StopSpam to reply
     
    Don Burn, Nov 19, 2008
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.